summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-03-25 14:09:18 +0000
committerMark Wright <gienah@gentoo.org>2012-03-25 14:09:18 +0000
commitf549a2958af95b7a080eb80b9bc8dc0c92b1b9a7 (patch)
tree6b1d88fe0e8fc1e974f70b9feedebc3cdf33fe5f /sci-mathematics
parentMarking Module-Implementation-0.60.0 ~ppc for bug 403413 (diff)
downloadhistorical-f549a2958af95b7a080eb80b9bc8dc0c92b1b9a7.tar.gz
historical-f549a2958af95b7a080eb80b9bc8dc0c92b1b9a7.tar.bz2
historical-f549a2958af95b7a080eb80b9bc8dc0c92b1b9a7.zip
Add agda-executable, Command-line program for type-checking and compiling Agda programs.
Package-Manager: portage-2.1.10.51/cvs/Linux x86_64
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/agda-executable/ChangeLog12
-rw-r--r--sci-mathematics/agda-executable/Manifest16
-rw-r--r--sci-mathematics/agda-executable/agda-executable-2.3.0.1.ebuild32
-rw-r--r--sci-mathematics/agda-executable/agda-executable-2.3.0.ebuild32
-rw-r--r--sci-mathematics/agda-executable/metadata.xml13
5 files changed, 105 insertions, 0 deletions
diff --git a/sci-mathematics/agda-executable/ChangeLog b/sci-mathematics/agda-executable/ChangeLog
new file mode 100644
index 000000000000..28a5668815e4
--- /dev/null
+++ b/sci-mathematics/agda-executable/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for sci-mathematics/agda-executable
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda-executable/ChangeLog,v 1.1 2012/03/25 14:09:18 gienah Exp $
+
+*agda-executable-2.3.0 (25 Mar 2012)
+*agda-executable-2.3.0.1 (25 Mar 2012)
+
+ 25 Mar 2012; Mark Wright <gienah@gentoo.org> +agda-executable-2.3.0.1.ebuild,
+ +agda-executable-2.3.0.ebuild, +metadata.xml:
+ Add agda-executable, Command-line program for type-checking and compiling Agda
+ programs.
+
diff --git a/sci-mathematics/agda-executable/Manifest b/sci-mathematics/agda-executable/Manifest
new file mode 100644
index 000000000000..fefd9547df42
--- /dev/null
+++ b/sci-mathematics/agda-executable/Manifest
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+DIST Agda-executable-2.3.0.1.tar.gz 1765 RMD160 47de80d448ebceee0e621730f7d1c45fdb068538 SHA1 cacbb5508fb6d870e7ddf7edb8198aa3cda380ef SHA256 614594c414c828c87abb1913741db66447c09617d57b92e58ffe445ceffed694
+DIST Agda-executable-2.3.0.tar.gz 1764 RMD160 39a4420fa9f0402aab972c5be49872bf0d705e3d SHA1 00c1009861e3ac419453c658a4e4488fb844e0a9 SHA256 b75ce406ac9343dbc10a221f7552df2d5ddccc8ef38359d33465c02dbe992ad8
+EBUILD agda-executable-2.3.0.1.ebuild 790 RMD160 092404f897d09abd5650d04d4c24bb2cb1ae31cc SHA1 ad2923ea719219d0cfc86c9709fdbd0b3bd9beeb SHA256 53dc26830f4747b207ffc8a3f701d2848dd2ad0bc39019b4af8f7ba6cf39b989
+EBUILD agda-executable-2.3.0.ebuild 788 RMD160 e6b4753ec8382f64f485883a8141fd26bd450fd4 SHA1 e8650b9e249597524af1caae3f3b74458ec922a2 SHA256 027a786e6c6f61405e254eec41e97a6595e51c8e73227bf5da5a03ae4239a5f9
+MISC ChangeLog 534 RMD160 555826f112c0e938c3d72830df64b87f5238cbac SHA1 ad886470dd32319dddef819f94100056fa577ac5 SHA256 08a1a371c52bdd6ff1fcc5fe485642ea2e1589a98e358ff30a28ae1afe4debea
+MISC metadata.xml 448 RMD160 1052bf58a1666d8eee400a09194a7ab4cf80ab09 SHA1 3e70b33405eb43387da13d7fffdff9ca9bf3bc25 SHA256 5e3aedaf07222facb5978ed2def421d74b635e23d66259ea5054abb89c80b6c7
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iF4EAREIAAYFAk9vJxwACgkQoBEVQmGOlx/EOAD+OvQeCKJ7yg++1UYxsxDOJxcr
+6TvQZ0Yr1uA003Jv9mcA/0WFbx3EqxVo6V0RWRy0kX7U0L63yIhzRN1tRqI/PcUW
+=y52+
+-----END PGP SIGNATURE-----
diff --git a/sci-mathematics/agda-executable/agda-executable-2.3.0.1.ebuild b/sci-mathematics/agda-executable/agda-executable-2.3.0.1.ebuild
new file mode 100644
index 000000000000..b843dfac1904
--- /dev/null
+++ b/sci-mathematics/agda-executable/agda-executable-2.3.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda-executable/agda-executable-2.3.0.1.ebuild,v 1.1 2012/03/25 14:09:18 gienah Exp $
+
+EAPI="4"
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal eutils
+
+MY_PN="Agda-executable"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Command-line program for type-checking and compiling Agda programs"
+HOMEPAGE="http://wiki.portal.chalmers.se/agda/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ ~sci-mathematics/agda-${PV}
+ >=dev-haskell/cabal-1.8
+ >=dev-lang/ghc-6.8.2"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ cabal-mksetup
+}
diff --git a/sci-mathematics/agda-executable/agda-executable-2.3.0.ebuild b/sci-mathematics/agda-executable/agda-executable-2.3.0.ebuild
new file mode 100644
index 000000000000..fd6101ad6f37
--- /dev/null
+++ b/sci-mathematics/agda-executable/agda-executable-2.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda-executable/agda-executable-2.3.0.ebuild,v 1.1 2012/03/25 14:09:18 gienah Exp $
+
+EAPI="3"
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal eutils
+
+MY_PN="Agda-executable"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Command-line program for type-checking and compiling Agda programs"
+HOMEPAGE="http://wiki.portal.chalmers.se/agda/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ ~sci-mathematics/agda-2.3.0
+ >=dev-haskell/cabal-1.8
+ >=dev-lang/ghc-6.8.2"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ cabal-mksetup
+}
diff --git a/sci-mathematics/agda-executable/metadata.xml b/sci-mathematics/agda-executable/metadata.xml
new file mode 100644
index 000000000000..58fbc0e32043
--- /dev/null
+++ b/sci-mathematics/agda-executable/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This package provides a command-line program for type-checking and
+ compiling Agda programs. The program can also generate hyperlinked,
+ highlighted HTML files from Agda sources.
+ </longdescription>
+</pkgmetadata>