summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-08-24 12:14:06 +0000
committerTravis Tilley <lv@gentoo.org>2004-08-24 12:14:06 +0000
commit6af3f53696a6032f751086f980872e09b6a0aefd (patch)
tree996e10bb13e3440bd8e3beb76aa7a762f1ec4d00 /skel.ebuild
parentmark 009 stable, add 009.1 (diff)
downloadhistorical-6af3f53696a6032f751086f980872e09b6a0aefd.tar.gz
historical-6af3f53696a6032f751086f980872e09b6a0aefd.tar.bz2
historical-6af3f53696a6032f751086f980872e09b6a0aefd.zip
added mention of inherit to skel.ebuild... though it's amazing there wasnt mention of it already
Diffstat (limited to 'skel.ebuild')
-rw-r--r--skel.ebuild15
1 files changed, 15 insertions, 0 deletions
diff --git a/skel.ebuild b/skel.ebuild
index 2e4b724ada39..27b93a6b9f03 100644
--- a/skel.ebuild
+++ b/skel.ebuild
@@ -11,6 +11,20 @@
# will be committed to cvs, the details on that line will be automatically
# generated to contain the correct data.
+# inherit lists eclasses to inherit functions from. Almost all ebuilds should
+# inherit eutils, as a large amount of important functionality has been
+# moved there. For example, the $(get_libdir) mentioned below wont work
+# without the following line:
+inherit eutils
+# A well-used example of an eclass function that needs eutils is epatch. If
+# your source needs patches applied, it's suggested to put your patch in the
+# 'files' directory and use:
+#
+# epatch ${FILESDIR}/patch-name-here
+#
+# eclasses tend to list descriptions of how to use their functions properly.
+# take a look at /usr/portage/eclasses/ for more examples.
+
# Short one-line description of this package.
DESCRIPTION="This is a sample skeleton ebuild file"
@@ -134,6 +148,7 @@ src_install() {
# prefix=${D}/usr \
# mandir=${D}/usr/share/man \
# infodir=${D}/usr/share/info \
+ # libdir=${D}/usr/$(get_libdir) \
# install || die
# Again, verify the Makefiles! We don't want anything falling
# outside of ${D}.