summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-05-18 17:25:12 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-05-18 17:25:12 +0000
commit81b1cd2d2122a8e6aaa2d0f673baba037596855a (patch)
tree70e5cdc1428976cb0cffaee39ba86f8e420d842e /skel.ebuild
parentchase latest release (diff)
downloadhistorical-81b1cd2d2122a8e6aaa2d0f673baba037596855a.tar.gz
historical-81b1cd2d2122a8e6aaa2d0f673baba037596855a.tar.bz2
historical-81b1cd2d2122a8e6aaa2d0f673baba037596855a.zip
Changed the order in which the environment variables appear to a
more human-friendly one.
Diffstat (limited to 'skel.ebuild')
-rw-r--r--skel.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/skel.ebuild b/skel.ebuild
index f22d557ba15f..02c00bccad9f 100644
--- a/skel.ebuild
+++ b/skel.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /home/cvsroot/gentoo-x86/skel.ebuild,v 1.5 2002/04/29 22:56:53 sandymac Exp $
+# $Header: /home/cvsroot/gentoo-x86/skel.ebuild,v 1.6 2002/05/07 03:58:19 drobbins Exp $
# NOTE: The comments in this file are for instruction and documentation.
# They're not meant to appear with your final, production ebuild. Please
@@ -11,19 +11,9 @@
# will be commited to cvs, the details on that line will be automatically
# generated to contain the correct data.
-# Source directory; the dir where the sources can be found (automatically
-# unpacked) inside ${WORKDIR}. S will get a default setting of ${WORKDIR}/${P}
-# if you omit this line.
-
-S=${WORKDIR}/${P}
-
# Short one-line description of this package.
DESCRIPTION="This is a sample skeleton ebuild file"
-# Point to any required sources; these will be automatically downloaded by
-# Portage.
-SRC_URI="ftp://foo.bar.com/${P}.tar.gz"
-
# Homepage, not used by Portage directly but handy for developer reference
HOMEPAGE="http://"
@@ -44,6 +34,16 @@ DEPEND=""
# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
#RDEPEND=""
+# Point to any required sources; these will be automatically downloaded by
+# Portage.
+SRC_URI="ftp://foo.bar.com/${P}.tar.gz"
+
+# Source directory; the dir where the sources can be found (automatically
+# unpacked) inside ${WORKDIR}. S will get a default setting of ${WORKDIR}/${P}
+# if you omit this line.
+
+S=${WORKDIR}/${P}
+
src_compile() {
# Most open-source packages use GNU autoconf for configuration.
# You should use something similar to the following lines to