summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-11-18 16:58:35 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-11-18 16:58:35 +0000
commit0a921cfb04a916981fba2a4557e7c0b34d5ccca8 (patch)
tree1dd257f399086546048a8b7ebbd492019e029ca9 /sys-apps/dchroot/dchroot-0.12.1.ebuild
parentNon-maintainer commit. Fix building with _FORTIFY_SOURCE=2 and recent gnutls ... (diff)
downloadhistorical-0a921cfb04a916981fba2a4557e7c0b34d5ccca8.tar.gz
historical-0a921cfb04a916981fba2a4557e7c0b34d5ccca8.tar.bz2
historical-0a921cfb04a916981fba2a4557e7c0b34d5ccca8.zip
Respecting CC variable, respecting LDFLAGS, bug #293575
Package-Manager: portage-2.1.6.13/cvs/Linux i686
Diffstat (limited to 'sys-apps/dchroot/dchroot-0.12.1.ebuild')
-rw-r--r--sys-apps/dchroot/dchroot-0.12.1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/sys-apps/dchroot/dchroot-0.12.1.ebuild b/sys-apps/dchroot/dchroot-0.12.1.ebuild
index b3f6b816127a..181a56992b61 100644
--- a/sys-apps/dchroot/dchroot-0.12.1.ebuild
+++ b/sys-apps/dchroot/dchroot-0.12.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dchroot/dchroot-0.12.1.ebuild,v 1.1 2007/07/08 21:37:19 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dchroot/dchroot-0.12.1.ebuild,v 1.2 2009/11/18 16:58:35 vostorga Exp $
+
+inherit toolchain-funcs
DESCRIPTION="Utility for managing chroots for non-root users"
HOMEPAGE="http://packages.debian.org/unstable/admin/dchroot"
@@ -20,9 +22,15 @@ src_unpack() {
sed -i \
-e '/^all:/s:$: docs:' \
-e '/^CFLAGS/s:-O2:@CFLAGS@:' \
+ -e '/@CFLAGS@/ s:@CFLAGS@:@CFLAGS@ @LDFLAGS@:' \
Makefile.in || die "sed failed"
}
+src_compile() {
+ econf
+ emake CC="$(tc-getCC)" || die
+}
+
src_install() {
einstall || die
dodoc README TODO