summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-12-07 21:16:05 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-12-07 21:16:05 +0000
commit85f00ddb3629490556a493770f916f97e239ef3e (patch)
treedabb10044fbb42cd859c1f09d33c436fa9265525 /sys-apps/epoch/epoch-1.0_rc1.ebuild
parentx86 stable, bug #486312 (diff)
downloadhistorical-85f00ddb3629490556a493770f916f97e239ef3e.tar.gz
historical-85f00ddb3629490556a493770f916f97e239ef3e.tar.bz2
historical-85f00ddb3629490556a493770f916f97e239ef3e.zip
New ebuild for sys-apps/epoch; an init system, a /sbin/init replacement; designed for simplicity.
Package-Manager: portage-HEAD/cvs/Linux x86_64 Manifest-Sign-Key: 0x6D34E57D
Diffstat (limited to 'sys-apps/epoch/epoch-1.0_rc1.ebuild')
-rw-r--r--sys-apps/epoch/epoch-1.0_rc1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/sys-apps/epoch/epoch-1.0_rc1.ebuild b/sys-apps/epoch/epoch-1.0_rc1.ebuild
new file mode 100644
index 000000000000..fef77363f7b3
--- /dev/null
+++ b/sys-apps/epoch/epoch-1.0_rc1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/epoch/epoch-1.0_rc1.ebuild,v 1.1 2013/12/07 21:15:59 tomwij Exp $
+
+EAPI="5"
+
+inherit eutils linux-info
+
+MY_PV="${PV/rc/RC}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="An init system, a /sbin/init replacement; designed for simplicity."
+HOMEPAGE="http://universe2.us/epoch.html"
+SRC_URI="https://github.com/Subsentient/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ local CONFIG_CHECK="~PROC_FS"
+
+ [[ ${MERGE_TYPE} != buildonly ]] && check_extra_config
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-CFLAGS.patch
+}
+
+src_compile() {
+ NEED_EMPTY_CFLAGS=1 sh ./buildepoch.sh || die "Cannot build epoch."
+}
+
+newepochins() {
+ local type="$1"
+
+ cd ${type} || die "Cannot change directory."
+ for file in * ; do
+ if [[ "${file}" != "epoch" ]] ; then
+ new${type} ${file} epoch-${file}
+ fi
+ done
+ cd .. || die "Cannot change directory."
+}
+
+src_install() {
+ cd built || die "Cannot change directory."
+
+ dosbin sbin/epoch
+
+ # For now, rename to epoch-* until we can blend in with a standard approach.
+ newepochins bin
+ newepochins sbin
+
+ insinto /etc/epoch/
+ newins "${FILESDIR}"/${P}-epoch.conf epoch.conf
+}
+
+pkg_postinst() {
+ elog "Make sure to provide /run and /tmp tmpfs mounts using /etc/fstab."
+ elog ""
+ elog "An example epoch configuration is provided at /etc/epoch/epoch.conf"
+ elog "which starts a minimal needed to use Gentoo."
+ elog ""
+ elog "Additional information about epoch is available at"
+ elog "${HOMEPAGE} and configuration documentation at"
+ elog "http://universe2.us/epochconfig.html which is useful reading material."
+ elog ""
+ elog "Its author Subsentient can be contacted at #epoch on irc.freenode.net."
+}