summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-07 22:02:42 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-07 22:02:42 +0000
commit60ab2172594c5db57ebc6ba64fb41d569d7698f9 (patch)
tree2f43cb42de24006742ecfa9ad17279134e9ed5eb /sys-apps/file
parentVersion bump; submitted by Brandon Philips <brandon@ifup.org> in bug #68277. ... (diff)
downloadhistorical-60ab2172594c5db57ebc6ba64fb41d569d7698f9.tar.gz
historical-60ab2172594c5db57ebc6ba64fb41d569d7698f9.tar.bz2
historical-60ab2172594c5db57ebc6ba64fb41d569d7698f9.zip
old
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/file-4.10-r1.ebuild71
-rw-r--r--sys-apps/file/file-4.10.ebuild70
-rw-r--r--sys-apps/file/files/digest-file-4.101
-rw-r--r--sys-apps/file/files/digest-file-4.10-r11
-rw-r--r--sys-apps/file/files/file-4.10-mconvert.patch18
5 files changed, 0 insertions, 161 deletions
diff --git a/sys-apps/file/file-4.10-r1.ebuild b/sys-apps/file/file-4.10-r1.ebuild
deleted file mode 100644
index 0ec36c9be3f7..000000000000
--- a/sys-apps/file/file-4.10-r1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.10-r1.ebuild,v 1.7 2004/11/14 21:06:49 kloeri Exp $
-
-inherit flag-o-matic gnuconfig eutils distutils libtool
-
-DESCRIPTION="Program to identify a file's format by scanning binary data for patterns"
-HOMEPAGE="ftp://ftp.astron.com/pub/file/"
-SRC_URI="ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz
- ftp://ftp.astron.com/pub/file/${P}.tar.gz"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="alpha ~amd64 arm hppa ia64 mips ~ppc ~ppc64 s390 sh sparc x86"
-IUSE="python build"
-
-DEPEND="virtual/libc
- !build? ( python? ( virtual/python ) )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- epatch ${FILESDIR}/file-4.10-mconvert.patch
-
- # (12 Oct 2003) <kumba@gentoo.org>
- # This patch is for MIPS only. It slightly changes the 'file' output
- # on MIPS machines to a specific format so that other programs can
- # recognize things.
- use mips && epatch ${FILESDIR}/${PN}-4.xx-mips-gentoo.diff
-
- # GNU updates
- uclibctoolize
- gnuconfig_update
-
- # make sure python links against the current libmagic #54401
- sed -i "/library_dirs/s:'\.\./src':'../src/.libs':" python/setup.py
-
- # dont let python README kill main README #60043
- mv python/README{,.python}
-}
-
-src_compile() {
- # file command segfaults on hppa - reported by gustavo@zacarias.com.ar
- [ ${ARCH} = "hppa" ] && filter-flags "-mschedule=8000"
-
- econf --datadir=/usr/share/misc || die
-
- emake || die "emake failed"
-
- use python && cd python && distutils_src_compile
-}
-
-src_install() {
- make DESTDIR=${D} install || die "make install failed"
-
- if ! use build ; then
- dodoc ChangeLog MAINT README
- use python && cd python && distutils_src_install
- else
- rm -rf ${D}/usr/share/man ${D}/usr/lib/*.a
- fi
-}
-
-pkg_postinst() {
- use python && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use python && distutils_pkg_postrm
-}
diff --git a/sys-apps/file/file-4.10.ebuild b/sys-apps/file/file-4.10.ebuild
deleted file mode 100644
index 47fecbfcdbbf..000000000000
--- a/sys-apps/file/file-4.10.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.10.ebuild,v 1.8 2004/09/25 06:41:01 vapier Exp $
-
-inherit flag-o-matic gnuconfig eutils distutils libtool
-
-DESCRIPTION="Program to identify a file's format by scanning binary data for patterns"
-HOMEPAGE="ftp://ftp.astron.com/pub/file/"
-SRC_URI="ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz
- ftp://ftp.astron.com/pub/file/${P}.tar.gz"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sparc x86"
-IUSE="python build"
-
-DEPEND="virtual/libc
- !build? ( python? ( virtual/python ) )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- # (12 Oct 2003) <kumba@gentoo.org>
- # This patch is for MIPS only. It slightly changes the 'file' output
- # on MIPS machines to a specific format so that other programs can
- # recognize things.
- use mips && epatch ${FILESDIR}/${PN}-4.xx-mips-gentoo.diff
-
- # GNU updates
- uclibctoolize
- gnuconfig_update
-
- # make sure python links against the current libmagic #54401
- sed -i "/library_dirs/s:'\.\./src':'../src/.libs':" python/setup.py
-
- # dont let python README kill main README #60043
- mv python/README{,.python}
-}
-
-src_compile() {
- # file command segfaults on hppa - reported by gustavo@zacarias.com.ar
- [ ${ARCH} = "hppa" ] && filter-flags "-mschedule=8000"
-
- econf --datadir=/usr/share/misc || die
-
- # Buggy Makefiles. This fixes bug 31356
- emake -j1 || die "emake failed"
-
- use python && cd python && distutils_src_compile
-}
-
-src_install() {
- make DESTDIR=${D} install || die "make install failed"
-
- if ! use build ; then
- dodoc ChangeLog MAINT README
- use python && cd python && distutils_src_install
- else
- rm -rf ${D}/usr/share/man ${D}/usr/lib/*.a
- fi
-}
-
-pkg_postinst() {
- use python && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use python && distutils_pkg_postrm
-}
diff --git a/sys-apps/file/files/digest-file-4.10 b/sys-apps/file/files/digest-file-4.10
deleted file mode 100644
index 0d666da7378f..000000000000
--- a/sys-apps/file/files/digest-file-4.10
+++ /dev/null
@@ -1 +0,0 @@
-MD5 c3cf1bda84a9d55896d4b7dd2caee68d file-4.10.tar.gz 368537
diff --git a/sys-apps/file/files/digest-file-4.10-r1 b/sys-apps/file/files/digest-file-4.10-r1
deleted file mode 100644
index 0d666da7378f..000000000000
--- a/sys-apps/file/files/digest-file-4.10-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 c3cf1bda84a9d55896d4b7dd2caee68d file-4.10.tar.gz 368537
diff --git a/sys-apps/file/files/file-4.10-mconvert.patch b/sys-apps/file/files/file-4.10-mconvert.patch
deleted file mode 100644
index 9d1a6e157bab..000000000000
--- a/sys-apps/file/files/file-4.10-mconvert.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/softmagic.c.orig 2004-11-13 03:07:49.000000000 -0500
-+++ src/softmagic.c 2004-11-13 03:27:20.000000000 -0500
-@@ -427,12 +427,12 @@ mconvert(struct magic_set *ms, union VAL
- return 1;
- case FILE_STRING:
- {
-- int n;
-+ size_t n;
-
- /* Null terminate and eat *trailing* return */
- p->s[sizeof(p->s) - 1] = '\0';
-- n = strlen(p->s) - 1;
-- if (p->s[n] == '\n')
-+ n = strlen(p->s);
-+ if (n-- && p->s[n] == '\n')
- p->s[n] = '\0';
- return 1;
- }