summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-17 11:30:27 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-17 11:30:27 +0000
commit7bd4829e55c29e47014b470c2b05b30d402db968 (patch)
treeff9ca89d9a3bdd073f5479573af4f7b631495c5b /sys-apps/file
parentfix (diff)
downloadhistorical-7bd4829e55c29e47014b470c2b05b30d402db968.tar.gz
historical-7bd4829e55c29e47014b470c2b05b30d402db968.tar.bz2
historical-7bd4829e55c29e47014b470c2b05b30d402db968.zip
Version bump.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/ChangeLog7
-rw-r--r--sys-apps/file/Manifest10
-rw-r--r--sys-apps/file/file-4.14.ebuild77
-rw-r--r--sys-apps/file/files/digest-file-4.141
4 files changed, 90 insertions, 5 deletions
diff --git a/sys-apps/file/ChangeLog b/sys-apps/file/ChangeLog
index 3f6230db73d9..09593436b706 100644
--- a/sys-apps/file/ChangeLog
+++ b/sys-apps/file/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/file
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.78 2005/04/01 19:25:14 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.79 2005/07/17 11:30:27 vapier Exp $
+
+*file-4.14 (17 Jul 2005)
+
+ 17 Jul 2005; Mike Frysinger <vapier@gentoo.org> +file-4.14.ebuild:
+ Version bump.
*file-4.13 (01 Apr 2005)
diff --git a/sys-apps/file/Manifest b/sys-apps/file/Manifest
index 63142e845d6b..93d8577bb183 100644
--- a/sys-apps/file/Manifest
+++ b/sys-apps/file/Manifest
@@ -1,21 +1,23 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
+MD5 32b6c1f46de603e457378c24808e32b3 file-4.14.ebuild 2319
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 c6073a11ea3fcb5cc0d1625a54aad8d4 file-4.12.ebuild 2081
MD5 a0d0a5452082fac452dbe25d1f40435b file-4.13.ebuild 2299
-MD5 5173afd9d8a51dd24b27504105b70f19 ChangeLog 10479
+MD5 a2adc56570ebb79f31088af4c563d2c1 ChangeLog 10589
MD5 f856a50dada76a4ca5cee58fbd04e76b files/file-4.13-cross-compile.patch 964
MD5 a952f0eca26a046e4b815529d2b734ef files/misc.magic 71
MD5 407c20e1fb3186144d6c7d2788714163 files/digest-file-4.13 61
MD5 7a96e5548d52493366ab39f1c6ae9237 files/file-4.13-ia64.patch 530
+MD5 c2aadc08e97769242f12a7a286104a7f files/digest-file-4.14 61
MD5 d336b3490362624aec2e30679c44a198 files/digest-file-4.12 61
MD5 f0f2d2181cac822f0c4d4675fb1ff38c files/cracklib.magic 360
MD5 66df8eecd30769daeb3f643dc6432db3 files/file-4.xx-mips-gentoo.patch 5578
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFC2j52gIKl8Uu19MoRAqqdAJ9S7mJQlXuShl2jLpslgBWsXwQrQACfeC+u
-iMQQZR4mUhEa9pd5NiTTFUs=
-=HvPM
+iD8DBQFC2kFogIKl8Uu19MoRAoAvAJ96MDoScC6roz4Q/IZVev395fOugwCbBsEp
+AX1x9mzCaQTY98LxeuRxHi0=
+=6Q63
-----END PGP SIGNATURE-----
diff --git a/sys-apps/file/file-4.14.ebuild b/sys-apps/file/file-4.14.ebuild
new file mode 100644
index 000000000000..95e0e568a614
--- /dev/null
+++ b/sys-apps/file/file-4.14.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.14.ebuild,v 1.1 2005/07/17 11:30:27 vapier Exp $
+
+inherit flag-o-matic eutils distutils libtool toolchain-funcs
+
+DESCRIPTION="Program to identify a file's format by scanning binary data for patterns"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
+SRC_URI="ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz
+ ftp://ftp.astron.com/pub/file/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="python build"
+
+DEPEND="!build? ( python? ( virtual/python ) )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # the magic and src subdir sometimes don't get along #81974
+ sed -i -e '/^SUBDIRS/s:magic::' Makefile.in
+
+ # Rename ia64 labels (from Fedora)
+ epatch "${FILESDIR}"/${PN}-4.13-ia64.patch
+
+ # This tweaks the output format for mips binaries so things like
+ # libtool don't barf all over the place when trying to parse it.
+ epatch "${FILESDIR}"/${PN}-4.xx-mips-gentoo.patch
+
+ # The build process tries to run the compiled file ... not a good
+ # thing if file was cross compiled ;)
+ tc-is-cross-compiler && epatch "${FILESDIR}"/${PN}-4.13-cross-compile.patch
+
+ # misc updates
+ cat "${FILESDIR}"/*.magic >> magic/magic.mime
+ uclibctoolize
+
+ # make sure python links against the current libmagic #54401
+ sed -i "/library_dirs/s:'\.\./src':'../src/.libs':" python/setup.py
+
+ # dont let python README kill main README #60043
+ mv python/README{,.python}
+}
+
+src_compile() {
+ # file command segfaults on hppa - reported by gustavo@zacarias.com.ar
+ [[ ${ARCH} == hppa ]] && filter-flags -mschedule=8000
+
+ econf --datadir=/usr/share/misc || die
+ emake || die "emake failed"
+ emake -C magic || die "emake magic failed"
+
+ use python && cd python && distutils_src_compile
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ make DESTDIR="${D}" install -C magic || die "make magic install failed"
+
+ if ! use build ; then
+ dodoc ChangeLog MAINT README
+ use python && cd python && distutils_src_install
+ else
+ rm -r "${D}"/usr/share/man "${D}"/usr/lib/*.a
+ fi
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}
diff --git a/sys-apps/file/files/digest-file-4.14 b/sys-apps/file/files/digest-file-4.14
new file mode 100644
index 000000000000..344cae8ba633
--- /dev/null
+++ b/sys-apps/file/files/digest-file-4.14
@@ -0,0 +1 @@
+MD5 66983e60087e8bcd588c8ab38a861af0 file-4.14.tar.gz 545141