summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-03 20:31:42 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-03 20:31:42 +0000
commitc5d7ca3c725f5fc74ec8b3e03dc8fecffafaee1a (patch)
treec0e36c34cd43b8800d515d6f154ec9423d260934 /sys-apps/gawk/files
parentStable on ppc64 (diff)
downloadhistorical-c5d7ca3c725f5fc74ec8b3e03dc8fecffafaee1a.tar.gz
historical-c5d7ca3c725f5fc74ec8b3e03dc8fecffafaee1a.tar.bz2
historical-c5d7ca3c725f5fc74ec8b3e03dc8fecffafaee1a.zip
Fix by Kito for building with gcc4 #104740 and move a bunch of ugly filefunc details out of the ebuild and into the filefunc Makefile.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'sys-apps/gawk/files')
-rw-r--r--sys-apps/gawk/files/filefuncs/Makefile23
-rw-r--r--sys-apps/gawk/files/gawk-3.1.5-gcc4.patch23
2 files changed, 45 insertions, 1 deletions
diff --git a/sys-apps/gawk/files/filefuncs/Makefile b/sys-apps/gawk/files/filefuncs/Makefile
index c3d99de9328e..bd2cfca7ee94 100644
--- a/sys-apps/gawk/files/filefuncs/Makefile
+++ b/sys-apps/gawk/files/filefuncs/Makefile
@@ -1,7 +1,7 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# Author: Martin Schlemmer <azarah@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/files/filefuncs/Makefile,v 1.6 2005/05/14 17:56:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/files/filefuncs/Makefile,v 1.7 2005/09/03 20:31:42 vapier Exp $
CC ?= gcc
LD = $(CC)
@@ -17,6 +17,21 @@ TARGET_LIB = $(TARGET).so.$(MAJORVER).$(MINORVER)
LIBDIR = lib
+# Gentoo specific cruft, you like it dont ya idiot
+ifdef D
+DESTDIR = $(D)
+endif
+ifdef S
+AWKINCDIR = $(S)
+endif
+
+DOIT = yes
+ifeq ($(USERLAND),Darwin)
+DOIT = no
+endif
+
+ifeq ($(DOIT),yes)
+
all: $(TARGET_LIB)
$(TARGET).o: $(TARGET).c
@@ -34,3 +49,9 @@ install: $(TARGET_LIB)
clean:
rm -f $(TARGET)
rm -f *.o *~ core
+
+else
+
+all install clean:
+
+endif
diff --git a/sys-apps/gawk/files/gawk-3.1.5-gcc4.patch b/sys-apps/gawk/files/gawk-3.1.5-gcc4.patch
new file mode 100644
index 000000000000..3ebadcbe6684
--- /dev/null
+++ b/sys-apps/gawk/files/gawk-3.1.5-gcc4.patch
@@ -0,0 +1,23 @@
+Sat Sep 3 16:03:25 EDT 2005 Kito Danya Dietrich <kito@gentoo.org>
+
+ * hard-locale.h (hard_locale): Declare xmalloc in global scope rather than
+ function scope which gcc-4.x rejects.
+
+--- gawk-3.1.5/hard-locale.h
++++ gawk-3.1.5/hard-locale.h
+@@ -21,6 +21,7 @@
+ along with this program; if not, write to the Free Software Foundation,
+ Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA. */
+
++static ptr_t xmalloc PARAMS ((size_t n));
+
+ /* Return nonzero if the current CATEGORY locale is hard, i.e. if you
+ can't get away with assuming traditional C or POSIX behavior. */
+@@ -40,7 +41,6 @@
+ if (strcmp (p, "C") == 0 || strcmp (p, "POSIX") == 0)
+ hard = 0;
+ # else
+- static ptr_t xmalloc PARAMS ((size_t n));
+
+ char *locale = xmalloc (strlen (p) + 1);
+ strcpy (locale, p);