summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2012-04-17 08:40:55 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2012-04-17 08:40:55 +0000
commit86be4660ea3f7583ec40c8174e33dfcf6aeae8de (patch)
tree0d4c3ab44541d553d5c598e979d4ad2193b380b2 /sys-apps/hardened-shadow
parentUse the m4 dir so configure does not bail out. (diff)
downloadhistorical-86be4660ea3f7583ec40c8174e33dfcf6aeae8de.tar.gz
historical-86be4660ea3f7583ec40c8174e33dfcf6aeae8de.tar.bz2
historical-86be4660ea3f7583ec40c8174e33dfcf6aeae8de.zip
Version bump for new pambase.
Package-Manager: portage-2.1.10.49/cvs/Linux i686
Diffstat (limited to 'sys-apps/hardened-shadow')
-rw-r--r--sys-apps/hardened-shadow/ChangeLog8
-rw-r--r--sys-apps/hardened-shadow/hardened-shadow-0.9-r1.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/sys-apps/hardened-shadow/ChangeLog b/sys-apps/hardened-shadow/ChangeLog
index b84b025d2e7f..7f47b39c85e0 100644
--- a/sys-apps/hardened-shadow/ChangeLog
+++ b/sys-apps/hardened-shadow/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/hardened-shadow
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hardened-shadow/ChangeLog,v 1.1 2012/03/11 12:10:24 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hardened-shadow/ChangeLog,v 1.2 2012/04/17 08:40:55 phajdan.jr Exp $
+
+*hardened-shadow-0.9-r1 (17 Apr 2012)
+
+ 17 Apr 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ +hardened-shadow-0.9-r1.ebuild:
+ Version bump for new pambase.
*hardened-shadow-0.9 (11 Mar 2012)
diff --git a/sys-apps/hardened-shadow/hardened-shadow-0.9-r1.ebuild b/sys-apps/hardened-shadow/hardened-shadow-0.9-r1.ebuild
new file mode 100644
index 000000000000..44f6cc29a861
--- /dev/null
+++ b/sys-apps/hardened-shadow/hardened-shadow-0.9-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hardened-shadow/hardened-shadow-0.9-r1.ebuild,v 1.1 2012/04/17 08:40:55 phajdan.jr Exp $
+
+EAPI=4
+
+inherit autotools-utils eutils multilib
+
+DESCRIPTION="Hardened implementation of user account utilities"
+HOMEPAGE="http://code.google.com/p/hardened-shadow/"
+SRC_URI="http://hardened-shadow.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="sys-libs/pam
+ !sys-apps/shadow"
+RDEPEND="${DEPEND}
+ >=sys-auth/pambase-20120417"
+
+pkg_setup() {
+ # The hardened-shadow group is needed at src_install time,
+ # so the only place we can create the group is pkg_setup.
+ enewgroup hardened-shadow
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ # Remove pam.d files colliding with pambase.
+ rm -r "${ED}"/etc/pam.d || die
+}