summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Kroah-Hartman <gregkh@gentoo.org>2004-03-30 01:11:28 +0000
committerGreg Kroah-Hartman <gregkh@gentoo.org>2004-03-30 01:11:28 +0000
commitd38347566884c6caea7de594389c008c4b4e544c (patch)
tree5bf96454e818107c9ebc8ffb85c0b1edfbe40bd2 /sys-apps/hotplug
parentstable on ppc (diff)
downloadhistorical-d38347566884c6caea7de594389c008c4b4e544c.tar.gz
historical-d38347566884c6caea7de594389c008c4b4e544c.tar.bz2
historical-d38347566884c6caea7de594389c008c4b4e544c.zip
tweaked hotplug.rc script a bit
Diffstat (limited to 'sys-apps/hotplug')
-rw-r--r--sys-apps/hotplug/ChangeLog7
-rw-r--r--sys-apps/hotplug/Manifest4
-rw-r--r--sys-apps/hotplug/files/hotplug.rc12
3 files changed, 15 insertions, 8 deletions
diff --git a/sys-apps/hotplug/ChangeLog b/sys-apps/hotplug/ChangeLog
index 75dd4e8db08e..a0cda04ff11f 100644
--- a/sys-apps/hotplug/ChangeLog
+++ b/sys-apps/hotplug/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hotplug
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/ChangeLog,v 1.35 2004/03/30 00:27:50 gregkh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/ChangeLog,v 1.36 2004/03/30 01:11:28 gregkh Exp $
+
+ 29 Mar 2004; Greg Kroah-Hartman <gregkh@gentoo.org> files/hotplug.rc:
+ Change the hotplug init.d script to show what subsystem it is starting
+ and stopping to help out in finding problems (and letting people know
+ exactly what is happening on their systems.)
*hotplug-20040329 (29 Mar 2004)
diff --git a/sys-apps/hotplug/Manifest b/sys-apps/hotplug/Manifest
index 6762d4ee129b..ab7f00166477 100644
--- a/sys-apps/hotplug/Manifest
+++ b/sys-apps/hotplug/Manifest
@@ -1,4 +1,4 @@
-MD5 d74c3bee494820a0fdde783355c51719 ChangeLog 5880
+MD5 40952953231923739fe7671420f36c32 ChangeLog 6145
MD5 20c3f8b015678d0bf9d6463fef97dcd7 hotplug-20020826-r2.ebuild 1561
MD5 b0a484d63057d74095ddeb36f7700ce6 hotplug-20030501-r2.ebuild 1515
MD5 da047afd1a129c6f8ace01cd8627e401 hotplug-20030805-r1.ebuild 1743
@@ -19,7 +19,7 @@ MD5 f9303a2467242ed310370ddcd63414b6 files/digest-hotplug-20040105 151
MD5 687c2739aaf462dc70058802f4d65ca1 files/digest-hotplug-20040311 151
MD5 d8a0d8878d8904a779bda401d86268b1 files/firmware.agent 1188
MD5 7c4681458effb34f299cbc4b9245098c files/hotplug.functions.patch 522
-MD5 f7087ab58af3a1afc7e23b668c29e3fb files/hotplug.rc 799
+MD5 e906434f0ef7ac28170c0115a22f3978 files/hotplug.rc 843
MD5 9f13f3363b85caac03bfb623c652b4fa files/kernel-26-fix.patch 816
MD5 92547b2263d5423d874565504d2324f7 files/usb.agent.diff 886
MD5 1bd9ddb0959318fe56dec239c8265fb1 files/usb.confd 291
diff --git a/sys-apps/hotplug/files/hotplug.rc b/sys-apps/hotplug/files/hotplug.rc
index f7b0275047f0..9118cce95797 100644
--- a/sys-apps/hotplug/files/hotplug.rc
+++ b/sys-apps/hotplug/files/hotplug.rc
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/files/hotplug.rc,v 1.7 2004/03/06 04:09:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/files/hotplug.rc,v 1.8 2004/03/30 01:11:28 gregkh Exp $
depend() {
need modules
@@ -17,23 +17,25 @@ checkconfig() {
start() {
checkconfig || return 1
- ebegin "Starting USB and PCI hotplugging"
for RC in /etc/hotplug/*.rc
do
+ NAME=`basename $RC .rc`
+ ebegin "Starting $NAME hotplugging"
# We do not want to check the return status, as
# some of the scripts may fail due to drivers not
# compiled as modules ...
$RC start
+ eend 0
done
- eend 0
}
stop() {
local error
- ebegin "Stopping USB and PCI hotplugging"
for RC in /etc/hotplug/*.rc
do
+ NAME=`basename $RC .rc`
+ ebegin "Stopping $NAME hotplugging"
$RC stop
+ eend 0
done
- eend 0
}