summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-07-27 12:30:25 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-07-27 12:30:25 +0000
commit37d11d7cb0e66565996cda5abeefda3365452345 (patch)
treee8ceda51bd31796cc7d2fd8783efc7e1b0c1d632 /sys-apps/hwsetup
parentSlight changes to install (diff)
downloadhistorical-37d11d7cb0e66565996cda5abeefda3365452345.tar.gz
historical-37d11d7cb0e66565996cda5abeefda3365452345.tar.bz2
historical-37d11d7cb0e66565996cda5abeefda3365452345.zip
Changed all calls to XFree86 to just X to make it X server agnostic.
Diffstat (limited to 'sys-apps/hwsetup')
-rw-r--r--sys-apps/hwsetup/ChangeLog8
-rw-r--r--sys-apps/hwsetup/Manifest17
-rw-r--r--sys-apps/hwsetup/files/digest-hwsetup-1.0-r21
-rw-r--r--sys-apps/hwsetup/files/hwsetup-1.0-gentoo.patch21
-rw-r--r--sys-apps/hwsetup/hwsetup-1.0-r2.ebuild31
5 files changed, 65 insertions, 13 deletions
diff --git a/sys-apps/hwsetup/ChangeLog b/sys-apps/hwsetup/ChangeLog
index a2506da6fb17..79591fb15dba 100644
--- a/sys-apps/hwsetup/ChangeLog
+++ b/sys-apps/hwsetup/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/hwsetup
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/ChangeLog,v 1.12 2004/06/24 22:11:06 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/ChangeLog,v 1.13 2004/07/27 12:30:25 wolf31o2 Exp $
+
+*hwsetup-1.0-r2 (27 Jul 2004)
+
+ 27 Jul 2004; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/hwsetup-1.0-gentoo.patch, +hwsetup-1.0-r2.ebuild:
+ Changed all calls to XFree86 to just X to make it X server agnostic.
23 Jun 2004; Chris Gianelloni <wolf31o2@gentoo.org> hwsetup-1.0-r1.ebuild:
Added to ~ppc per dholm.
diff --git a/sys-apps/hwsetup/Manifest b/sys-apps/hwsetup/Manifest
index 60c4b280eea3..76fcfa1d778c 100644
--- a/sys-apps/hwsetup/Manifest
+++ b/sys-apps/hwsetup/Manifest
@@ -1,14 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 b6b69eae3f5ffb4f12c148d40b908293 ChangeLog 1270
-MD5 d86e5b5e47260e5a965eae2afe6d6d40 metadata.xml 159
MD5 78c7eb2af710138e04eed996bebf020e hwsetup-1.0-r1.ebuild 661
+MD5 4e2d13d5b31bfc756a824e24ea62f27d hwsetup-1.0-r2.ebuild 751
+MD5 4467f167d7131402dbad65277530e3f8 ChangeLog 1486
+MD5 d86e5b5e47260e5a965eae2afe6d6d40 metadata.xml 159
MD5 70141575b96009e82605b4f86fbe8758 files/digest-hwsetup-1.0-r1 64
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.8 (GNU/Linux)
-
-iD8DBQFA4iibHTu7gpaalycRAmymAKD7cQAyHtFUE+FzfV+UR3xdLq9twwCgwIu2
-qEOnSVt2DEe4+PiIcfZlmMA=
-=JNcL
------END PGP SIGNATURE-----
+MD5 70141575b96009e82605b4f86fbe8758 files/digest-hwsetup-1.0-r2 64
+MD5 1ada56ed20f7ac972b207a4ba6f2887f files/hwsetup-1.0-gentoo.patch 696
diff --git a/sys-apps/hwsetup/files/digest-hwsetup-1.0-r2 b/sys-apps/hwsetup/files/digest-hwsetup-1.0-r2
new file mode 100644
index 000000000000..b3852e0446f7
--- /dev/null
+++ b/sys-apps/hwsetup/files/digest-hwsetup-1.0-r2
@@ -0,0 +1 @@
+MD5 12ed659c6ce09dd4c06ee4bc07f0adfe hwsetup_1.0-14.tar.gz 8491
diff --git a/sys-apps/hwsetup/files/hwsetup-1.0-gentoo.patch b/sys-apps/hwsetup/files/hwsetup-1.0-gentoo.patch
new file mode 100644
index 000000000000..03de58c3eef9
--- /dev/null
+++ b/sys-apps/hwsetup/files/hwsetup-1.0-gentoo.patch
@@ -0,0 +1,21 @@
+diff -urN hwsetup-1.0.orig/hwsetup.c hwsetup-1.0/hwsetup.c
+--- hwsetup-1.0.orig/hwsetup.c 2003-06-02 15:01:28.000000000 -0400
++++ hwsetup-1.0/hwsetup.c 2004-07-24 18:57:36.986337040 -0400
+@@ -103,7 +103,7 @@
+
+ struct xinfo *getxinfo(struct device *d)
+ {
+- const char *xfree4="XFree86", *xvesa4="vesa";
++ const char *xfree4="X", *xvesa4="vesa";
+ const char *xpath=XPATH;
+ static struct xinfo xi;
+ int rescanned=0;
+@@ -206,7 +206,7 @@
+ {
+ char xm[32]="";
+ strcpy(xi.xserver,xfree4);
+- if(sscanf(xpos,"XFree86(%30[^)])",xm)==1)
++ if(sscanf(xpos,"X(%30[^)])",xm)==1)
+ strcpy(xi.xmodule,xm);
+ else
+ strcpy(xi.xmodule,xvesa4);
diff --git a/sys-apps/hwsetup/hwsetup-1.0-r2.ebuild b/sys-apps/hwsetup/hwsetup-1.0-r2.ebuild
new file mode 100644
index 000000000000..79650722a2e5
--- /dev/null
+++ b/sys-apps/hwsetup/hwsetup-1.0-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/hwsetup-1.0-r2.ebuild,v 1.1 2004/07/27 12:30:25 wolf31o2 Exp $
+
+inherit eutils
+
+MY_PV=${PV}-14
+DESCRIPTION="Hardware setup program"
+HOMEPAGE="http://www.knopper.net/"
+SRC_URI="http://developer.linuxtag.net/knoppix/sources/${PN}_${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc -sparc -mips ~alpha ~amd64"
+IUSE=""
+
+DEPEND=">=sys-apps/kudzu-knoppix-1.0"
+RDEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ einstall DESTDIR=${D} PREFIX=/usr MANDIR=/usr/share/man || die "Install failed"
+}