summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael J. Cohen <mjc@gentoo.org>2002-12-28 04:35:37 +0000
committerMichael J. Cohen <mjc@gentoo.org>2002-12-28 04:35:37 +0000
commit55e0ae29836b979eb0a552d8bc3e51fe0ee6f854 (patch)
treea1264fd847813faad2a73c53c7f28423cc65c5e7 /sys-apps/lm_sensors
parentOops.. (diff)
downloadhistorical-55e0ae29836b979eb0a552d8bc3e51fe0ee6f854.tar.gz
historical-55e0ae29836b979eb0a552d8bc3e51fe0ee6f854.tar.bz2
historical-55e0ae29836b979eb0a552d8bc3e51fe0ee6f854.zip
Oops.
Diffstat (limited to 'sys-apps/lm_sensors')
-rw-r--r--sys-apps/lm_sensors/lm_sensors-2.6.3-r1.ebuild48
-rw-r--r--sys-apps/lm_sensors/lm_sensors-2.6.3.ebuild0
-rw-r--r--sys-apps/lm_sensors/lm_sensors-2.6.4-r1.ebuild48
-rw-r--r--sys-apps/lm_sensors/lm_sensors-2.6.4.ebuild46
-rw-r--r--sys-apps/lm_sensors/lm_sensors-2.6.5.ebuild49
-rw-r--r--sys-apps/lm_sensors/lm_sensors-2.7.0.ebuild52
6 files changed, 243 insertions, 0 deletions
diff --git a/sys-apps/lm_sensors/lm_sensors-2.6.3-r1.ebuild b/sys-apps/lm_sensors/lm_sensors-2.6.3-r1.ebuild
new file mode 100644
index 000000000000..aef71638b86e
--- /dev/null
+++ b/sys-apps/lm_sensors/lm_sensors-2.6.3-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/lm_sensors-2.6.3-r1.ebuild,v 1.8 2002/12/28 04:35:37 mjc Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Hardware Sensors Monitoring by lm_sensors"
+SRC_URI="http://www2.lm-sensors.nu/~lm78/archive/${P}.tar.gz"
+HOMEPAGE="http://www2.lm-sensors.nu/~lm78"
+KEYWORDS="x86 ppc sparc "
+LICENSE="GPL-2"
+
+SLOT="0"
+
+DEPEND="virtual/linux-sources"
+
+src_compile() {
+ emake clean all || die "lm_sensors requires the source of a compatible kernel\nversion installed in /usr/src/linux and i2c support built as a modules"
+}
+
+src_install() {
+ emake DESTDIR=${D} PREFIX=/usr MANDIR=/usr/share/man install || die
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/rc_lm_sensors lm_sensors
+}
+
+pkg_postinst() {
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+
+ einfo
+ einfo "The lm_sensors hardware sensors package has been installed."
+ einfo
+ einfo "It is recommended that you read the lm_sensors documentation."
+ einfo "To enable lm_sensors you will need to compile i2c support in"
+ einfo "your kernel as a module and run /usr/sbin/sensors-detect to"
+ einfo "detect the hardware in your system."
+ einfo
+ einfo "Be warned, the probing of hardware in your system performed by"
+ einfo "sensors-detect could freeze your system. Also do not use"
+ einfo "lm_sensors on certain laptop models from IBM. See the lm_sensors"
+ einfo "documentation and website for more information."
+ einfo
+ einfo "IMPORTANT: When you merge this package it installs kernel modules"
+ einfo "that can only be used with the specific kernel version whose"
+ einfo "source is located in /usr/src/linux. If you upgrade to a new"
+ einfo "kernel, you will need to remerge the lm_sensors package to build"
+ einfo "new kernel modules."
+ einfo
+}
diff --git a/sys-apps/lm_sensors/lm_sensors-2.6.3.ebuild b/sys-apps/lm_sensors/lm_sensors-2.6.3.ebuild
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sys-apps/lm_sensors/lm_sensors-2.6.3.ebuild
diff --git a/sys-apps/lm_sensors/lm_sensors-2.6.4-r1.ebuild b/sys-apps/lm_sensors/lm_sensors-2.6.4-r1.ebuild
new file mode 100644
index 000000000000..ffe5f27e13d4
--- /dev/null
+++ b/sys-apps/lm_sensors/lm_sensors-2.6.4-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/lm_sensors-2.6.4-r1.ebuild,v 1.8 2002/12/28 04:35:37 mjc Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Hardware Sensors Monitoring by lm_sensors"
+SRC_URI="http://www2.lm-sensors.nu/~lm78/archive/${P}.tar.gz"
+HOMEPAGE="http://www2.lm-sensors.nu/~lm78"
+KEYWORDS="x86 ppc sparc "
+LICENSE="GPL-2"
+
+SLOT="0"
+
+DEPEND="virtual/linux-sources"
+
+src_compile() {
+ emake clean all || die "lm_sensors requires the source of a compatible kernel\nversion installed in /usr/src/linux and i2c support built as a modules"
+}
+
+src_install() {
+ emake DESTDIR=${D} PREFIX=/usr MANDIR=/usr/share/man install || die
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/rc_lm_sensors lm_sensors
+}
+
+pkg_postinst() {
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+
+ einfo
+ einfo "The lm_sensors hardware sensors package has been installed."
+ einfo
+ einfo "It is recommended that you read the lm_sensors documentation."
+ einfo "To enable lm_sensors you will need to compile i2c support in"
+ einfo "your kernel as a module and run /usr/sbin/sensors-detect to"
+ einfo "detect the hardware in your system."
+ einfo
+ einfo "Be warned, the probing of hardware in your system performed by"
+ einfo "sensors-detect could freeze your system. Also do not use"
+ einfo "lm_sensors on certain laptop models from IBM. See the lm_sensors"
+ einfo "documentation and website for more information."
+ einfo
+ einfo "IMPORTANT: When you merge this package it installs kernel modules"
+ einfo "that can only be used with the specific kernel version whose"
+ einfo "source is located in /usr/src/linux. If you upgrade to a new"
+ einfo "kernel, you will need to remerge the lm_sensors package to build"
+ einfo "new kernel modules."
+ einfo
+}
diff --git a/sys-apps/lm_sensors/lm_sensors-2.6.4.ebuild b/sys-apps/lm_sensors/lm_sensors-2.6.4.ebuild
new file mode 100644
index 000000000000..3f44cf37a054
--- /dev/null
+++ b/sys-apps/lm_sensors/lm_sensors-2.6.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/lm_sensors-2.6.4.ebuild,v 1.8 2002/12/28 04:35:37 mjc Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Hardware Sensors Monitoring by lm_sensors"
+SRC_URI="http://www2.lm-sensors.nu/~lm78/archive/${P}.tar.gz"
+HOMEPAGE="http://www2.lm-sensors.nu/~lm78"
+KEYWORDS="x86 ppc sparc "
+LICENSE="GPL-2"
+
+SLOT="0"
+
+DEPEND="virtual/linux-sources"
+
+src_compile() {
+ emake clean all || die "lm_sensors requires the source of a compatible kernel\nversion installed in /usr/src/linux and i2c support built as a modules"
+}
+
+src_install() {
+ emake DESTDIR=${D} PREFIX=/usr MANDIR=/usr/share/man install || die
+}
+
+pkg_postinst() {
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+
+ einfo
+ einfo "The lm_sensors hardware sensors package has been installed."
+ einfo
+ einfo "It is recommended that you read the lm_sensors documentation."
+ einfo "To enable lm_sensors you will need to compile i2c support in"
+ einfo "your kernel as a module and run /usr/sbin/sensors-detect to"
+ einfo "detect the hardware in your system."
+ einfo
+ einfo "Be warned, the probing of hardware in your system performed by"
+ einfo "sensors-detect could freeze your system. Also do not use"
+ einfo "lm_sensors on certain laptop models from IBM. See the lm_sensors"
+ einfo "documentation and website for more information."
+ einfo
+ einfo "IMPORTANT: When you merge this package it installs kernel modules"
+ einfo "that can only be used with the specific kernel version whose"
+ einfo "source is located in /usr/src/linux. If you upgrade to a new"
+ einfo "kernel, you will need to remerge the lm_sensors package to build"
+ einfo "new kernel modules."
+ einfo
+}
diff --git a/sys-apps/lm_sensors/lm_sensors-2.6.5.ebuild b/sys-apps/lm_sensors/lm_sensors-2.6.5.ebuild
new file mode 100644
index 000000000000..505451149304
--- /dev/null
+++ b/sys-apps/lm_sensors/lm_sensors-2.6.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/lm_sensors-2.6.5.ebuild,v 1.5 2002/12/28 04:35:37 mjc Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Hardware Sensors Monitoring by lm_sensors"
+SRC_URI="http://www2.lm-sensors.nu/~lm78/archive/${P}.tar.gz"
+HOMEPAGE="http://www2.lm-sensors.nu/~lm78"
+KEYWORDS="x86 ppc sparc"
+LICENSE="GPL-2"
+
+SLOT="0"
+
+DEPEND="virtual/linux-sources"
+
+src_compile() {
+ emake clean all || die "lm_sensors requires the source of a compatible kernel\nversion installed in /usr/src/linux and i2c support built as a modules"
+}
+
+src_install() {
+ emake DESTDIR=${D} PREFIX=/usr MANDIR=/usr/share/man install \
+ || die "Install failed"
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/rc_lm_sensors lm_sensors
+}
+
+pkg_postinst() {
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+
+ einfo
+ einfo "The lm_sensors hardware sensors package has been installed."
+ einfo
+ einfo "It is recommended that you read the lm_sensors documentation."
+ einfo "To enable lm_sensors you will need to compile i2c support in"
+ einfo "your kernel as a module and run /usr/sbin/sensors-detect to"
+ einfo "detect the hardware in your system."
+ einfo
+ einfo "Be warned, the probing of hardware in your system performed by"
+ einfo "sensors-detect could freeze your system. Also do not use"
+ einfo "lm_sensors on certain laptop models from IBM. See the lm_sensors"
+ einfo "documentation and website for more information."
+ einfo
+ einfo "IMPORTANT: When you merge this package it installs kernel modules"
+ einfo "that can only be used with the specific kernel version whose"
+ einfo "source is located in /usr/src/linux. If you upgrade to a new"
+ einfo "kernel, you will need to remerge the lm_sensors package to build"
+ einfo "new kernel modules."
+ einfo
+}
diff --git a/sys-apps/lm_sensors/lm_sensors-2.7.0.ebuild b/sys-apps/lm_sensors/lm_sensors-2.7.0.ebuild
new file mode 100644
index 000000000000..a1486708f114
--- /dev/null
+++ b/sys-apps/lm_sensors/lm_sensors-2.7.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/lm_sensors-2.7.0.ebuild,v 1.3 2002/12/28 04:35:37 mjc Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Hardware Sensors Monitoring by lm_sensors"
+SRC_URI="http://www2.lm-sensors.nu/~lm78/archive/${P}.tar.gz"
+HOMEPAGE="http://www2.lm-sensors.nu/~lm78"
+
+# gentoo-sources-2.4.20-r1 and xfs-sources-2.4.20-r1 will
+# have support for this package, do not change these to ~
+# until your arch has i2c-2.7.0 in it's kernel.
+KEYWORDS="-x86 -ppc -sparc"
+LICENSE="GPL-2"
+
+SLOT="0"
+
+DEPEND="virtual/linux-sources"
+
+src_compile() {
+ emake clean all || die "lm_sensors requires the source of a compatible kernel\nversion installed in /usr/src/linux and i2c support built as a modules"
+}
+
+src_install() {
+ einstall DESTDIR=${D} PREFIX=/usr MANDIR=/usr/share/man || die "Install failed"
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/rc_lm_sensors lm_sensors
+}
+
+pkg_postinst() {
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+
+ einfo
+ einfo "The lm_sensors hardware sensors package has been installed."
+ einfo
+ einfo "It is recommended that you read the lm_sensors documentation."
+ einfo "To enable lm_sensors you will need to compile i2c support in"
+ einfo "your kernel as a module and run /usr/sbin/sensors-detect to"
+ einfo "detect the hardware in your system."
+ einfo
+ einfo "Be warned, the probing of hardware in your system performed by"
+ einfo "sensors-detect could freeze your system. Also do not use"
+ einfo "lm_sensors on certain laptop models from IBM. See the lm_sensors"
+ einfo "documentation and website for more information."
+ einfo
+ einfo "IMPORTANT: When you merge this package it installs kernel modules"
+ einfo "that can only be used with the specific kernel version whose"
+ einfo "source is located in /usr/src/linux. If you upgrade to a new"
+ einfo "kernel, you will need to remerge the lm_sensors package to build"
+ einfo "new kernel modules."
+ einfo
+}