summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-03-30 20:04:16 +0000
committerMike Frysinger <vapier@gentoo.org>2012-03-30 20:04:16 +0000
commite5eea718fb9f599d287a3db64f2e65e626f6ad07 (patch)
treeadd662810b7698a3348997546c23e7cb30af7e68 /sys-apps/util-linux/util-linux-2.21.ebuild
parentVersion bump to development release. (diff)
downloadhistorical-e5eea718fb9f599d287a3db64f2e65e626f6ad07.tar.gz
historical-e5eea718fb9f599d287a3db64f2e65e626f6ad07.tar.bz2
historical-e5eea718fb9f599d287a3db64f2e65e626f6ad07.zip
Add cross-compiling fixes to match upstream.
Package-Manager: portage-2.2.0_alpha95/cvs/Linux x86_64
Diffstat (limited to 'sys-apps/util-linux/util-linux-2.21.ebuild')
-rw-r--r--sys-apps/util-linux/util-linux-2.21.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-apps/util-linux/util-linux-2.21.ebuild b/sys-apps/util-linux/util-linux-2.21.ebuild
index ef5255468054..4c259ba8a813 100644
--- a/sys-apps/util-linux/util-linux-2.21.ebuild
+++ b/sys-apps/util-linux/util-linux-2.21.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.21.ebuild,v 1.1 2012/02/24 16:35:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.21.ebuild,v 1.2 2012/03/30 20:04:16 vapier Exp $
EAPI="3"
@@ -68,6 +68,12 @@ lfs_fallocate_test() {
src_configure() {
lfs_fallocate_test
+ if tc-is-cross-compiler ; then
+ # newer util-linux has this fixed in the configure script already
+ [[ ${PV} != 2.21* ]] && die
+ export scanf_cv_alloc_modifier=no
+ [[ ${CHOST} == *-gnu* ]] && scanf_cv_alloc_modifier=ms
+ fi
econf \
--enable-fs-paths-extra=/usr/sbin \
$(use_enable nls) \