summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-04-26 05:42:18 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-04-26 05:42:18 +0000
commit52cdbd2eecc4209d67fa3bf4c21b08864e640f5c (patch)
treea3eb16a2aeedacc5cf1b09364c8c7b3435601fa5 /sys-apps/util-linux
parentFixed sandbox violation. Updated syntax. (diff)
downloadhistorical-52cdbd2eecc4209d67fa3bf4c21b08864e640f5c.tar.gz
historical-52cdbd2eecc4209d67fa3bf4c21b08864e640f5c.tar.bz2
historical-52cdbd2eecc4209d67fa3bf4c21b08864e640f5c.zip
Added international crypto patch. This patch does not contain any cryptographic sourcecode. See cryptoapi ebuild. (#1607)
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/ChangeLog10
-rw-r--r--sys-apps/util-linux/files/digest-util-linux-2.11o-r22
-rw-r--r--sys-apps/util-linux/util-linux-2.11o-r2.ebuild75
-rw-r--r--sys-apps/util-linux/util-linux-2.11o.ebuild5
4 files changed, 89 insertions, 3 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index 9010f6bfd4d8..6006827bda35 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/util-linux
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.4 2002/04/11 15:11:00 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.5 2002/04/26 05:42:18 rphillips Exp $
+
+*util-linux-2.11o-r2 (25 Apr 2002)
+
+ 25 Apr 2002; Ryan Phillips <rphillips@gentoo.org> util-linux-2.11o-r2.ebuild
+ files/digest-util-linux-2.11o-r2
+
+ patch util-linux with the international crypto patch. This patch
+ does not contain any cryptographic components. (#1607)
*util-linux-2.11o-r1 (11 Apr 2002)
diff --git a/sys-apps/util-linux/files/digest-util-linux-2.11o-r2 b/sys-apps/util-linux/files/digest-util-linux-2.11o-r2
new file mode 100644
index 000000000000..30b511b04c19
--- /dev/null
+++ b/sys-apps/util-linux/files/digest-util-linux-2.11o-r2
@@ -0,0 +1,2 @@
+MD5 38ddea8feec3af4847012d7a0be2f9ae util-linux-2.11o.tar.gz 1490079
+MD5 dc020755682a383607c792b37b36d94e util-linux-2.11o.patch.gz 18710
diff --git a/sys-apps/util-linux/util-linux-2.11o-r2.ebuild b/sys-apps/util-linux/util-linux-2.11o-r2.ebuild
new file mode 100644
index 000000000000..6d1c99ac971e
--- /dev/null
+++ b/sys-apps/util-linux/util-linux-2.11o-r2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11o-r2.ebuild,v 1.1 2002/04/26 05:42:18 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Various useful Linux utilities"
+SRC_URI="http://www.kernel.org/pub/linux/utils/${PN}/${P}.tar.gz
+ http://www.kernel.org/pub/linux/kernel/people/hvr/util-linux-patch-int/${P}.patch.gz"
+
+DEPEND="virtual/glibc >=sys-libs/ncurses-5.2-r2"
+
+RDEPEND="$DEPEND sys-devel/perl
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${WORKDIR}
+ cd ${S}
+ gunzip -c ${DISTDIR}/${P}.patch.gz | patch -p0
+ cp MCONFIG MCONFIG.orig
+ #Build login etc; we will install only login manually....
+ #We do this to fix a bug with shadow's login
+ sed -e "s:-pipe -O2 \$(CPUOPT) -fomit-frame-pointer:${CFLAGS}:" \
+ -e "s:CPU=.*:CPU=${CHOST%%-*}:" \
+ -e "s:HAVE_SHADOW=yes:HAVE_SHADOW=no:" \
+ -e "s:HAVE_PAM=no:HAVE_PAM=yes:" \
+ -e "s:HAVE_SLN=no:HAVE_SLN=yes:" \
+ -e "s:HAVE_TSORT=no:HAVE_TSORT=yes:" \
+ -e "s:usr/man:usr/share/man:" \
+ -e "s:usr/info:usr/share/info:" \
+ MCONFIG.orig > MCONFIG
+}
+
+src_compile() {
+
+ ./configure || die
+
+ if [ -z "`use nls`" ]
+ then
+ cp defines.h defines.h.orig
+ cp Makefile Makefile.orig
+
+ sed -e "s/#define ENABLE_NLS//g" \
+ -e "s/#define HAVE_libintl_h//g" \
+ defines.h.orig > defines.h
+
+ sed "s/\(^SUBDIRS=\)po/\1lib/g" \
+ Makefile.orig > Makefile
+ fi
+
+ emake LDFLAGS="" || die
+ cd sys-utils; makeinfo *.texi || die
+}
+
+src_install() {
+ #do not install all the login-utils; we will install login
+ #manually ...
+ cp MCONFIG MCONFIG.orig
+ sed -e "s:HAVE_SHADOW=no:HAVE_SHADOW=yes:" \
+ MCONFIG.orig > MCONFIG
+
+ make DESTDIR=${D} install || die
+
+ into /
+ dobin login-utils/login
+ doman login-utils/login.1
+
+ dodoc HISTORY MAINTAINER README VERSION
+ docinto licenses
+ dodoc licenses/* HISTORY
+ docinto examples
+ dodoc example.files/*
+}
diff --git a/sys-apps/util-linux/util-linux-2.11o.ebuild b/sys-apps/util-linux/util-linux-2.11o.ebuild
index b1d2accdd508..ddc46a3504a1 100644
--- a/sys-apps/util-linux/util-linux-2.11o.ebuild
+++ b/sys-apps/util-linux/util-linux-2.11o.ebuild
@@ -2,11 +2,12 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: System Team <system@gentoo.org>
# Author: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11o.ebuild,v 1.1 2002/04/08 13:47:52 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11o.ebuild,v 1.2 2002/04/26 05:42:18 rphillips Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Various useful Linux utilities"
-SRC_URI="http://www.kernel.org/pub/linux/utils/${PN}/${P}.tar.gz"
+SRC_URI="http://www.kernel.org/pub/linux/utils/${PN}/${P}.tar.gz
+
DEPEND="virtual/glibc >=sys-libs/ncurses-5.2-r2"