summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-19 03:21:25 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-19 03:21:25 +0000
commitef728bf56ec2f69744a18103c2b3370d30eaf1b5 (patch)
treeaabcaf1c148af51ee8fbc44b3a8358c623487d3d /sys-apps/util-linux
parentlintool fixes for #9258 (diff)
downloadhistorical-ef728bf56ec2f69744a18103c2b3370d30eaf1b5.tar.gz
historical-ef728bf56ec2f69744a18103c2b3370d30eaf1b5.tar.bz2
historical-ef728bf56ec2f69744a18103c2b3370d30eaf1b5.zip
lintool fixes for #9258
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/util-linux-2.11o-r3.ebuild23
-rw-r--r--sys-apps/util-linux/util-linux-2.11r-r1.ebuild4
-rw-r--r--sys-apps/util-linux/util-linux-2.11r.ebuild4
3 files changed, 14 insertions, 17 deletions
diff --git a/sys-apps/util-linux/util-linux-2.11o-r3.ebuild b/sys-apps/util-linux/util-linux-2.11o-r3.ebuild
index da8eca0e3a90..58ac3f5f2047 100644
--- a/sys-apps/util-linux/util-linux-2.11o-r3.ebuild
+++ b/sys-apps/util-linux/util-linux-2.11o-r3.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11o-r3.ebuild,v 1.8 2002/10/05 05:39:25 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11o-r3.ebuild,v 1.9 2002/10/19 03:21:25 vapier Exp $
IUSE="nls"
S=${WORKDIR}/${P}
DESCRIPTION="Various useful Linux utilities"
SRC_URI="http://www.kernel.org/pub/linux/utils/${PN}/${P}.tar.gz
- http://www.kernel.org/pub/linux/kernel/people/hvr/util-linux-patch-int/${P}.patch.gz"
+ http://www.kernel.org/pub/linux/kernel/people/hvr/util-linux-patch-int/${P}.patch.gz"
HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
KEYWORDS="x86 ppc sparc sparc64"
LICENSE="GPL-2"
@@ -15,8 +15,7 @@ LICENSE="GPL-2"
DEPEND="virtual/glibc
>=sys-libs/ncurses-5.2-r2
sys-apps/pam-login"
-
-RDEPEND="$DEPEND sys-devel/perl
+RDEPEND="${DEPEND} sys-devel/perl
nls? ( sys-devel/gettext )"
SLOT="0"
@@ -27,18 +26,17 @@ src_unpack() {
cd ${S}
gunzip -c ${DISTDIR}/${P}.patch.gz | patch -p0
cp MCONFIG MCONFIG.orig
- sed -e "s:-pipe -O2 \$(CPUOPT) -fomit-frame-pointer:${CFLAGS}:" \
- -e "s:CPU=.*:CPU=${CHOST%%-*}:" \
- -e "s:HAVE_PAM=no:HAVE_PAM=yes:" \
- -e "s:HAVE_SLN=no:HAVE_SLN=yes:" \
- -e "s:HAVE_TSORT=no:HAVE_TSORT=yes:" \
- -e "s:usr/man:usr/share/man:" \
- -e "s:usr/info:usr/share/info:" \
+ sed -e "s:-pipe -O2 \$(CPUOPT) -fomit-frame-pointer:${CFLAGS}:" \
+ -e "s:CPU=.*:CPU=${CHOST%%-*}:" \
+ -e "s:HAVE_PAM=no:HAVE_PAM=yes:" \
+ -e "s:HAVE_SLN=no:HAVE_SLN=yes:" \
+ -e "s:HAVE_TSORT=no:HAVE_TSORT=yes:" \
+ -e "s:usr/man:usr/share/man:" \
+ -e "s:usr/info:usr/share/info:" \
MCONFIG.orig > MCONFIG
}
src_compile() {
-
./configure || die
if [ -z "`use nls`" ]
@@ -67,4 +65,3 @@ src_install() {
docinto examples
dodoc example.files/*
}
-
diff --git a/sys-apps/util-linux/util-linux-2.11r-r1.ebuild b/sys-apps/util-linux/util-linux-2.11r-r1.ebuild
index bf5252d98363..beedc2569479 100644
--- a/sys-apps/util-linux/util-linux-2.11r-r1.ebuild
+++ b/sys-apps/util-linux/util-linux-2.11r-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11r-r1.ebuild,v 1.9 2002/10/05 05:39:25 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11r-r1.ebuild,v 1.10 2002/10/19 03:21:25 vapier Exp $
IUSE="crypt nls"
S=${WORKDIR}/${P}
DESCRIPTION="Various useful Linux utilities"
SRC_URI="http://www.kernel.org/pub/linux/utils/${PN}/${P}.tar.gz
- http://www.kernel.org/pub/linux/kernel/people/hvr/util-linux-patch-int/${P}.patch.gz"
+ http://www.kernel.org/pub/linux/kernel/people/hvr/util-linux-patch-int/${P}.patch.gz"
HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
KEYWORDS="x86 ppc sparc sparc64"
LICENSE="GPL-2"
diff --git a/sys-apps/util-linux/util-linux-2.11r.ebuild b/sys-apps/util-linux/util-linux-2.11r.ebuild
index b935507ce57a..5a5c221272d9 100644
--- a/sys-apps/util-linux/util-linux-2.11r.ebuild
+++ b/sys-apps/util-linux/util-linux-2.11r.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11r.ebuild,v 1.8 2002/10/05 05:39:25 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11r.ebuild,v 1.9 2002/10/19 03:21:25 vapier Exp $
IUSE="nls"
S=${WORKDIR}/${P}
DESCRIPTION="Various useful Linux utilities"
SRC_URI="http://www.kernel.org/pub/linux/utils/${PN}/${P}.tar.gz
- http://www.kernel.org/pub/linux/kernel/people/hvr/util-linux-patch-int/${P}.patch.gz"
+ http://www.kernel.org/pub/linux/kernel/people/hvr/util-linux-patch-int/${P}.patch.gz"
HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
KEYWORDS="x86 ppc sparc sparc64"
LICENSE="GPL-2"