summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-09-18 05:12:22 +0000
committerDonny Davies <woodchip@gentoo.org>2001-09-18 05:12:22 +0000
commit002b22b044fed9b7a0c40019968a59473f1a5081 (patch)
tree8863de7fb140d35d4e4f34a66112ca2618141aec /sys-apps
parentVery minory edited ebuild to account for new init system (diff)
downloadhistorical-002b22b044fed9b7a0c40019968a59473f1a5081.tar.gz
historical-002b22b044fed9b7a0c40019968a59473f1a5081.tar.bz2
historical-002b22b044fed9b7a0c40019968a59473f1a5081.zip
latest version of iproute2. complete with the compilation fix mentioned on the dev
list, and several other cleanups. removed the old, semi-broken version.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/iproute2/files/digest-iproute2-2.2.4-r31
-rw-r--r--sys-apps/iproute2/files/digest-iproute2-2.4.71
-rw-r--r--sys-apps/iproute2/files/makefile-kernel-includes.diff18
-rw-r--r--sys-apps/iproute2/iproute2-2.2.4-r3.ebuild66
-rw-r--r--sys-apps/iproute2/iproute2-2.4.7.ebuild68
5 files changed, 87 insertions, 67 deletions
diff --git a/sys-apps/iproute2/files/digest-iproute2-2.2.4-r3 b/sys-apps/iproute2/files/digest-iproute2-2.2.4-r3
deleted file mode 100644
index 4bb3a63d1bcb..000000000000
--- a/sys-apps/iproute2/files/digest-iproute2-2.2.4-r3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 70ef05a56f32f73a1ef67ef40d35c37e iproute2-2.2.4-now-ss001007.tar.gz
diff --git a/sys-apps/iproute2/files/digest-iproute2-2.4.7 b/sys-apps/iproute2/files/digest-iproute2-2.4.7
new file mode 100644
index 000000000000..1622edeb5a61
--- /dev/null
+++ b/sys-apps/iproute2/files/digest-iproute2-2.4.7
@@ -0,0 +1 @@
+MD5 b05a4e375d9468be3a1dd3f0e83daee8 iproute2-2.4.7-now-ss010824.tar.gz
diff --git a/sys-apps/iproute2/files/makefile-kernel-includes.diff b/sys-apps/iproute2/files/makefile-kernel-includes.diff
new file mode 100644
index 000000000000..f92d3228dd10
--- /dev/null
+++ b/sys-apps/iproute2/files/makefile-kernel-includes.diff
@@ -0,0 +1,18 @@
+--- Makefile.orig Tue Sep 18 00:02:08 2001
++++ Makefile Tue Sep 18 00:03:25 2001
+@@ -1,5 +1,5 @@
+ # Path to parent kernel include files directory
+-KERNEL_INCLUDE=/usr/src/linux/include
++KERNEL_INCLUDE=/usr/include
+ LIBC_INCLUDE=/usr/include
+
+ DEFINES= -DRESOLVE_HOSTNAMES
+@@ -29,7 +29,7 @@
+
+ CC = gcc
+ CCOPTS = -D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -Werror -g
+-CFLAGS = $(CCOPTS) $(GLIBCFIX) -I$(KERNEL_INCLUDE) -I../include $(DEFINES)
++CFLAGS = $(CCOPTS) $(GLIBCFIX) -I../include $(DEFINES) -I$(KERNEL_INCLUDE)
+
+ LDLIBS += -L../lib -lnetlink -lutil
+
diff --git a/sys-apps/iproute2/iproute2-2.2.4-r3.ebuild b/sys-apps/iproute2/iproute2-2.2.4-r3.ebuild
deleted file mode 100644
index 5a3bcc4580bb..000000000000
--- a/sys-apps/iproute2/iproute2-2.2.4-r3.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.2.4-r3.ebuild,v 1.3 2001/09/15 19:27:22 danarmak Exp $
-
-A=iproute2-2.2.4-now-ss001007.tar.gz
-S=${WORKDIR}/iproute2
-DESCRIPTION="Kernel 2.4 routing and traffic control utilities"
-SRC_URI="ftp://ftp.inr.ac.ru/ip-routing/${A}"
-
-DEPEND="virtual/glibc" # tex? ( app-text/tetex )"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- cp Makefile Makefile.orig
- sed -e '/^KERNEL_INCLUDE/c\' -e 'KERNEL_INCLUDE=/usr/include' Makefile.orig > Makefile
-
- cd ${S}/lib
- cp ll_proto.c ll_proto.c.orig
- sed -e "36 d" ll_proto.c.orig > ll_proto.c
-
-# cp Makefile Makefile.orig
-# sed -e "s/-O2/${CFLAGS}/g" Makefile.orig > Makefile
-# #this next thing is required to enable diffserv (ATM support doesn't compile right now)
-# cp Config Config.orig
-# sed -e 's/DIFFSERV=n/DIFFSERV=y/g' Config.orig > Config
-}
-
-src_compile() {
- try make ${MAKEOPTS}
-# if [ "`use tex`" ]
-# then
-# cd doc
-# try make
-# fi
-}
-
-
-src_install() {
-
- into /
- cd ${S}/ip
- dosbin ifcfg ip routef routel rtacct rtmon rtpr
- cd ${S}/tc
- dosbin tc
- cd ${S}
- dodoc README* RELNOTES
- docinto examples/diffserv
- dodoc examples/diffserv/*
- docinto examples
- dodoc examples/*
- dodir /etc/iproute2
- insinto /etc/iproute2
- doins ${S}/etc/iproute2/*
-
- if [ "`use tex`" ]
- then
- docinto ps
- dodoc doc/*.ps
- fi
-
-}
-
-
diff --git a/sys-apps/iproute2/iproute2-2.4.7.ebuild b/sys-apps/iproute2/iproute2-2.4.7.ebuild
new file mode 100644
index 000000000000..9c440f79ce58
--- /dev/null
+++ b/sys-apps/iproute2/iproute2-2.4.7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.4.7.ebuild,v 1.1 2001/09/18 05:12:22 woodchip Exp $
+
+A=iproute2-2.4.7-now-ss010824.tar.gz
+S=${WORKDIR}/iproute2
+DESCRIPTION="Kernel 2.4 routing and traffic control utilities"
+SRC_URI="ftp://ftp.inr.ac.ru/ip-routing/${A}"
+
+DEPEND="virtual/glibc"
+# if we include tex, it _could_ lead to X being pulled in during emerge system.
+# tex? ( app-text/tetex )"
+
+src_unpack() {
+
+ unpack ${A}
+
+ # we now install the kernel headers used for compiling glibc, directly into
+ # /usr/include/{asm,linux}; which is a good thing(tm). we need to patch
+ # iproute2's Makefile to thusly compile without a /usr/src/linux tree.
+ # ~woodchip
+ cd ${S}
+ patch -p0 < ${FILESDIR}/makefile-kernel-includes.diff || die
+
+ # omits this protocol support from being built: "__PF(PUP,pup)"
+ # the package builds fine without this patch. is there another concern?
+ # ~woodchip
+ # cd ${S}/lib
+ # cp ll_proto.c ll_proto.c.orig
+ # sed -e "36 d" ll_proto.c.orig > ll_proto.c
+
+ # why was this commented out? were the programs segfaulting/not working?
+ # they seem ok here when i compile with optimisations, so im reenabling
+ # this patch. if theres problems, will glady change back. ~woodchip
+ cp Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/g" Makefile.orig > Makefile
+
+ # this next thing is required to enable diffserv (ATM support doesn't compile right now)
+ # cp Config Config.orig
+ # sed -e 's/DIFFSERV=n/DIFFSERV=y/g' Config.orig > Config
+}
+
+src_compile() {
+
+ make ${MAKEOPTS} || die
+ # if [ "`use tex`" ] ; then
+ # cd doc
+ # make || die
+ # fi
+}
+
+src_install() {
+
+ cd ${S}/ip ; dosbin ifcfg ip routef routel rtacct rtmon rtpr
+ cd ${S}/tc ; dosbin tc
+
+ cd ${S} ; dodoc README* RELNOTES
+ docinto examples/diffserv ; dodoc examples/diffserv/*
+ docinto examples ; dodoc examples/*
+
+ dodir /etc/iproute2
+ insinto /etc/iproute2 ; doins ${S}/etc/iproute2/*
+
+ if [ "`use tex`" ] ; then
+ docinto ps ; dodoc doc/*.ps
+ fi
+}