summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2005-04-20 11:47:10 +0000
committerBenedikt Boehm <hollow@gentoo.org>2005-04-20 11:47:10 +0000
commit06397c17e00ee54f92aea1f22b6b576a691e598b (patch)
treeee1a990cd74e43e4797df5a3691c4a49e3f04409 /sys-apps
parentadded baselayout-vserver (diff)
downloadhistorical-06397c17e00ee54f92aea1f22b6b576a691e598b.tar.gz
historical-06397c17e00ee54f92aea1f22b6b576a691e598b.tar.bz2
historical-06397c17e00ee54f92aea1f22b6b576a691e598b.zip
initial version
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/baselayout-vserver/ChangeLog10
-rw-r--r--sys-apps/baselayout-vserver/Manifest16
-rw-r--r--sys-apps/baselayout-vserver/baselayout-vserver-1.0.ebuild425
-rw-r--r--sys-apps/baselayout-vserver/files/copyright45
-rw-r--r--sys-apps/baselayout-vserver/files/digest-baselayout-vserver-1.02
-rw-r--r--sys-apps/baselayout-vserver/files/vserver-changes87
-rw-r--r--sys-apps/baselayout-vserver/metadata.xml8
7 files changed, 593 insertions, 0 deletions
diff --git a/sys-apps/baselayout-vserver/ChangeLog b/sys-apps/baselayout-vserver/ChangeLog
new file mode 100644
index 000000000000..cd3c5efc637e
--- /dev/null
+++ b/sys-apps/baselayout-vserver/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-apps/baselayout-vserver
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout-vserver/ChangeLog,v 1.1 2005/04/20 11:47:10 hollow Exp $
+
+*baselayout-vserver-1.0 (20 Apr 2005)
+
+ 20 Apr 2005; Benedikt Boehm <hollow@gentoo.org> +files/copyright,
+ +files/vserver-changes, +metadata.xml, +baselayout-vserver-1.0.ebuild:
+ Initial version of baselayout-vserver (using rc-scripts-1.7.0)
+
diff --git a/sys-apps/baselayout-vserver/Manifest b/sys-apps/baselayout-vserver/Manifest
new file mode 100644
index 000000000000..dc3db0d40e16
--- /dev/null
+++ b/sys-apps/baselayout-vserver/Manifest
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 ce54dd47d5a880816ed8b3ef30f71d1e baselayout-vserver-1.0.ebuild 12850
+MD5 74c5aadf8e3e9d642a20e64d1afefec8 metadata.xml 239
+MD5 dc82c95d4fbc335ef2a0e8a5039dcdcf ChangeLog 473
+MD5 7c0cd50e4ac1dc062f5e6ab578e95659 files/copyright 2099
+MD5 76a9437d29bd77c416f76fbcf0cf2af2 files/vserver-changes 1642
+MD5 8a0d41f3187138a032d55869caedf650 files/digest-baselayout-vserver-1.0 144
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCZkFzmPFBzbX68WERAs9KAJ0R1bnztO7uZ/MmA6BgaEi1eynPsACeKcjs
+3nt1W1jMNhmhfCYoI23XZGI=
+=fk0r
+-----END PGP SIGNATURE-----
diff --git a/sys-apps/baselayout-vserver/baselayout-vserver-1.0.ebuild b/sys-apps/baselayout-vserver/baselayout-vserver-1.0.ebuild
new file mode 100644
index 000000000000..c2f0bfb7b5b9
--- /dev/null
+++ b/sys-apps/baselayout-vserver/baselayout-vserver-1.0.ebuild
@@ -0,0 +1,425 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout-vserver/baselayout-vserver-1.0.ebuild,v 1.1 2005/04/20 11:47:10 hollow Exp $
+
+inherit flag-o-matic eutils toolchain-funcs multilib
+
+SV=1.7.0 # rc-scripts version
+SVREV= # rc-scripts rev
+
+S="${WORKDIR}/rc-scripts-${SV}${SVREV}"
+
+DESCRIPTION="Filesystem baselayout and init scripts for use in Linux-VServer"
+HOMEPAGE="http://dev.gentoo.org/~hollow/vserver/baselayout"
+SRC_URI="mirror://gentoo/rc-scripts-${SV}${SVREV}.tar.bz2
+ mirror://gentoo/rc-scripts-${SV}${SVREV}-vserver.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="bootstrap build static uclibc"
+
+# This version of baselayout needs gawk in /bin, but as we do not have
+# a c++ compiler during bootstrap, we cannot depend on it if "bootstrap"
+# or "build" are in USE.
+RDEPEND=">=sys-apps/sysvinit-2.84
+ !build? ( !bootstrap? (
+ >=sys-libs/readline-5.0-r1
+ >=app-shells/bash-3.0-r7
+ ) )
+ !sys-apps/baselayout"
+DEPEND="virtual/os-headers"
+PROVIDE="virtual/baselayout"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/rc-scripts-1.7.0-vserver.patch
+
+ # Fix Sparc specific stuff
+ if [[ $(tc-arch) == "sparc" ]] ; then
+ sed -i -e 's:KEYMAP="us":KEYMAP="sunkeymap":' ${S}/etc/rc.conf || die
+ fi
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ make -C ${S}/src CC="$(tc-getCC)" LD="$(tc-getCC) ${LDFLAGS}" \
+ CFLAGS="${CFLAGS}" || die
+}
+
+# ${PATH} should include where to get MAKEDEV when calling this
+# function
+create_dev_nodes() {
+ einfo "Using generic-vserver to make ${ARCH} device nodes..."
+ MAKEDEV generic-vserver
+}
+
+# This is a temporary workaround until bug 9849 is completely solved
+# in portage. We need to create the directories so they're available
+# during src_install, but when src_install is finished, call unkdir
+# to remove any empty directories instead of leaving them around.
+kdir() {
+ typeset -a args
+ typeset d
+
+ # Create the directories for the remainder of src_install, and
+ # remember how to create the directories later.
+ for d in "$@"; do
+ if [[ $d == /* ]]; then
+ install -d "${args[@]}" "${D}/${d}"
+ cat >> "${D}/usr/share/baselayout/mkdirs.sh" <<EOF
+install -d ${args[@]} "\${ROOT}/${d}" 2>/dev/null \\
+ || ewarn " can't create ${d}"
+touch "\${ROOT}/${d}/.keep" 2>/dev/null \\
+ || ewarn " can't create ${d}/.keep"
+EOF
+ else
+ args=("${args[@]}" "${d}")
+ fi
+ done
+}
+
+# Continued from kdir above... This function removes any empty
+# directories as a temporary workaround for bug 9849. The directories
+# (and .keep files) are re-created in pkg_postinst, which means they
+# aren't listed in CONTENTS, unfortunately.
+unkdir() {
+ einfo "Running unkdir to workaround bug 9849"
+ find ${D} -depth -type d -exec rmdir {} \; 2>/dev/null
+ if [[ $? == 127 ]]; then
+ ewarn "Problem running unkdir: find command not found"
+ fi
+}
+
+src_install() {
+ local dir libdirs libdirs_env rcscripts_dir
+
+ # This directory is to stash away things that will be used in
+ # pkg_postinst; it's needed first for kdir to function
+ dodir /usr/share/baselayout
+
+ # Jeremy Huddleston <eradicator@gentoo.org>
+ # For multilib, we want to make sure that all our multilibdirs exist
+ # and make lib even if it's not listed as one (like on amd64/ppc64
+ # which sometimes has lib32/lib64 instead of lib/lib64).
+ # lib should NOT be a symlink to one of the other libdirs.
+ # Old systems with symlinks won't be affected by this change, as the
+ # symlinks already exist and won't get removed, but new systems will
+ # be setup properly.
+ #
+ # I'll be making a script to convert existing systems from symlink to
+ # nosymlink and putting it in /usr/portage/scripts.
+ libdirs=$(get_all_libdirs)
+ : ${libdirs:=lib} # it isn't that we don't trust multilib.eclass...
+
+ # This should be /lib/rcscripts, but we have to support old profiles too.
+ if [ "${SYMLINK_LIB}" = "yes" ]; then
+ rcscripts_dir="/$(get_abi_LIBDIR ${DEFAULT_ABI})/rcscripts"
+ else
+ rcscripts_dir="/lib/rcscripts"
+ fi
+
+ einfo "Creating directories..."
+ kdir /usr
+ kdir /usr/local
+ kdir /boot
+ kdir /dev
+ kdir /dev/pts
+ kdir /dev/shm
+ kdir /etc/conf.d
+ kdir /etc/cron.daily
+ kdir /etc/cron.hourly
+ kdir /etc/cron.monthly
+ kdir /etc/cron.weekly
+ kdir /etc/env.d
+ dodir /etc/init.d # .keep file might mess up init.d stuff
+ kdir /etc/opt
+ kdir /home
+ kdir ${rcscripts_dir}
+ kdir ${rcscripts_dir}/awk
+ kdir ${rcscripts_dir}/sh
+ kdir /opt
+ kdir -o root -g uucp -m0755 /var/lock
+ kdir /proc
+ kdir -m 0700 /root
+ kdir /sbin
+ kdir /sys # for 2.6 kernels
+ kdir /usr/bin
+ kdir /usr/include
+ kdir /usr/include/asm
+ kdir /usr/include/linux
+ kdir /usr/local/bin
+ kdir /usr/local/games
+ kdir /usr/local/sbin
+ kdir /usr/local/share
+ kdir /usr/local/share/doc
+ kdir /usr/local/share/man
+ kdir /usr/local/src
+ kdir /usr/portage
+ kdir /usr/sbin
+ kdir /usr/share/doc
+ kdir /usr/share/info
+ kdir /usr/share/man
+ kdir /usr/share/misc
+ kdir /usr/src
+ kdir -m 1777 /tmp
+ kdir /var
+ dodir /var/db/pkg # .keep file messes up Portage
+ kdir /var/lib/misc
+ kdir /var/lock/subsys
+ kdir /var/log/news
+ kdir /var/run
+ kdir /var/spool
+ kdir /var/state
+ kdir -m 1777 /var/tmp
+
+ for dir in ${libdirs}; do
+ libdirs_env=${libdirs_env:+$libdirs_env:}/${dir}:/usr/${dir}:/usr/local/${dir}
+ [[ ${dir} == "lib" && ${SYMLINK_LIB} == "yes" ]] && continue
+ kdir /${dir}
+ kdir /usr/${dir}
+ kdir /usr/local/${dir}
+ done
+
+ # Ugly compatibility with stupid ebuilds and old profiles symlinks
+ if [[ ${SYMLINK_LIB} == "yes" ]] ; then
+ rm -r "${D}"/{lib,usr/lib,usr/local/lib} &> /dev/null
+ dosym $(get_abi_LIBDIR ${DEFAULT_ABI}) /lib
+ dosym $(get_abi_LIBDIR ${DEFAULT_ABI}) /usr/lib
+ dosym $(get_abi_LIBDIR ${DEFAULT_ABI}) /usr/local/lib
+ fi
+
+ # FHS compatibility symlinks stuff
+ dosym /var/tmp /usr/tmp
+ dosym share/man /usr/local/man
+
+ #
+ # Setup files in /etc
+ #
+ insopts -m0644
+ insinto /etc
+ find ${S}/etc -maxdepth 1 -type f -print0 | xargs --null doins
+
+ # Install some files to /usr/share/baselayout instead of /etc to keep from
+ # (1) overwriting the user's settings, (2) screwing things up when
+ # attempting to merge files, (3) accidentally packaging up personal files
+ # with quickpkg
+ fperms 0600 /etc/shadow
+ mv ${D}/etc/{passwd,shadow,group,hosts,issue.devfix} ${D}/usr/share/baselayout
+
+ cp -P ${S}/init.d/* ${D}/etc/init.d
+ chmod a+x ${D}/etc/init.d/*
+ insinto /etc/conf.d
+ doins ${S}/etc/conf.d/*
+ insinto /etc/env.d
+ doins ${S}/etc/env.d/*
+ insinto /etc/skel
+ find ${S}/etc/skel -maxdepth 1 -type f -print0 | xargs --null doins
+
+ # Special-case uglyness... For people updating from lib32 -> lib amd64
+ # profiles, keep lib32 in the search path while it's around
+ if has_multilib_profile && [ -d /lib32 -o -d /usr/lib32 ] && ! hasq lib32 ${libdirs}; then
+ libdirs_env="${libdirs_env}:/lib32:/usr/lib32:/usr/local/lib32"
+ fi
+
+ # List all the multilib libdirs in /etc/env/04multilib (only if they're
+ # actually different from the normal
+ if has_multilib_profile || [[ $(get_libdir) != "lib" || -n ${CONF_MULTILIBDIR} ]]; then
+ echo "LDPATH=\"${libdirs_env}\"" > ${D}/etc/env.d/04multilib
+ fi
+
+ # As of baselayout-1.10-1-r1, sysvinit is its own package again, and
+ # provides the inittab itself
+ ## We provide our own inittab for vserver
+ #rm -f "${D}"/etc/inittab
+
+ # Stash the rc-lists for use during pkg_postinst
+ cp -r "${S}"/rc-lists "${D}"/usr/share/baselayout
+
+ # uclibc doesn't need nsswitch.conf... added by solar
+ use uclibc && rm -f ${D}/etc/nsswitch.conf
+
+ # rc-scripts version for testing of features that *should* be present
+ echo "Gentoo Base System version ${SV}" > ${D}/etc/gentoo-release
+
+ #
+ # Setup files related to /dev
+ #
+ into /
+ dosbin ${S}/sbin/MAKEDEV
+ dosym ../../sbin/MAKEDEV /usr/sbin/MAKEDEV
+ dosym ../sbin/MAKEDEV /dev/MAKEDEV
+
+ #
+ # Setup files in /bin
+ #
+ cd ${S}/bin
+ dobin rc-status
+
+ #
+ # Setup files in /sbin
+ #
+ cd ${S}/sbin
+ into /
+ dosbin rc rc-update
+ # These moved from /etc/init.d/ to /sbin to help newb systems
+ # from breaking
+ dosbin runscript.sh functions.sh
+
+ # Compat symlinks between /etc/init.d and /sbin
+ # (some stuff have hardcoded paths)
+ dosym ../../sbin/depscan.sh /etc/init.d/depscan.sh
+ dosym ../../sbin/runscript.sh /etc/init.d/runscript.sh
+ dosym ../../sbin/functions.sh /etc/init.d/functions.sh
+
+ #
+ # Setup files in /lib/rcscripts
+ # These are support files for other things in baselayout that needn't be
+ # under CONFIG_PROTECTed /etc
+ #
+ cd ${S}/sbin
+ exeinto ${rcscripts_dir}/sh
+ doexe rc-services.sh rc-daemon.sh rc-help.sh
+
+ # We can only install new, fast awk versions of scripts
+ # if 'build' or 'bootstrap' is not in USE. This will
+ # change if we have sys-apps/gawk-3.1.1-r1 or later in
+ # the build image ...
+ if ! use build; then
+ # This is for new depscan.sh and env-update.sh
+ # written in awk
+ cd ${S}/sbin
+ into /
+ dosbin depscan.sh
+ dosbin env-update.sh
+ insinto ${rcscripts_dir}/awk
+ doins ${S}/src/awk/*.awk
+ fi
+
+ #
+ # Install baselayout documentation
+ #
+ if ! use build ; then
+ doman ${S}/man/*.*
+ docinto /
+ dodoc ${FILESDIR}/copyright
+ dodoc ${S}/ChangeLog
+ dodoc ${FILESDIR}/vserver-changes
+ fi
+
+ #
+ # Install baselayout utilities
+ #
+ cd ${S}/src
+ make DESTDIR="${D}" install || die
+
+ # Hack to fix bug 9849, continued in pkg_postinst
+ unkdir
+}
+
+pkg_postinst() {
+ local x y
+
+ # Reincarnate dirs from kdir/unkdir (hack for bug 9849)
+ einfo "Creating directories and .keep files."
+ einfo "Some of these might fail if they're read-only mounted"
+ einfo "filesystems, for example /dev or /proc. That's okay!"
+ source ${ROOT}/usr/share/baselayout/mkdirs.sh
+
+ # Set up default runlevel symlinks
+ # This used to be done in src_install but required knowledge of ${ROOT},
+ # which meant that it was effectively broken for binary installs.
+ if [[ -z $(/bin/ls ${ROOT}/etc/runlevels 2>/dev/null) ]]; then
+ for x in boot default; do
+ einfo "Creating default runlevel symlinks for ${x}"
+ mkdir -p ${ROOT}/etc/runlevels/${x}
+ for y in $(<${ROOT}/usr/share/baselayout/rc-lists/${x}); do
+ if [[ ! -e ${ROOT}/etc/init.d/${y} ]]; then
+ ewarn "init.d/${y} not found -- ignoring"
+ else
+ ln -sfn ${ROOT}/etc/init.d/${y} \
+ ${ROOT}/etc/runlevels/${x}/${y}
+ fi
+ done
+ done
+ fi
+
+ # Create /etc/hosts in pkg_postinst so we don't overwrite an
+ # existing file during bootstrap
+ if [[ ! -e ${ROOT}/etc/hosts ]]; then
+ cp ${ROOT}/usr/share/baselayout/hosts ${ROOT}/etc
+ fi
+
+ # Touching /etc/passwd and /etc/shadow after install can be fatal, as many
+ # new users do not update them properly... see src_install() for why they
+ # are in /usr/share/baselayout/
+ for x in passwd shadow group fstab ; do
+ if [[ -e ${ROOT}/etc/${x} ]] ; then
+ touch "${ROOT}/etc/${x}"
+ else
+ cp "${ROOT}/usr/share/baselayout/${x}" "${ROOT}/etc/${x}"
+ fi
+ done
+
+ # Under what circumstances would mtab be a symlink? It would be
+ # nice if there were an explanatory comment here
+ #if [[ -L ${ROOT}/etc/mtab ]]; then
+ # rm -f "${ROOT}/etc/mtab"
+ # if [[ ${ROOT} == / ]]; then
+ # cp /proc/mounts "${ROOT}/etc/mtab"
+ # else
+ # touch "${ROOT}/etc/mtab"
+ # fi
+ #fi
+
+ # We should only install empty files if these files don't already exist.
+ [[ -e ${ROOT}/var/log/lastlog ]] || \
+ touch "${ROOT}/var/log/lastlog"
+ [[ -e ${ROOT}/var/run/utmp ]] || \
+ install -m 0664 -g utmp /dev/null "${ROOT}/var/run/utmp"
+ [[ -e ${ROOT}/var/log/wtmp ]] || \
+ install -m 0664 -g utmp /dev/null "${ROOT}/var/log/wtmp"
+
+ # Reload init to fix unmounting problems of / on next reboot.
+ # This is really needed, as without the new version of init cause init
+ # not to quit properly on reboot, and causes a fsck of / on next reboot.
+ if [[ ${ROOT} == / ]] && ! use build && ! use bootstrap; then
+ # Regenerate init.d dependency tree
+ /sbin/depscan.sh &>/dev/null
+ fi
+
+ # Enable shadow groups (we need ROOT=/ here, as grpconv only
+ # operate on / ...).
+ if [[ ${ROOT} == / && \
+ ! -f /etc/gshadow && -x /usr/sbin/grpck && -x /usr/sbin/grpconv ]]
+ then
+ if /usr/sbin/grpck -r &>/dev/null; then
+ /usr/sbin/grpconv
+ else
+ echo
+ ewarn "Running 'grpck' returned errors. Please run it by hand, and then"
+ ewarn "run 'grpconv' afterwards!"
+ echo
+ fi
+ fi
+
+ # This is also written in src_install (so it's in CONTENTS), but
+ # write it here so that the new version is immediately in the file
+ # (without waiting for the user to do etc-update)
+ rm -f ${ROOT}/etc/._cfg????_gentoo-release
+ echo "Gentoo Base System version ${SV}" > ${ROOT}/etc/gentoo-release
+
+ echo
+ einfo "Please be sure to update all pending '._cfg*' files in /etc,"
+ einfo "else things might break at your next reboot! You can use 'etc-update'"
+ einfo "to accomplish this:"
+ einfo
+ einfo " # etc-update"
+ echo
+ einfo "This release of baselayout-vserver supports experimental"
+ einfo "plain init style, gentoo init style will work as expected"
+ echo
+}
diff --git a/sys-apps/baselayout-vserver/files/copyright b/sys-apps/baselayout-vserver/files/copyright
new file mode 100644
index 000000000000..2bdf95eb73a1
--- /dev/null
+++ b/sys-apps/baselayout-vserver/files/copyright
@@ -0,0 +1,45 @@
+This package is maintained for Debian by Bdale Garbee, <bdale@gag.com>.
+
+It was downloaded from ftp.redhat.com, as a source .rpm from the 5.1 release
+tree.
+
+Copyright:
+
+No explicit copyright is asserted. Nick Holloway is the earliest author
+recorded in the sourcecode. I queried him for an explicit statement
+regarding the license status of this work, and this is his reply:
+
+ Date: Tue, 21 Jul 1998 19:57:10 +0100
+ From: Nick Holloway <Nick.Holloway@alfie.demon.co.uk>
+ Message-Id: <199807211857.TAA19068@alfie.demon.co.uk>
+ To: Bdale Garbee <bdale@gag.com>
+ Subject: Re: makedev license?
+
+ > I maintain the makedev package for Debian GNU/Linux. I am about to move
+ > from the ill-fated makedev-1.6 to the makedev-2.3.1 derived from your work
+ > by the folks at Redhat. I don't see any evidence of a copyright assertion
+ > or explicit license statement in the source. Your name appears to be the
+ > earliest attached to the current sourcecode. Am I correct in assuming the
+ > GPL? We try to be meticulous about having our base system be compliant
+ > with our Debian Free Software Guidelines, so I'd like an explicit statement.
+
+ It was never explictly released as GPL, as that would have required
+ including the file COPYING which would have been much larger than the
+ actual MAKEDEV script (I was also too lazy to find out what incantations
+ needed to be made). However, it is intended to be used as anyone sees
+ fit, and the statement under "Copying Policy" is "Freely Redistributable"
+ (see MAKEDEV.lsm from any of the releases I made).
+
+ The more recent modifications were done by Michael K. Johnson at
+ Redhat. I think the understanding was that he would be taking over the
+ maintenance of MAKEDEV (our discussion took place last September).
+
+ The only previous history was (according to an old posting to
+ comp.os.linux) that I started with Jim Winstead's script.
+
+ So, as far as I am concerned, it is consistentwith the Debian FSG.
+
+ --
+ `O O' | Home: Nick.Holloway@alfie.demon.co.uk http://www.alfie.demon.co.uk/
+ // ^ \\ | Work: Nick.Holloway@parallax.co.uk
+
diff --git a/sys-apps/baselayout-vserver/files/digest-baselayout-vserver-1.0 b/sys-apps/baselayout-vserver/files/digest-baselayout-vserver-1.0
new file mode 100644
index 000000000000..768ff4ef6930
--- /dev/null
+++ b/sys-apps/baselayout-vserver/files/digest-baselayout-vserver-1.0
@@ -0,0 +1,2 @@
+MD5 afa07a4242fab5d085813c8e97a43345 rc-scripts-1.7.0.tar.bz2 162694
+MD5 0b1e8979419aff03e1c44671b1f2a8bd rc-scripts-1.7.0-vserver.patch 333240
diff --git a/sys-apps/baselayout-vserver/files/vserver-changes b/sys-apps/baselayout-vserver/files/vserver-changes
new file mode 100644
index 000000000000..9156cdffb70b
--- /dev/null
+++ b/sys-apps/baselayout-vserver/files/vserver-changes
@@ -0,0 +1,87 @@
+* bin/bashlogin
+ removed, only used by livecds
+
+* bin/rc-status
+ removed handling of single runlevel
+
+* etc/conf.d
+ removed config for init scripts (clock, crypto-loop
+ net, wireless)
+
+* etc/modules*
+ removed, no modules in vservers
+
+* etc/ppp
+ Removed
+
+* etc/inittab
+ removed tty handling, ctrlaltdel and X
+ commented runlevel 1 and 2
+
+* etc/profile
+ fixed bashrc path
+
+* etc/rc, etc/conf.d/rc
+ removed unused config options
+
+* etc/sysctl.conf
+ commented all options
+
+* etc/init.d
+ removed init scripts unusable in vservers:
+ - checkfs
+ - checkroot
+ - clock
+ - consolefont
+ - crypto-loop
+ - localmount
+ - modules
+ - net*
+ - numlock
+
+* etc/bootmisc
+ fixed depend, removed dmesg (no permission)
+
+* etc/{domainname,hostname,rmnologin,urandom}
+ fixed depend
+
+* etc/halt.sh
+ removed misc stuff (mount, devfs, ups)
+
+* etc/keymaps
+ fixed depend, removed terminal encodings (we have no terminals)
+
+* etc/{reboot.sh,shutdown.sh}
+ removed stopping of interfaces
+ added forced reboot (no initctl in vservers with init style = "gentoo") (TODO: remove gentoo init style)
+
+* lib/
+ removed (only net.* helpers in here)
+
+* man/modules*
+ removed, no modules in vservers
+
+* rc-lists/{boot,default}
+ removed unusable init scripts
+
+* rc-lists/nonetwork
+ removed, runlevel does not exist in vservers
+
+* sbin/MAKEDEV
+ added minimal vserver devices
+
+* sbin/functions
+ removed unused functions and options
+
+* sbin/{livecd-functions.sh,modules-update}
+ removed, not needed
+
+* sbin/rc-services
+ removed unused functions
+
+* sbin/rc
+ removed incompatibilities with vservers
+
+* sbin/runscript.sh
+ removed handling of net.* init scripts
+ removed single runlevel
diff --git a/sys-apps/baselayout-vserver/metadata.xml b/sys-apps/baselayout-vserver/metadata.xml
new file mode 100644
index 000000000000..7858f6985354
--- /dev/null
+++ b/sys-apps/baselayout-vserver/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hollow@gentoo.org</email>
+ <name>Benedikt Boehm</name>
+ </maintainer>
+</pkgmetadata>