summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-01-14 15:51:13 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-01-14 15:51:13 +0000
commit08ae81e6c1e5c7786d34eab5c91102381197ec41 (patch)
treeb29e5708d1fa36780f739f6ab87bca10d327c229 /sys-apps
parentcorrected java-config calls in the startup script. fixes bug #77912. (diff)
downloadhistorical-08ae81e6c1e5c7786d34eab5c91102381197ec41.tar.gz
historical-08ae81e6c1e5c7786d34eab5c91102381197ec41.tar.bz2
historical-08ae81e6c1e5c7786d34eab5c91102381197ec41.zip
changed the multilib part of src_install to just du* rather than use make as the 'make' way was too ugly/kludgey...
Package-Manager: portage-2.0.51-r12
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/portage/Manifest12
-rw-r--r--sys-apps/portage/portage-2.0.51-r10.ebuild23
-rw-r--r--sys-apps/portage/portage-2.0.51-r11.ebuild23
-rw-r--r--sys-apps/portage/portage-2.0.51-r12.ebuild23
4 files changed, 39 insertions, 42 deletions
diff --git a/sys-apps/portage/Manifest b/sys-apps/portage/Manifest
index 379778669fce..608e58262378 100644
--- a/sys-apps/portage/Manifest
+++ b/sys-apps/portage/Manifest
@@ -4,9 +4,9 @@ Hash: SHA1
MD5 c697b628359c7055961817876804f0a6 metadata.xml 221
MD5 ba4ae80e5e6cf58aac9c5aa1cc5f777e ChangeLog 411
MD5 838be491686bbc8355f44e91020e425c portage-2.0.51-r3.ebuild 12549
-MD5 1f574fe53932151d92feb29286ec1115 portage-2.0.51-r12.ebuild 13291
-MD5 a2f8e45c527bbc7a6e4d464c236a4b65 portage-2.0.51-r11.ebuild 13291
-MD5 0b4e04de236db5195da59c1ee2a29472 portage-2.0.51-r10.ebuild 13291
+MD5 8c0de8f88d1caaf30287a2042fc2ad24 portage-2.0.51-r12.ebuild 13050
+MD5 eafbd0b35fc16bab12294b9bec65fc88 portage-2.0.51-r11.ebuild 13050
+MD5 6b6502688f9b9b676e8a524f3a846d72 portage-2.0.51-r10.ebuild 13050
MD5 a754ca9e2eea9f8484bf5f93d339043a files/README.RESCUE 1911
MD5 5ea5d3ffe4a24cd1c719420cd0a2de11 files/digest-portage-2.0.51-r3 70
MD5 ded45fee9effe9096a69c8be02263a7a files/digest-portage-2.0.51-r12 71
@@ -16,7 +16,7 @@ MD5 4db139ef78ff65c537654f5f7e512dfd files/digest-portage-2.0.51-r10 71
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)
-iD8DBQFB5+FmArHZZzCEUG0RAqAIAJ4rcHUcXTnfOEaxtQAYdGURH2QgUACcCL1U
-CvNO5myMZNa/7PlkEdnKrFg=
-=DWDE
+iD8DBQFB5+p8ArHZZzCEUG0RAtF9AJ0bRrXSWu3uXSlScPKw/HEowVw/9gCdEy6U
+/dg87OAW8Ek29QHPYee0C8A=
+=jkjq
-----END PGP SIGNATURE-----
diff --git a/sys-apps/portage/portage-2.0.51-r10.ebuild b/sys-apps/portage/portage-2.0.51-r10.ebuild
index 6987c7f2f54f..da213091d6de 100644
--- a/sys-apps/portage/portage-2.0.51-r10.ebuild
+++ b/sys-apps/portage/portage-2.0.51-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51-r10.ebuild,v 1.6 2005/01/14 15:12:10 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51-r10.ebuild,v 1.7 2005/01/14 15:51:13 eradicator Exp $
inherit flag-o-matic eutils toolchain-funcs
@@ -134,20 +134,19 @@ src_install() {
if use ppc-macos || use x86-fbsd; then
ewarn "Not installing sandbox on ${ARCH}"
elif [ -n "${MULTILIB_ABIS}" ]; then
+ into /
OABI="${ABI}"
for ABI in ${MULTILIB_ABIS}; do
- cp libsandbox.so.${ABI} libsandbox.so
- touch libsandbox.so
- make DESTDIR="${D}" install || \
- die "Failed to install sandbox"
- if [ "$(get_libdir)" = "lib" ]; then
- mv ${D}/lib/libsandbox.so ${D}/lib/libsandbox.so.lib
- else
- dodir /$(get_libdir)
- mv ${D}/lib/libsandbox.so ${D}/$(get_libdir)
- fi
+ newlib.so libsandbox.so.${ABI} libsandbox.so
done
- [ -f "${D}/lib/libsandbox.so.lib" ] && mv ${D}/lib/libsandbox.so.lib ${D}/lib/libsandbox.so
+ into /usr
+
+ exeinto /usr/lib/portage/bin
+ doexe sandbox
+
+ insinto /usr/lib/portage/lib
+ doins sandbox.bashrc
+
ABI="${OABI}"
elif [ "${ARCH}" == "amd64" -a -z "${MULTILIB_ABIS}" ]; then
check_multilib
diff --git a/sys-apps/portage/portage-2.0.51-r11.ebuild b/sys-apps/portage/portage-2.0.51-r11.ebuild
index 5dd301c2d1d1..afba0a42c91b 100644
--- a/sys-apps/portage/portage-2.0.51-r11.ebuild
+++ b/sys-apps/portage/portage-2.0.51-r11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51-r11.ebuild,v 1.3 2005/01/14 15:12:10 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51-r11.ebuild,v 1.4 2005/01/14 15:51:13 eradicator Exp $
inherit flag-o-matic eutils toolchain-funcs
@@ -134,20 +134,19 @@ src_install() {
if use ppc-macos || use x86-fbsd; then
ewarn "Not installing sandbox on ${ARCH}"
elif [ -n "${MULTILIB_ABIS}" ]; then
+ into /
OABI="${ABI}"
for ABI in ${MULTILIB_ABIS}; do
- cp libsandbox.so.${ABI} libsandbox.so
- touch libsandbox.so
- make DESTDIR="${D}" install || \
- die "Failed to install sandbox"
- if [ "$(get_libdir)" = "lib" ]; then
- mv ${D}/lib/libsandbox.so ${D}/lib/libsandbox.so.lib
- else
- dodir /$(get_libdir)
- mv ${D}/lib/libsandbox.so ${D}/$(get_libdir)
- fi
+ newlib.so libsandbox.so.${ABI} libsandbox.so
done
- [ -f "${D}/lib/libsandbox.so.lib" ] && mv ${D}/lib/libsandbox.so.lib ${D}/lib/libsandbox.so
+ into /usr
+
+ exeinto /usr/lib/portage/bin
+ doexe sandbox
+
+ insinto /usr/lib/portage/lib
+ doins sandbox.bashrc
+
ABI="${OABI}"
elif [ "${ARCH}" == "amd64" -a -z "${MULTILIB_ABIS}" ]; then
check_multilib
diff --git a/sys-apps/portage/portage-2.0.51-r12.ebuild b/sys-apps/portage/portage-2.0.51-r12.ebuild
index 2aa63db76358..4c9662f500d8 100644
--- a/sys-apps/portage/portage-2.0.51-r12.ebuild
+++ b/sys-apps/portage/portage-2.0.51-r12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51-r12.ebuild,v 1.3 2005/01/14 15:12:10 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51-r12.ebuild,v 1.4 2005/01/14 15:51:13 eradicator Exp $
inherit flag-o-matic eutils toolchain-funcs
@@ -134,20 +134,19 @@ src_install() {
if use ppc-macos || use x86-fbsd; then
ewarn "Not installing sandbox on ${ARCH}"
elif [ -n "${MULTILIB_ABIS}" ]; then
+ into /
OABI="${ABI}"
for ABI in ${MULTILIB_ABIS}; do
- cp libsandbox.so.${ABI} libsandbox.so
- touch libsandbox.so
- make DESTDIR="${D}" install || \
- die "Failed to install sandbox"
- if [ "$(get_libdir)" = "lib" ]; then
- mv ${D}/lib/libsandbox.so ${D}/lib/libsandbox.so.lib
- else
- dodir /$(get_libdir)
- mv ${D}/lib/libsandbox.so ${D}/$(get_libdir)
- fi
+ newlib.so libsandbox.so.${ABI} libsandbox.so
done
- [ -f "${D}/lib/libsandbox.so.lib" ] && mv ${D}/lib/libsandbox.so.lib ${D}/lib/libsandbox.so
+ into /usr
+
+ exeinto /usr/lib/portage/bin
+ doexe sandbox
+
+ insinto /usr/lib/portage/lib
+ doins sandbox.bashrc
+
ABI="${OABI}"
elif [ "${ARCH}" == "amd64" -a -z "${MULTILIB_ABIS}" ]; then
check_multilib