summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-10-19 22:38:35 +0000
committerMike Frysinger <vapier@gentoo.org>2010-10-19 22:38:35 +0000
commit84d5e87ffde929de644722eb9b2c34a9b40dd118 (patch)
treea16f7bf8efeed3efdb45bd0f62e0fb07cf73dfcb /sys-apps
parentdrop unnecessary sed -- pkg itself does this now (diff)
downloadhistorical-84d5e87ffde929de644722eb9b2c34a9b40dd118.tar.gz
historical-84d5e87ffde929de644722eb9b2c34a9b40dd118.tar.bz2
historical-84d5e87ffde929de644722eb9b2c34a9b40dd118.zip
old
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/smartmontools/files/smartmontools-5.36-utf8.patch34
-rw-r--r--sys-apps/smartmontools/smartmontools-5.38-r1.ebuild44
2 files changed, 0 insertions, 78 deletions
diff --git a/sys-apps/smartmontools/files/smartmontools-5.36-utf8.patch b/sys-apps/smartmontools/files/smartmontools-5.36-utf8.patch
deleted file mode 100644
index a6bf3617c8c6..000000000000
--- a/sys-apps/smartmontools/files/smartmontools-5.36-utf8.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Fix separator usage in UTF8 output
-
-http://bugs.gentoo.org/139409
-http://sourceforge.net/mailarchive/forum.php?thread_id=14805424&forum_id=12495
-
---- smartmontools-5.36/ataprint.c
-+++ smartmontools-5.36/ataprint.c
-@@ -445,7 +445,7 @@
- unsigned short lba_64 = drive->words088_255[103-88];
- uint64_t capacity_short=0, capacity=0, threedigits, power_of_ten;
- int started=0,k=1000000000;
-- char separator=',';
-+ char *separator=",";
-
- // get correct character to use as thousands separator
- #ifdef HAVE_LOCALE_H
-@@ -453,7 +453,7 @@
- setlocale (LC_ALL, "");
- currentlocale=localeconv();
- if (*(currentlocale->thousands_sep))
-- separator=*(currentlocale->thousands_sep);
-+ separator=currentlocale->thousands_sep;
- #endif // #ifdef HAVE_LOCALE_H
-
- // if drive supports LBA addressing, determine 32-bit LBA capacity
-@@ -485,7 +485,7 @@
- capacity -= threedigits*power_of_ten;
- if (started)
- // we have already printed some digits
-- pstring += sprintf(pstring, "%c%03"PRIu64, separator, threedigits);
-+ pstring += sprintf(pstring, "%s%03"PRIu64, separator, threedigits);
- else if (threedigits || k==6) {
- // these are the first digits that we are printing
- pstring += sprintf(pstring, "%"PRIu64, threedigits);
diff --git a/sys-apps/smartmontools/smartmontools-5.38-r1.ebuild b/sys-apps/smartmontools/smartmontools-5.38-r1.ebuild
deleted file mode 100644
index 9b7734ca3cff..000000000000
--- a/sys-apps/smartmontools/smartmontools-5.38-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-5.38-r1.ebuild,v 1.1 2009/08/26 23:08:15 robbat2 Exp $
-
-inherit flag-o-matic
-
-DESCRIPTION="control and monitor storage systems using the Self-Monitoring, Analysis and Reporting Technology System (S.M.A.R.T.)"
-HOMEPAGE="http://smartmontools.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE="static minimal"
-
-RDEPEND="!minimal? ( virtual/mailx )"
-DEPEND=""
-
-src_compile() {
- use minimal && einfo "Skipping the monitoring daemon for minimal build."
- use static && append-ldflags -static
- econf || die
- emake || die
-}
-
-src_install() {
- dosbin smartctl || die "dosbin smartctl"
- dodoc AUTHORS CHANGELOG NEWS README TODO WARNINGS
- doman smartctl.8
- if ! use minimal; then
- dosbin smartd || die "dosbin smartd"
- doman smartd*.[58]
- newdoc smartd.conf smartd.conf.example
- docinto examplescripts
- dodoc examplescripts/*
- rm -f "${D}"/usr/share/doc/${PF}/examplescripts/Makefile*
-
- insinto /etc
- doins smartd.conf
-
- newinitd "${FILESDIR}"/smartd.rc smartd
- newconfd "${FILESDIR}"/smartd.confd smartd
- fi
-}