summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-08-01 18:19:03 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-08-01 18:19:03 +0000
commitfce1ae9082c43f8e6fb340ce9df9c14b080086ca (patch)
tree20fee9b2b0d0bc2ef7b3e8a07a5734e0ba0d4d25 /sys-apps
parentfixing #24238 (diff)
downloadhistorical-fce1ae9082c43f8e6fb340ce9df9c14b080086ca.tar.gz
historical-fce1ae9082c43f8e6fb340ce9df9c14b080086ca.tar.bz2
historical-fce1ae9082c43f8e6fb340ce9df9c14b080086ca.zip
fixing #24238
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/diffutils/Manifest4
-rw-r--r--sys-apps/diffutils/diffutils-2.8.4-r4.ebuild76
-rw-r--r--sys-apps/diffutils/files/diffutils-2.8.4-tabsize-dumps-core.diff20
-rw-r--r--sys-apps/diffutils/files/digest-diffutils-2.8.4-r41
4 files changed, 99 insertions, 2 deletions
diff --git a/sys-apps/diffutils/Manifest b/sys-apps/diffutils/Manifest
index aeda17e80ac0..fd34632f0510 100644
--- a/sys-apps/diffutils/Manifest
+++ b/sys-apps/diffutils/Manifest
@@ -1,8 +1,8 @@
MD5 29d178467060a9f681bb8f08f869b4eb diffutils-2.7.7.ebuild 1435
MD5 fb3f0b366432c518460394a6ab49d0b0 diffutils-2.8.4-r2.ebuild 1846
-MD5 5e82162a3ba531d70062c10c32f97185 diffutils-2.8.4-r4.ebuild 2051
+MD5 b018901bb6e4a0fc38251fb9c8dee6b5 diffutils-2.8.4-r4.ebuild 2050
MD5 519c697cd987d2c7d00f699dce0a822c diffutils-2.8.4-r1.ebuild 1643
-MD5 c38d1a0eba9e9aa39026909268b07241 ChangeLog 3287
+MD5 68e0100a1bab17ffa18d4b989e3a8e88 ChangeLog 3415
MD5 49b165126655112966b466b8e26c2cbc diffutils-2.8.4-r3.ebuild 1907
MD5 a571ebf3fcef3b033e33a4f013521e13 files/diffutils-2.8.4-tabsize-dumps-core.diff 804
MD5 9529ec57ddcde7ce5c18cef8de250645 files/digest-diffutils-2.7.7 67
diff --git a/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild b/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild
new file mode 100644
index 000000000000..bdbeaa5c4eb7
--- /dev/null
+++ b/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild,v 1.1 2003/08/01 18:18:55 taviso Exp $
+
+IUSE="nls build static"
+
+inherit eutils
+inherit flag-o-matic
+
+# sdiff SIGSEGVs with this on gcc-3.2.1, so take it out
+# this fixes bug #13502
+filter-flags "-mpowerpc-gfxopt"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Tools to make diffs and compare files"
+SRC_URI="ftp://alpha.gnu.org/gnu/diffutils/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/diffutils/diffutils.html"
+
+KEYWORDS="~x86 ~alpha"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ >=sys-apps/portage-2.0.47-r10
+ >=sys-apps/sed-4
+ nls? ( sys-devel/gettext )
+ !build? ( sys-apps/texinfo sys-apps/help2man )"
+
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ if [ -n "`use build`" ] ; then
+ #disable texinfo building so we can remove the dep
+ sed -i -e 's:SUBDIRS = doc:SUBDIRS =:' \
+ Makefile.in || die "Makefile.in sed"
+ fi
+
+ # Build fails with make -j5 or greater on pentium4. This is because
+ # the jobs creating the opjects, which depend on paths.h is sheduled
+ # at the same time paths.h is generated. This patch just fix a small
+ # typeo that caused this. This closes bug #8934.
+ # <azarah@gentoo.org> (14 Oct 2002)
+ epatch ${FILESDIR}/${P}-Makefile-fix-typeo.patch
+
+ # Removes waitpid() call after pclose() on piped diff stream, closing
+ # bug #11728, thanks to D Wollmann <converter@dalnet-perl.org>
+ epatch ${FILESDIR}/${P}-sdiff-no-waitpid.patch
+
+ # --tabsize option, undocumented in diff but used in sdiff, makes
+ # diff dump core.
+ # <taviso@gentoo.org> (1 Aug 2003)
+ epatch ${FILESDIR}/${P}-tabsize-dumps-core.diff
+}
+
+src_compile() {
+ econf --build=${CHOST} `use_enable nls` || die "econf"
+
+ if [ "`use static`" ] ; then
+ emake LDFLAGS=-static || die
+ else
+ emake || die
+ fi
+}
+
+src_install() {
+ einstall
+
+ if [ -z "`use build`" ] ; then
+ dodoc COPYING ChangeLog NEWS README
+ else
+ rm -rf ${D}/usr/share/info
+ fi
+}
diff --git a/sys-apps/diffutils/files/diffutils-2.8.4-tabsize-dumps-core.diff b/sys-apps/diffutils/files/diffutils-2.8.4-tabsize-dumps-core.diff
new file mode 100644
index 000000000000..acc79f0bba8e
--- /dev/null
+++ b/sys-apps/diffutils/files/diffutils-2.8.4-tabsize-dumps-core.diff
@@ -0,0 +1,20 @@
+############################################################
+# Added by Tavis Ormandy <taviso@gentoo.org> 01/08/2003
+# Reproduce with
+#
+# $ diff --tabsize
+# Segmentation fault.
+#
+###############################
+diff -ruN diffutils-2.8.4.orig/src/diff.c diffutils-2.8.4/src/diff.c
+--- diffutils-2.8.4.orig/src/diff.c 2002-06-17 06:55:42.000000000 +0100
++++ diffutils-2.8.4/src/diff.c 2003-08-01 17:51:58.000000000 +0100
+@@ -234,7 +234,7 @@
+ {"starting-file", 1, 0, 'S'},
+ {"strip-trailing-cr", 0, 0, STRIP_TRAILING_CR_OPTION},
+ {"suppress-common-lines", 0, 0, SUPPRESS_COMMON_LINES_OPTION},
+- {"tabsize", 0, 0, TABSIZE_OPTION},
++ {"tabsize", 1, 0, TABSIZE_OPTION},
+ {"text", 0, 0, 'a'},
+ {"to-file", 1, 0, TO_FILE_OPTION},
+ {"unchanged-group-format", 1, 0, UNCHANGED_GROUP_FORMAT_OPTION},
diff --git a/sys-apps/diffutils/files/digest-diffutils-2.8.4-r4 b/sys-apps/diffutils/files/digest-diffutils-2.8.4-r4
new file mode 100644
index 000000000000..ab1523b47820
--- /dev/null
+++ b/sys-apps/diffutils/files/digest-diffutils-2.8.4-r4
@@ -0,0 +1 @@
+MD5 a9c028579abc79ecd6842d60a13abf1d diffutils-2.8.4.tar.gz 828766