summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-01-02 19:30:34 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-01-02 19:30:34 +0000
commitb4b69ade32bcc555b55c414e99c2333eed863c4e (patch)
tree62896f7338a1694978fce495d4d7792adf222472 /sys-auth/nss-mdns/nss-mdns-0.9.ebuild
parentBump to version 1.2; bug 149228 (diff)
downloadhistorical-b4b69ade32bcc555b55c414e99c2333eed863c4e.tar.gz
historical-b4b69ade32bcc555b55c414e99c2333eed863c4e.tar.bz2
historical-b4b69ade32bcc555b55c414e99c2333eed863c4e.zip
version bump from upstream
Package-Manager: portage-2.1.2_rc4-r4
Diffstat (limited to 'sys-auth/nss-mdns/nss-mdns-0.9.ebuild')
-rw-r--r--sys-auth/nss-mdns/nss-mdns-0.9.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/sys-auth/nss-mdns/nss-mdns-0.9.ebuild b/sys-auth/nss-mdns/nss-mdns-0.9.ebuild
new file mode 100644
index 000000000000..df91cdbfdd77
--- /dev/null
+++ b/sys-auth/nss-mdns/nss-mdns-0.9.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-mdns/nss-mdns-0.9.ebuild,v 1.1 2007/01/02 19:30:34 compnerd Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.9"
+
+inherit autotools eutils
+
+DESCRIPTION="Name Service Switch module for Multicast DNS"
+HOMEPAGE="http://0pointer.de/lennart/projects/nss-mdns/"
+SRC_URI="http://0pointer.de/lennart/projects/nss-mdns/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="avahi"
+
+DEPEND="avahi? ( net-dns/avahi )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-0.8-avahi-socket.patch
+ eautomake
+}
+
+src_compile() {
+ econf --enable-legacy --enable-search-domains $(use_enable avahi) || die "configure failed"
+ emake || die "compile failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+
+ insinto /etc
+ doins ${FILESDIR}/mdns.allow
+
+ dodoc README
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "You must modify your name service switch look up file to enable"
+ ewarn "multicast DNS lookups. If you wish to resolve only IPv6 addresses"
+ ewarn "use mdns6. For IPv4 addresses only, use mdns4. To resolve both"
+ ewarn "use mdns. Keep in mind that mdns will be slower if there are no"
+ ewarn "IPv6 addresses published via mDNS on the network. There are also"
+ ewarn "minimal (mdns?_minimal) libraries which only lookup .local hosts"
+ ewarn "and 169.254.x.x addresses."
+ ewarn
+ ewarn "Add the appropriate mdns into the hosts line in /etc/nsswitch.conf"
+ ewarn "An example line looks like:"
+ einfo "hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4"
+ ewarn
+ ewarn "If you want to perform mDNS lookups for domains other than the ones"
+ ewarn "ending in .local, add them to /etc/mdns.allow"
+ ewarn
+ ebeep 5
+ epause 10
+}