summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-03-08 20:01:48 +0000
committerMike Frysinger <vapier@gentoo.org>2009-03-08 20:01:48 +0000
commitce76de5282089b44cedad2631d29664f71ca43e4 (patch)
treef6563e4b7c92df519f1126be25ebaf833136737e /sys-auth/pam_bioapi/pam_bioapi-0.4.0-r1.ebuild
parentDrop KDE 4.2.0 (diff)
downloadhistorical-ce76de5282089b44cedad2631d29664f71ca43e4.tar.gz
historical-ce76de5282089b44cedad2631d29664f71ca43e4.tar.bz2
historical-ce76de5282089b44cedad2631d29664f71ca43e4.zip
Do not add version info to pam module #261598 and fix up pam.d files #261677 (both by Diego E. Pettenò).
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'sys-auth/pam_bioapi/pam_bioapi-0.4.0-r1.ebuild')
-rw-r--r--sys-auth/pam_bioapi/pam_bioapi-0.4.0-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-auth/pam_bioapi/pam_bioapi-0.4.0-r1.ebuild b/sys-auth/pam_bioapi/pam_bioapi-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..bb068a802bad
--- /dev/null
+++ b/sys-auth/pam_bioapi/pam_bioapi-0.4.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_bioapi/pam_bioapi-0.4.0-r1.ebuild,v 1.1 2009/03/08 20:01:48 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="PAM interface to bioapi package"
+HOMEPAGE="http://code.google.com/p/pam-bioapi/"
+SRC_URI="http://pam-bioapi.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="sys-auth/bioapi
+ sys-libs/pam
+ dev-db/sqlite"
+RDEPEND="${DEPEND}
+ sys-auth/tfm-fingerprint"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-headers.patch #241322
+ sed -i \
+ -e 's/-version-info 0:4:0/-avoid-version/' \
+ libpam_bioapi/Makefile.in #261598
+ sed -i \
+ -e 's:@prefix@::' \
+ -e '/pam_unix.so/s:.*:auth include system-auth:' \
+ etc/pam.d/{bioapi_chbird,test-pam_bioapi}.in #261598
+}
+
+src_compile() {
+ econf --sbindir=/sbin || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/security "${D}"/$(get_libdir)/ || die
+ rm -f "${D}"/$(get_libdir)/security/*.la
+}