summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-05-16 09:09:20 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-05-16 09:09:20 +0000
commit73ef18efbe36f20479a1ad03df63b4b9d2f1c4d2 (patch)
treebbb69fc9e29f65c792e08dfa567a001f5d100027 /sys-auth/pam_chroot/pam_chroot-0.9.2.ebuild
parentVersion bump to latest. Drop older. (diff)
downloadhistorical-73ef18efbe36f20479a1ad03df63b4b9d2f1c4d2.tar.gz
historical-73ef18efbe36f20479a1ad03df63b4b9d2f1c4d2.tar.bz2
historical-73ef18efbe36f20479a1ad03df63b4b9d2f1c4d2.zip
Remove old version; bypass Makefile and simply build the module within the ebuild, so that -Werror is dropped.
Package-Manager: portage-2.2.0_alpha33/cvs/Linux x86_64
Diffstat (limited to 'sys-auth/pam_chroot/pam_chroot-0.9.2.ebuild')
-rw-r--r--sys-auth/pam_chroot/pam_chroot-0.9.2.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/sys-auth/pam_chroot/pam_chroot-0.9.2.ebuild b/sys-auth/pam_chroot/pam_chroot-0.9.2.ebuild
index e496dfe748b9..707e576da75c 100644
--- a/sys-auth/pam_chroot/pam_chroot-0.9.2.ebuild
+++ b/sys-auth/pam_chroot/pam_chroot-0.9.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_chroot/pam_chroot-0.9.2.ebuild,v 1.2 2008/03/21 14:34:13 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_chroot/pam_chroot-0.9.2.ebuild,v 1.3 2011/05/16 09:09:19 flameeyes Exp $
inherit toolchain-funcs pam flag-o-matic eutils
@@ -17,9 +17,15 @@ DEPEND="virtual/pam
!<sys-libs/pam-0.99"
RDEPEND="${DEPEND}"
+doecho() {
+ echo "$@"
+ "$@" || die
+}
+
src_compile() {
- LDFLAGS="$(raw-ldflags)" emake \
- CC="$(tc-getCC)" LD="$(tc-getLD)" || die "emake failed"
+ # using the Makefile would require patching it to work properly, so
+ # rather simply re-create it here.
+ doecho $(tc-getCC) ${LDFLAGS} -shared -fPIC ${CFLAGS} ${PN}.c -o ${PN}.so -lpam
}
src_install() {