summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-12 16:22:46 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-12 16:22:46 +0000
commit77a3abb648fee10dc5a4ccc8cc9498940c5d5267 (patch)
tree704058ad210143a9f9730b2b78b1e5487fec870a /sys-auth/pam_dotfile/pam_dotfile-0.7-r1.ebuild
parentVersion bump (diff)
downloadhistorical-77a3abb648fee10dc5a4ccc8cc9498940c5d5267.tar.gz
historical-77a3abb648fee10dc5a4ccc8cc9498940c5d5267.tar.bz2
historical-77a3abb648fee10dc5a4ccc8cc9498940c5d5267.zip
Use autotools eclass and depend on correct versions of autotools. Thanks to Patrick Lauer for reporting in bug #151033.
Package-Manager: portage-2.1.2_pre2-r9
Diffstat (limited to 'sys-auth/pam_dotfile/pam_dotfile-0.7-r1.ebuild')
-rw-r--r--sys-auth/pam_dotfile/pam_dotfile-0.7-r1.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/sys-auth/pam_dotfile/pam_dotfile-0.7-r1.ebuild b/sys-auth/pam_dotfile/pam_dotfile-0.7-r1.ebuild
index 134a040b4394..21090cf0509f 100644
--- a/sys-auth/pam_dotfile/pam_dotfile-0.7-r1.ebuild
+++ b/sys-auth/pam_dotfile/pam_dotfile-0.7-r1.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_dotfile/pam_dotfile-0.7-r1.ebuild,v 1.3 2006/05/24 20:49:27 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_dotfile/pam_dotfile-0.7-r1.ebuild,v 1.4 2006/10/12 16:22:46 flameeyes Exp $
-inherit eutils pam
+WANT_AUTOMAKE="latest"
+WANT_AUTOCONF="latest"
+
+inherit eutils pam autotools
MY_P="${P/_beta/beta}"
S="${WORKDIR}/${MY_P}"
@@ -22,13 +25,11 @@ DEPEND="doc? ( www-client/lynx )
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
EPATCH_SUFFIX="patch" epatch ${WORKDIR}/${PV}
- sed -i -e 's:./configure:#./configure:' ${S}/bootstrap.sh
- sed -i -e "s:aclocal:aclocal -I ${WORKDIR}/${PV}/m4:" ${S}/bootstrap.sh
- sh bootstrap.sh
+ AT_M4DIR="${WORKDIR}/${PV}/m4" eautoreconf
}
src_compile() {