summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2013-08-28 06:00:48 +0000
committerUlrich Müller <ulm@gentoo.org>2013-08-28 06:00:48 +0000
commit0a0696fb9d9c05a29b45bc6a48b390f3fa6f57db (patch)
tree4fcc0a2fd3e6d77fffcd15424b102a806ff2536a /sys-auth/pam_skey/pam_skey-1.1.5-r5.ebuild
parentarm stable, bug #481824 (diff)
downloadhistorical-0a0696fb9d9c05a29b45bc6a48b390f3fa6f57db.tar.gz
historical-0a0696fb9d9c05a29b45bc6a48b390f3fa6f57db.tar.bz2
historical-0a0696fb9d9c05a29b45bc6a48b390f3fa6f57db.zip
Erase cleartext passwords from memory, fixes security bug 482588, CVE-2013-4285. Committing with stable keywords, thanks to Agostino Sarubbo for testing on amd64 and x86. Remove vulnerable versions.
Package-Manager: portage-2.2.1/cvs/Linux x86_64 RepoMan-Options: --force Manifest-Sign-Key: 0x9433907D693FB5B8!
Diffstat (limited to 'sys-auth/pam_skey/pam_skey-1.1.5-r5.ebuild')
-rw-r--r--sys-auth/pam_skey/pam_skey-1.1.5-r5.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sys-auth/pam_skey/pam_skey-1.1.5-r5.ebuild b/sys-auth/pam_skey/pam_skey-1.1.5-r5.ebuild
new file mode 100644
index 000000000000..5e4986c8f459
--- /dev/null
+++ b/sys-auth/pam_skey/pam_skey-1.1.5-r5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_skey/pam_skey-1.1.5-r5.ebuild,v 1.1 2013/08/28 06:00:25 ulm Exp $
+
+EAPI=5
+
+inherit eutils pam autotools multilib readme.gentoo
+
+DESCRIPTION="PAM interface for the S/Key authentication system"
+HOMEPAGE="http://freshmeat.net/projects/pam_skey/"
+SRC_URI="http://dkorunic.net/tarballs/${P}.tar.gz
+ mirror://gentoo/${P}-patches-6.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND=">=sys-libs/pam-0.78-r3
+ >=sys-auth/skey-1.1.5-r4"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+DOCS="README INSTALL"
+DOC_CONTENTS="To use the pam_skey module, you need to configure PAM
+ by adding a line like:
+ \n\nauth [success=done ignore=ignore auth_err=die default=bad] pam_skey.so\n
+ \nto an appropriate place in the /etc/pam.d/system-auth file.
+ Consult the README and INSTALL files in /usr/share/doc/${PF}
+ for detailed instructions.
+ \n\nPlease note that calling this module from unprivileged
+ applications, e.g. screensavers, is not supported.
+ \n\nError checking has become stricter in pam_skey-1.1.5-r4;
+ errors returned from the underlying skey library when accessing
+ the S/Key data base will no longer be ignored.
+ Make sure that your PAM configuration is correct."
+
+src_prepare() {
+ EPATCH_SUFFIX=patch epatch
+ epatch_user
+
+ cd autoconf
+ eautoconf
+ eautoheader
+ mv configure defs.h.in .. || die "mv failed"
+}
+
+src_configure() {
+ econf --libdir="/$(get_libdir)" CFLAGS="${CFLAGS} -fPIC"
+}
+
+pkg_postinst() {
+ case ${REPLACING_VERSIONS} in
+ 1.1.[45]|1.1.5-r[123]) FORCE_PRINT_ELOG=1 ;;
+ esac
+ readme.gentoo_print_elog
+}