summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-05-28 18:08:22 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-05-28 18:08:22 +0000
commite6a73c4fa573010b8a9ab373178d80ff57b1b67b (patch)
tree61d961de2ea5c987504985d9644db1c3845ab85a /sys-block/fio/fio-1.20.ebuild
parentForgot to add doc at the top of the new patch. (diff)
downloadhistorical-e6a73c4fa573010b8a9ab373178d80ff57b1b67b.tar.gz
historical-e6a73c4fa573010b8a9ab373178d80ff57b1b67b.tar.bz2
historical-e6a73c4fa573010b8a9ab373178d80ff57b1b67b.zip
Bug 220299, version bump.
Package-Manager: portage-2.1.5.2
Diffstat (limited to 'sys-block/fio/fio-1.20.ebuild')
-rw-r--r--sys-block/fio/fio-1.20.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-block/fio/fio-1.20.ebuild b/sys-block/fio/fio-1.20.ebuild
new file mode 100644
index 000000000000..791e11fad494
--- /dev/null
+++ b/sys-block/fio/fio-1.20.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/fio/fio-1.20.ebuild,v 1.1 2008/05/28 18:08:22 robbat2 Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="Jens Axboe's Flexible IO tester"
+HOMEPAGE="http://brick.kernel.dk/snaps/"
+SRC_URI="http://brick.kernel.dk/snaps/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libaio"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ append-flags -W
+ emake CC="$(tc-getCC)" OPTFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" prefix="/usr" || die "emake install failed"
+ dodoc README REPORTING-BUGS HOWTO
+ docinto examples
+ dodoc examples/*
+}