summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-07-11 02:41:55 +0000
committerMike Frysinger <vapier@gentoo.org>2011-07-11 02:41:55 +0000
commit14c19f2c464361f793a780e0a729b6659eb5e23f (patch)
tree87e0da89195935238c38615ab9596ab49c16382f /sys-block/nbd/nbd-2.9.23.ebuild
parentStable for HPPA (bug #373951). (diff)
downloadhistorical-14c19f2c464361f793a780e0a729b6659eb5e23f.tar.gz
historical-14c19f2c464361f793a780e0a729b6659eb5e23f.tar.bz2
historical-14c19f2c464361f793a780e0a729b6659eb5e23f.zip
Version bump.
Package-Manager: portage-2.2.0_alpha43/cvs/Linux x86_64
Diffstat (limited to 'sys-block/nbd/nbd-2.9.23.ebuild')
-rw-r--r--sys-block/nbd/nbd-2.9.23.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-block/nbd/nbd-2.9.23.ebuild b/sys-block/nbd/nbd-2.9.23.ebuild
new file mode 100644
index 000000000000..3931da387702
--- /dev/null
+++ b/sys-block/nbd/nbd-2.9.23.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/nbd/nbd-2.9.23.ebuild,v 1.1 2011/07/11 02:41:55 vapier Exp $
+
+EAPI="2"
+
+DESCRIPTION="Userland client/server for kernel network block device"
+HOMEPAGE="http://nbd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nbd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --enable-lfs \
+ --enable-syslog
+}
+
+src_compile() {
+ emake || die
+ emake -C gznbd || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dobin gznbd/gznbd || die
+ dodoc README
+}