summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-04-10 08:05:52 +0000
committerMike Frysinger <vapier@gentoo.org>2008-04-10 08:05:52 +0000
commit3c7e27c16caf70eb949de8f1568c1a3f7dcdb268 (patch)
treeb27c8b87a81e5c444d231ae51a7af601ac0b88bb /sys-devel/autoconf-wrapper/autoconf-wrapper-5.ebuild
parentold (diff)
downloadhistorical-3c7e27c16caf70eb949de8f1568c1a3f7dcdb268.tar.gz
historical-3c7e27c16caf70eb949de8f1568c1a3f7dcdb268.tar.bz2
historical-3c7e27c16caf70eb949de8f1568c1a3f7dcdb268.zip
Add support for autoconf-2.62 #217087.
Package-Manager: portage-2.2_pre5
Diffstat (limited to 'sys-devel/autoconf-wrapper/autoconf-wrapper-5.ebuild')
-rw-r--r--sys-devel/autoconf-wrapper/autoconf-wrapper-5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-devel/autoconf-wrapper/autoconf-wrapper-5.ebuild b/sys-devel/autoconf-wrapper/autoconf-wrapper-5.ebuild
new file mode 100644
index 000000000000..169c5ca7b2d0
--- /dev/null
+++ b/sys-devel/autoconf-wrapper/autoconf-wrapper-5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf-wrapper/autoconf-wrapper-5.ebuild,v 1.1 2008/04/10 08:05:51 vapier Exp $
+
+inherit multilib
+
+DESCRIPTION="wrapper for autoconf to manage multiple autoconf versions"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+S=${WORKDIR}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/misc
+ newexe "${FILESDIR}"/ac-wrapper-${PV}.sh ac-wrapper.sh || die
+
+ dodir /usr/bin
+ local x=
+ for x in auto{conf,header,m4te,reconf,scan,update} ifnames ; do
+ dosym ../$(get_libdir)/misc/ac-wrapper.sh /usr/bin/${x} || die
+ done
+}