summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-07-14 04:13:36 +0000
committerMike Frysinger <vapier@gentoo.org>2011-07-14 04:13:36 +0000
commit4c87944ba3a19fd18308d4efce591bbe8f6ee6e5 (patch)
tree1cc349a977e1a41141f5cdff0e20acc51729a856 /sys-devel/crossdev/crossdev-99999999.ebuild
parent[dev-db/mysql-5.5.14] Don't use live version of mysql_extras. (diff)
downloadhistorical-4c87944ba3a19fd18308d4efce591bbe8f6ee6e5.tar.gz
historical-4c87944ba3a19fd18308d4efce591bbe8f6ee6e5.tar.bz2
historical-4c87944ba3a19fd18308d4efce591bbe8f6ee6e5.zip
Encode the git version into crossdev so the log output is useful.
Package-Manager: portage-2.2.0_alpha45/cvs/Linux x86_64
Diffstat (limited to 'sys-devel/crossdev/crossdev-99999999.ebuild')
-rw-r--r--sys-devel/crossdev/crossdev-99999999.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys-devel/crossdev/crossdev-99999999.ebuild b/sys-devel/crossdev/crossdev-99999999.ebuild
index 506332a6bb14..373cdcb035b0 100644
--- a/sys-devel/crossdev/crossdev-99999999.ebuild
+++ b/sys-devel/crossdev/crossdev-99999999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-99999999.ebuild,v 1.4 2011/07/05 06:48:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-99999999.ebuild,v 1.5 2011/07/14 04:13:36 vapier Exp $
EAPI="3"
@@ -29,4 +29,7 @@ DEPEND="app-arch/xz-utils"
src_install() {
emake install DESTDIR="${D}" || die
+ if [[ "${PV}" == "99999999" ]] ; then
+ dosed "s:@CDEVPV@:${EGIT_VERSION}:" /usr/bin/crossdev || die
+ fi
}