summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-02-28 00:19:36 +0000
committerMike Frysinger <vapier@gentoo.org>2012-02-28 00:19:36 +0000
commit5a799febabb246c7be4308ea624e6490837ad967 (patch)
treee85019af2fee4adc5d5b3b39c95d54617297a151 /sys-devel/crossdev/crossdev-99999999.ebuild
parentRevbump to fix undefined symbol error at runtime when built with --as-needed ... (diff)
downloadhistorical-5a799febabb246c7be4308ea624e6490837ad967.tar.gz
historical-5a799febabb246c7be4308ea624e6490837ad967.tar.bz2
historical-5a799febabb246c7be4308ea624e6490837ad967.zip
Update to EAPI=4 and version bump.
Package-Manager: portage-2.2.0_alpha86/cvs/Linux x86_64
Diffstat (limited to 'sys-devel/crossdev/crossdev-99999999.ebuild')
-rw-r--r--sys-devel/crossdev/crossdev-99999999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sys-devel/crossdev/crossdev-99999999.ebuild b/sys-devel/crossdev/crossdev-99999999.ebuild
index 373cdcb035b0..ebdff8052a69 100644
--- a/sys-devel/crossdev/crossdev-99999999.ebuild
+++ b/sys-devel/crossdev/crossdev-99999999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-99999999.ebuild,v 1.5 2011/07/14 04:13:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-99999999.ebuild,v 1.6 2012/02/28 00:19:36 vapier Exp $
-EAPI="3"
+EAPI="4"
if [[ ${PV} == "99999999" ]] ; then
EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/crossdev.git"
@@ -28,8 +28,8 @@ RDEPEND=">=sys-apps/portage-2.1
DEPEND="app-arch/xz-utils"
src_install() {
- emake install DESTDIR="${D}" || die
+ default
if [[ "${PV}" == "99999999" ]] ; then
- dosed "s:@CDEVPV@:${EGIT_VERSION}:" /usr/bin/crossdev || die
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
fi
}