summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisa M. Seelye <lisa@gentoo.org>2004-02-21 20:15:24 +0000
committerLisa M. Seelye <lisa@gentoo.org>2004-02-21 20:15:24 +0000
commitc1524aa48f6f3d1e852ee5ba877be7b8996a36b4 (patch)
tree7e954eba56412a8ab26ce95a41fa5035fe365efb /sys-devel/distcc
parentBump 2.12.1 to stable across several arches - still need to hear from alpha a... (diff)
downloadhistorical-c1524aa48f6f3d1e852ee5ba877be7b8996a36b4.tar.gz
historical-c1524aa48f6f3d1e852ee5ba877be7b8996a36b4.tar.bz2
historical-c1524aa48f6f3d1e852ee5ba877be7b8996a36b4.zip
Removed 2.5-r1, finally. Waiting to hear from alpha and ppc for <2.12.1 removal
Diffstat (limited to 'sys-devel/distcc')
-rw-r--r--sys-devel/distcc/Manifest2
-rw-r--r--sys-devel/distcc/distcc-2.5-r1.ebuild111
-rw-r--r--sys-devel/distcc/files/digest-distcc-2.5-r11
3 files changed, 0 insertions, 114 deletions
diff --git a/sys-devel/distcc/Manifest b/sys-devel/distcc/Manifest
index 21e377542098..73a382ffddc1 100644
--- a/sys-devel/distcc/Manifest
+++ b/sys-devel/distcc/Manifest
@@ -3,14 +3,12 @@ MD5 cdaed817d844c36ba7ced99a3f516cc5 distcc-2.11.2-r1.ebuild 4061
MD5 5263b5361ec14a67ca799473c2ce12b3 distcc-2.8-r2.ebuild 3368
MD5 70619e7eb5fa4fd0aa4f3588579cd50d metadata.xml 443
MD5 79ac13db24395f06222cd7a4df41a19b ChangeLog 17046
-MD5 c83ed80f936d6332a49069dc11c67eac distcc-2.5-r1.ebuild 3207
MD5 fe917ad577ccf7fa5f5d90409202960f distcc-2.9.ebuild 3457
MD5 ed97af1dc861dbd229fae273affcde6e distcc-2.11.1.ebuild 3944
MD5 bc070b11fddab15318c3ce521b517a15 distcc-2.12.1.ebuild 4558
MD5 c09d755beeab4ae675a8352f4ee04c63 files/digest-distcc-2.11.2-r1 66
MD5 86e7b8c5c35c5e34e2adfe2c55369f7a files/digest-distcc-2.11.1 66
MD5 56fd1ac60c1b8402e1632da62f32a890 files/digest-distcc-2.8-r2 63
-MD5 e1ecfcc1aad7c385cf3c41966277cda7 files/digest-distcc-2.5-r1 63
MD5 ade4e8cda892045944e204fc2c3df8bd files/digest-distcc-2.9 63
MD5 9ca407ce154707a1f27485523adf943c files/digest-distcc-2.12.1 66
MD5 c09d755beeab4ae675a8352f4ee04c63 files/digest-distcc-2.11.2 66
diff --git a/sys-devel/distcc/distcc-2.5-r1.ebuild b/sys-devel/distcc/distcc-2.5-r1.ebuild
deleted file mode 100644
index 5211f1f94eb0..000000000000
--- a/sys-devel/distcc/distcc-2.5-r1.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-2.5-r1.ebuild,v 1.8 2004/02/21 20:08:23 lisa Exp $
-
-inherit eutils
-
-IUSE="selinux"
-
-HOMEPAGE="http://distcc.samba.org/"
-SRC_URI="http://distcc.samba.org/ftp/distcc/distcc-${PV}.tar.bz2"
-DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc sparc alpha hppa mips"
-
-OPV="1.2"
-LPV="2.3"
-
-DEPEND=">=sys-apps/portage-2.0.46-r11
- >=sys-devel/gcc-config-1.3.1
- sys-apps/shadow
- dev-libs/popt"
-
-RDEPEND="selinux? ( sec-policy/selinux-distcc )"
-
-src_compile() {
- econf || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D%/}" install
-
- insinto /usr/share/doc/${PN}
- doins "${S}/survey.txt"
-
- exeinto /usr/bin
- doexe "${FILESDIR}/${LPV}/distcc-config"
-
- insinto /etc/conf.d
- newins "${FILESDIR}/${OPV}/conf" distccd
-
- exeinto /etc/init.d
- newexe "${FILESDIR}/${OPV}/init" distccd
-
- # create and keep the symlink dir
- dodir /usr/lib/distcc/bin
- keepdir /usr/lib/distcc/bin
-
- # create the distccd pid directory
- dodir /var/run/distccd
- keepdir /var/run/distccd
-}
-
-pkg_preinst() {
- # non-/ installs don't require us to do anything here
- [ "${ROOT}" != "/" ] && return 0
-
- # stop daemon since script is being updated
- [ -n "$(pidof distccd)" -a -x /etc/init.d/distccd ] && \
- /etc/init.d/distccd stop
-
- # moved user creation and permissions to distcc-config script
- # because of ROOT install requirements
-}
-
-pkg_postinst() {
- # handle DISTCC_HOSTS upgrade better
- local ENVFILE
- ENVFILE="${ROOT}etc/env.d/02distcc"
- [ ! -f "${ENVFILE}" ] && \
- ENVFILE="${ROOT}etc/env.d/04distcc"
- if [ -f "${ENVFILE}" ]
- then
- # save hosts to new file
- ROOT="${ROOT}" ${ROOT}usr/bin/distcc-config --set-hosts \
- $(egrep '^DISTCC_HOSTS' "${ENVFILE}" | sed 's,[^=]*=,,')
- # now remove from the file
- grep -v 'DISTCC_HOSTS' "${ENVFILE}" > "${ENVFILE}.new"
- mv "${ENVFILE}.new" "${ENVFILE}"
- fi
-
- if [ "${ROOT}" = "/" ]; then
- einfo "Installing links to native compilers..."
- /usr/bin/distcc-config --install-user
- /usr/bin/distcc-config --install-links
- /usr/bin/distcc-config --install-links "${CHOST}"
- else
- # distcc-config can *almost* handle ROOT installs itself
- # but for now, but user must finsh things off
- ewarn "*** Installation is not complete ***"
- ewarn "You must run the following as root:"
- ewarn " /usr/bin/distcc-config --install"
- ewarn "after booting or chrooting into ${ROOT}"
- fi
- einfo "To use distcc with **non-Portage** C compiling, add"
- einfo "/usr/lib/distcc/bin to your path before /usr/bin. If you're"
- einfo "combining this with ccache, put the ccache path BEFORE distcc."
- einfo "Portage 2.0.46-r11+ will take advantage of distcc if you put"
- einfo "distcc into the FEATURES setting in make.conf and use"
- einfo "distcc-config --set-hosts. Do NOT set CC=distcc or similar."
- ewarn "See http://www.gentoo.org/doc/en/distcc.xml for information."
-}
-
-#pkg_prerm() {
-# # ztw - not sure if this is the right place
-# distcc-config --remove-links "${CHOST}"
-# distcc-config --remove-links
-#}
-
diff --git a/sys-devel/distcc/files/digest-distcc-2.5-r1 b/sys-devel/distcc/files/digest-distcc-2.5-r1
deleted file mode 100644
index b14915b69443..000000000000
--- a/sys-devel/distcc/files/digest-distcc-2.5-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 b0b6a34fa5a30bfa7f6853f477f7772f distcc-2.5.tar.bz2 220088