summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-22 23:45:23 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-22 23:45:23 +0000
commit22139a8b6cf383b21dc6da88082556a7c17b316c (patch)
tree6bd4436075379aad83507bee2851c812ea0b0802 /sys-devel
parentcleanup, and hence avoid intltool issues (diff)
downloadhistorical-22139a8b6cf383b21dc6da88082556a7c17b316c.tar.gz
historical-22139a8b6cf383b21dc6da88082556a7c17b316c.tar.bz2
historical-22139a8b6cf383b21dc6da88082556a7c17b316c.zip
initial ebuild
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/automake-wrapper/ChangeLog8
-rw-r--r--sys-devel/automake-wrapper/Manifest15
-rw-r--r--sys-devel/automake-wrapper/automake-wrapper-1.ebuild29
-rw-r--r--sys-devel/automake-wrapper/files/am-wrapper-1.pl137
-rw-r--r--sys-devel/automake-wrapper/files/digest-automake-wrapper-10
-rw-r--r--sys-devel/automake-wrapper/metadata.xml5
-rw-r--r--sys-devel/automake/Manifest19
7 files changed, 209 insertions, 4 deletions
diff --git a/sys-devel/automake-wrapper/ChangeLog b/sys-devel/automake-wrapper/ChangeLog
new file mode 100644
index 000000000000..182677264070
--- /dev/null
+++ b/sys-devel/automake-wrapper/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for sys-devel/automake-wrapper
+# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake-wrapper/ChangeLog,v 1.1 2004/10/22 23:45:23 vapier Exp $
+
+*automake-wrapper-1 (22 Oct 2004)
+
+ 22 Oct 2004; Mike Frysinger <vapier@gentoo.org>:
+ Break the automake wrapper (am-wrapper.pl) off into its own package.
diff --git a/sys-devel/automake-wrapper/Manifest b/sys-devel/automake-wrapper/Manifest
new file mode 100644
index 000000000000..14a2b01cb397
--- /dev/null
+++ b/sys-devel/automake-wrapper/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 7a3c9c16025c5595e83740e223e8387e automake-wrapper-1.ebuild 748
+MD5 cb9eb7b03089e2dffedc3c7d837ac669 ChangeLog 382
+MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+MD5 b2616b03dfd3516a4cc52c4b769e6b96 files/am-wrapper-1.pl 5721
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-automake-wrapper-1 0
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.9.10 (GNU/Linux)
+
+iD8DBQFBeZu0HTu7gpaalycRAvi4AKD29WT5sJ4VIwytiNpLi6Hfn1tlswCgjWiW
+XEkfEtp82Ui8xsmOHC7Eewk=
+=J7GK
+-----END PGP SIGNATURE-----
diff --git a/sys-devel/automake-wrapper/automake-wrapper-1.ebuild b/sys-devel/automake-wrapper/automake-wrapper-1.ebuild
new file mode 100644
index 000000000000..49ad375a42fa
--- /dev/null
+++ b/sys-devel/automake-wrapper/automake-wrapper-1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake-wrapper/automake-wrapper-1.ebuild,v 1.1 2004/10/22 23:45:23 vapier Exp $
+
+DESCRIPTION="wrapper for autoconf to manage multiple autoconf versions"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl"
+
+S=${WORKDIR}
+
+src_install() {
+ exeinto /usr/lib/misc
+ newexe ${FILESDIR}/am-wrapper-${PV}.pl am-wrapper.pl || die
+
+ keepdir /usr/share/aclocal
+
+ dodir /usr/bin
+ local x=
+ for x in aclocal automake ; do
+ dosym ../lib/misc/am-wrapper.pl /usr/bin/${x}
+ done
+}
diff --git a/sys-devel/automake-wrapper/files/am-wrapper-1.pl b/sys-devel/automake-wrapper/files/am-wrapper-1.pl
new file mode 100644
index 000000000000..4deff78df3b2
--- /dev/null
+++ b/sys-devel/automake-wrapper/files/am-wrapper-1.pl
@@ -0,0 +1,137 @@
+#!/usr/bin/perl
+#
+#
+# Author: Guillaume Cottenceau (gc@mandrakesoft.com)
+# Modified by: Martin Schlemmer (azarah@gentoo.org)
+#
+# Copyright 2001 MandrakeSoft
+#
+# This software may be freely redistributed under the terms of the GNU
+# public license.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+#
+#
+# Executes the correct autoconf version.
+#
+# - defaults to automake-1.4
+# - runs automake-1.8 if it exists and...
+# - envvar WANT_AUTOMAKE is set to `1.8'
+# -or-
+# - `Makefile.in' was generated by automake-1.8 or superior, which
+# specifically needs automake-1.8
+# -or_
+# - 'aclocal.m4' contain AM_AUTOMAKE_VERSION, specifying the use of 1.8
+# - runs automake-1.7 if it exists and...
+# - envvar WANT_AUTOMAKE is set to `1.7'
+# -or-
+# - `Makefile.in' was generated by automake-1.7 or superior, which
+# specifically needs automake-1.7
+# -or-
+# - 'aclocal.m4' contain AM_AUTOMAKE_VERSION, specifyint the use of 1.7
+# -or-
+# - runs automake-1.6 if it exists and...
+# - envvar WANT_AUTOMAKE is set to `1.6'
+# -or-
+# - `Makefile.in' was generated by automake-1.6 or superior, which
+# specifically needs automake-1.6
+# -or-
+# - 'aclocal.m4' contain AM_AUTOMAKE_VERSION, specifyint the use of 1.6
+# -or-
+# - `configure.in' contains AC_PREREQ and the value's 3 first letters
+# are stringwise greater than '2.53c'
+# -or-
+# - `configure' is already present and was generated by autoconf greater than
+# '2.53c'
+# - runs automake-1.5 if it exists and...
+# - envvar WANT_AUTOMAKE is set to `1.5'
+# -or-
+# - configure.ac is present
+# -or-
+# - `configure.in' contains AC_PREREQ and the value's 3 first letters
+# are stringwise greater than '2.13'
+# -or-
+# - `configure' is already present and was generated by autoconf greater than
+# '2.13'
+# -or-
+# - `Makefile.in' was generated by automake-1.5 or superior, which
+# specifically needs automake-1.5
+#
+#use MDK::Common;
+
+sub cat_ { local *F; open F, $_[0] or return; my @l = <F>; wantarray ? @l : join '', @l }
+sub am_version {
+ my $file = cat_(shift);
+ return (@versions = $file =~ /^\s*\[?AM_AUTOMAKE_VERSION\(\[?([^\)]{3}[0-9]?)[^\)]*\]?\)/mg) ? ((sort @versions)[-1]) : '';
+}
+sub ac_version {
+ my $file = cat_(shift);
+ return (@versions = $file =~ /^\s*\[?AC_PREREQ\(\[?([^\)]{3}[0-9]?)[^\)]*\]?\)/mg) ? ((sort @versions)[-1]) : '';
+}
+
+
+
+my $binary = "$0-1.4";
+my $binary_1_5 = "$0-1.5";
+my $binary_1_6 = "$0-1.6";
+my $binary_1_7 = "$0-1.7";
+my $binary_1_8 = "$0-1.8";
+
+# question here is do we really want 1.5 or 1.6? Out of a KDE outlook, it
+# should rather be 1.5, and since most people would rather have migrated to
+# 1.5, and then stay with it for a bit (those 1.4 die hards ..), only have
+# the 'configure.ac' test for 1.5 ...
+if ($ENV{WANT_AUTOMAKE} ne '1.4') {
+ if (-x $binary_1_8 # user may not have _1_8 ...
+ && (($ENV{WANT_AUTOMAKE} eq '1.8')
+ || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.8'
+ || (cat_('aclocal.m4') =~ /^# aclocal.m4 generated automatically by aclocal (\S+)/ ? $1 : '') ge '1.8'
+ || am_version('aclocal.m4') ge '1.8')) {
+ $ENV{WANT_AUTOMAKE} = '1.8'; # to prevent further "cats" and to enhance consistency (possible cwd etc)
+ $binary = $binary_1_8;
+ } elsif (-x $binary_1_7 # user may not have 1.7 ...
+ && (($ENV{WANT_AUTOMAKE} eq '1.7')
+ || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.7'
+ || (cat_('aclocal.m4') =~ /^# aclocal.m4 generated automatically by aclocal (\S+)/ ? $1 : '') ge '1.7'
+ || am_version('aclocal.m4') ge '1.7')) {
+ $ENV{WANT_AUTOMAKE} = '1.7'; # to prevent further "cats" and to enhance consistency (possible cwd etc)
+ $binary = $binary_1_7;
+ } elsif (-x $binary_1_6 # user may not have 1.6 ...
+ && (($ENV{WANT_AUTOMAKE} eq '1.6')
+ || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.6'
+ || (cat_('aclocal.m4') =~ /^# aclocal.m4 generated automatically by aclocal (\S+)/ ? $1 : '') ge '1.6'
+ || am_version('aclocal.m4') ge '1.6'
+ # Autoconf 2.53d and later need automake-1.6c, so enable 1.6 for 2.53
+ # and up .....
+ || ac_version('configure.in') gt '2.52'
+ || (cat_('configure') =~ /^# Generated by Autoconf (\S+)/m ? $1 : '') gt '2.52'
+ || ac_version('aclocal.m4') gt '2.52')) {
+ $ENV{WANT_AUTOMAKE} = '1.6'; # to prevent further "cats" and to enhance consistency (possible cwd etc)
+ $binary = $binary_1_6;
+ } elsif (-x $binary_1_5 # user may have only 1.4 ...
+ && (($ENV{WANT_AUTOMAKE} eq '1.5')
+ || -r 'configure.ac'
+ || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.5'
+ || (cat_('aclocal.m4') =~ /^# aclocal.m4 generated automatically by aclocal (\S+)/ ? $1 : '') ge '1.5'
+ || ac_version('configure.in') gt '2.13'
+ || (cat_('configure') =~ /^# Generated by Autoconf (\S+)/m ? $1 : '') gt '2.13'
+ || ac_version('aclocal.m4') gt '2.13')) {
+ $ENV{WANT_AUTOMAKE} = '1.5'; # to prevent further "cats" and to enhance consistency (possible cwd etc)
+ $binary = $binary_1_5;
+ } else {
+ if (-r 'configure.in' || -r 'configure.ac') {
+ $ENV{WANT_AUTOMAKE} = '1.4'; # for further consistency
+ } else {
+ $ENV{WANT_AUTOMAKE} = '1.8';
+ $binary = $binary_1_8;
+ }
+ }
+}
+
+$ENV{WANT_AMWRAPPER_DEBUG} and print STDERR "am-wrapper: will execute <$binary>\n";
+
+exec $binary, @ARGV;
+
+die "am-wrapper: ouch, couldn't call binary ($binary).\n";
diff --git a/sys-devel/automake-wrapper/files/digest-automake-wrapper-1 b/sys-devel/automake-wrapper/files/digest-automake-wrapper-1
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sys-devel/automake-wrapper/files/digest-automake-wrapper-1
diff --git a/sys-devel/automake-wrapper/metadata.xml b/sys-devel/automake-wrapper/metadata.xml
new file mode 100644
index 000000000000..96a2d586367d
--- /dev/null
+++ b/sys-devel/automake-wrapper/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>
diff --git a/sys-devel/automake/Manifest b/sys-devel/automake/Manifest
index cdf555561f20..3eb0b83bd6e7 100644
--- a/sys-devel/automake/Manifest
+++ b/sys-devel/automake/Manifest
@@ -1,12 +1,23 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 08693c4c42ffe4d3a7a64d0af79bde83 ChangeLog 9737
+MD5 c5295968fd59f66cf5092877134f40d5 ChangeLog 10002
+MD5 98f6de7bb8d514c4f8087ad41e53b30b automake-1.4_p6.ebuild 1605
+MD5 b331246d15bf0aa968cb0b0d76a57281 automake-1.5.ebuild 1588
+MD5 17668ac05983e5be735cc5d1db23b0bd automake-1.6.3.ebuild 1441
+MD5 11ebcec05e79c6af4c3e37945b3bc92b automake-1.7.9.ebuild 1475
+MD5 7d6bc3de75186f41489e81c83f4c2ab6 automake-1.8.5-r2.ebuild 1516
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 f8813798f3cc27f66ec97dc6069bb855 automake-1.8.5-r1.ebuild 12936
+MD5 78e8a0f1cc7ad91267499625df0de314 files/automake-1.5-slot.patch 1161
+MD5 252f1212a83cc74c42cd557bc3f65e32 files/digest-automake-1.4_p6 67
MD5 41ad4c592f0cb2cbc83ff461fc36eea9 files/automake-1.4_p5-ignore-duplicates.patch 882
MD5 fbf3743bc8590dcb5bd34c675cb9d9f0 files/automake-1.5-target_hook.patch 1132
MD5 2b5aa34b9c688d919f6b06df0c428cc4 files/am-wrapper.pl 6165
+MD5 61706a6ada025b2f032fb24668457cef files/digest-automake-1.5 64
+MD5 a591fd70f20b40a46667f57326ad4b7c files/digest-automake-1.6.3 67
+MD5 29dec70b283dffd42358d3643b1754c3 files/digest-automake-1.7.9 67
+MD5 0fe9854b3a6384ef4c7b0bd2bad72c59 files/digest-automake-1.8.5-r2 67
MD5 7abe94459d460b0af03ee8720383607b files/digest-automake-1.8.5-r1 332
MD5 e93136e02eb000c938f564484d306d76 files/automake-1.7.9-infopage-namechange.patch 592
MD5 9587f00ace066c11b5c22d72afe630a9 files/automake-1.8.2-infopage-namechange.patch 1131
@@ -14,7 +25,7 @@ MD5 d576cbc9cda51d6288db8b8569eb9e2a files/automake-1.8.5-config-guess-uclibc.pa
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.9.10 (GNU/Linux)
-iD8DBQFBZDOjHTu7gpaalycRAr5+AKCT+CpGxnwoEKSNjVU+gr9RkOutCgCgnuHb
-KvYAOesLQ+CQylI3w4+foJE=
-=UJjB
+iD8DBQFBeZwrHTu7gpaalycRAlFVAKC+pEFAf2tCSifIb6RoUTVI3CvSRQCg1e4G
+h1QM0GNnuKBQUJ6BBvVJQqc=
+=ViBk
-----END PGP SIGNATURE-----