summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-08-27 18:03:47 +0000
committerMike Frysinger <vapier@gentoo.org>2006-08-27 18:03:47 +0000
commit304a96463ea55f92ac267db893c7c18b7de03310 (patch)
treee7727799adafa83b5e44f11a5779ed6352cd6f2b /sys-devel
parentUpstream tarball changed size again. (elemesmedve, but #136547) (diff)
downloadhistorical-304a96463ea55f92ac267db893c7c18b7de03310.tar.gz
historical-304a96463ea55f92ac267db893c7c18b7de03310.tar.bz2
historical-304a96463ea55f92ac267db893c7c18b7de03310.zip
Now that we have moved binutils stuff, make sure the binaries can still be found automatically by the gcc cross-compiler.
Package-Manager: portage-2.1.1_rc1
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils-config/ChangeLog9
-rw-r--r--sys-devel/binutils-config/binutils-config-1.9-r1.ebuild19
-rwxr-xr-xsys-devel/binutils-config/files/binutils-config-1.97
-rw-r--r--sys-devel/binutils-config/files/digest-binutils-config-1.9-r11
4 files changed, 32 insertions, 4 deletions
diff --git a/sys-devel/binutils-config/ChangeLog b/sys-devel/binutils-config/ChangeLog
index 64094dcc5038..102de711d9ee 100644
--- a/sys-devel/binutils-config/ChangeLog
+++ b/sys-devel/binutils-config/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/binutils-config
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/ChangeLog,v 1.21 2006/08/27 09:15:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/ChangeLog,v 1.22 2006/08/27 18:03:47 vapier Exp $
+
+*binutils-config-1.9-r1 (27 Aug 2006)
+
+ 27 Aug 2006; Mike Frysinger <vapier@gentoo.org> files/binutils-config-1.9,
+ -binutils-config-1.9.ebuild, +binutils-config-1.9-r1.ebuild:
+ Now that we have moved binutils stuff, make sure the binaries can still be
+ found automatically by the gcc cross-compiler.
*binutils-config-1.9 (27 Aug 2006)
diff --git a/sys-devel/binutils-config/binutils-config-1.9-r1.ebuild b/sys-devel/binutils-config/binutils-config-1.9-r1.ebuild
new file mode 100644
index 000000000000..9decf8433fbf
--- /dev/null
+++ b/sys-devel/binutils-config/binutils-config-1.9-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/binutils-config-1.9-r1.ebuild,v 1.1 2006/08/27 18:03:47 vapier Exp $
+
+DESCRIPTION="Utility to change the binutils version being used"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+
+src_install() {
+ newbin "${FILESDIR}"/${PN}-${PV} ${PN} || die
+ doman "${FILESDIR}"/${PN}.8
+}
diff --git a/sys-devel/binutils-config/files/binutils-config-1.9 b/sys-devel/binutils-config/files/binutils-config-1.9
index 743ccbb7504d..ba08f5ca3464 100755
--- a/sys-devel/binutils-config/files/binutils-config-1.9
+++ b/sys-devel/binutils-config/files/binutils-config-1.9
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/files/binutils-config-1.9,v 1.1 2006/08/27 09:15:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/files/binutils-config-1.9,v 1.2 2006/08/27 18:03:47 vapier Exp $
# Format of /etc/env.d/binutils/:
# config-TARGET: CURRENT=version for TARGET
@@ -89,7 +89,7 @@ switch_profile() {
#
if [[ -d /usr/${HOST}/${TARGET}/binutils-bin/${VER} ]] ; then
BINPATH=/usr/${HOST}/${TARGET}/binutils-bin/${VER}
- BINPATH_LINKS=/usr/${HOST}/${TARGET}/bin
+ BINPATH_LINKS=/usr/libexec/gcc/${TARGET}
fi
fi
if [[ -z ${BINPATH} ]] ; then
@@ -209,6 +209,7 @@ uninstall_target() {
nm objcopy objdump ranlib readelf size strings strip ; do
rm -f "${ROOT}"/usr/bin/${TARGET}-${x}
rm -f "${ROOT}"/usr/{${HOST}/,}${TARGET}/bin/${x}
+ rm -f "${ROOT}"/usr/libexec/gcc/${TARGET}/${x}
done
for x in ansidecl.h bfd.h bfdlink.h dis-asm.h symcat.h ; do
rm -f "${ROOT}"/usr/{${HOST}/,}${TARGET}/{usr/,}include/${x}
@@ -330,7 +331,7 @@ while [[ $# -gt 0 ]] ; do
exit 0
;;
-V|--version)
- cvsver="$Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/files/binutils-config-1.9,v 1.1 2006/08/27 09:15:50 vapier Exp $"
+ cvsver="$Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/files/binutils-config-1.9,v 1.2 2006/08/27 18:03:47 vapier Exp $"
cvsver=${cvsver##*binutils-config-}
bver=${cvsver%%,v *}
cvsver=${cvsver#* }
diff --git a/sys-devel/binutils-config/files/digest-binutils-config-1.9-r1 b/sys-devel/binutils-config/files/digest-binutils-config-1.9-r1
new file mode 100644
index 000000000000..8b137891791f
--- /dev/null
+++ b/sys-devel/binutils-config/files/digest-binutils-config-1.9-r1
@@ -0,0 +1 @@
+