summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-08-15 22:34:55 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-08-15 22:34:55 +0000
commit85f5707e8f854485acd31d26a5f9336ab1dfb0ed (patch)
treea0604b4c93e10ec7e2e932fbd03c68249b0f8d87 /sys-devel
parentAdded support for CDB (Constant Database) lookups. Faster than linear (diff)
downloadhistorical-85f5707e8f854485acd31d26a5f9336ab1dfb0ed.tar.gz
historical-85f5707e8f854485acd31d26a5f9336ab1dfb0ed.tar.bz2
historical-85f5707e8f854485acd31d26a5f9336ab1dfb0ed.zip
enable gcc-3-deopt.patch again; doc updates
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog13
-rw-r--r--sys-devel/gcc/files/gcc-3-deopt-doc.patch14
-rw-r--r--sys-devel/gcc/gcc-3.2.ebuild109
3 files changed, 90 insertions, 46 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index cae4acaee582..ff9630dc713c 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sys-devel/gcc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.29 2002/08/15 00:25:57 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.30 2002/08/15 22:34:55 azarah Exp $
+
+ 15 Aug 2002; Martin Schlemmer <azarah@gentoo.org> gcc-3.2.ebuild :
+
+ Add back gcc-3-deopt.patch. Also add gcc-3-deopt-doc.patch. Update
+ the docs that gets installed, as well as added html pages for libstdc++-v3.
+
+*gcc-3.2 (15 Aug 2002)
+
+ 15 Aug 2002; Daniel Robbins <azarah@gentoo.org> gcc-3.2.ebuild :
+
+ Update to latest version
*gcc-3.2_pre-r1 (15 Aug 2002)
diff --git a/sys-devel/gcc/files/gcc-3-deopt-doc.patch b/sys-devel/gcc/files/gcc-3-deopt-doc.patch
new file mode 100644
index 000000000000..3d24aea02645
--- /dev/null
+++ b/sys-devel/gcc/files/gcc-3-deopt-doc.patch
@@ -0,0 +1,14 @@
+diff -Naur gcc-3.1.1/gcc/doc/gcc.1 gcc-3.1.1-optim/gcc/doc/gcc.1
+--- gcc/doc/gcc.1.orig 2002-07-25 18:56:25.000000000 -0500
++++ gcc/doc/gcc.1 2002-08-13 21:46:37.000000000 -0500
+@@ -6896,7 +6896,9 @@
+ computed in the function prologue. This is faster on most modern CPUs
+ because of reduced dependencies, improved scheduling and reduced stack usage
+ when preferred stack boundary is not equal to 2. The drawback is a notable
+-increase in code size. This switch implies \fB\-mno-push-args\fR.
++increase in code size--also, this feature is buggy and is known to break some
++things. This switch must be explicitly specified; use it at your own risk.
++This switch implies \fB\-mno-push-args\fR.
+ .Ip "\fB\-mthreads\fR" 4
+ .IX Item "-mthreads"
+ Support thread-safe exception handling on \fBMingw32\fR. Code that relies
diff --git a/sys-devel/gcc/gcc-3.2.ebuild b/sys-devel/gcc/gcc-3.2.ebuild
index e0dd5aa10e12..7cb2e5644ca3 100644
--- a/sys-devel/gcc/gcc-3.2.ebuild
+++ b/sys-devel/gcc/gcc-3.2.ebuild
@@ -1,26 +1,33 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.ebuild,v 1.1 2002/08/15 18:16:27 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.ebuild,v 1.2 2002/08/15 22:34:55 azarah Exp $
# NOTE TO MAINTAINER: Info pages get nuked for multiple version installs.
# Ill fix it later if i get a chance.
-#
-# IMPORTANT: The versions of libs installed should be updated
-# in src_install() ... Ill implement auto-version detection
-# later on.
inherit flag-o-matic libtool
# Compile problems with these ...
filter-flags "-fno-exceptions"
-MY_PV="`echo ${PV} | cut -d. -f1,2`"
-GCC_SUFFIX=-${MY_PV}
LOC="/usr"
-# dont install in /usr/include/g++-v3/, as it will nuke gcc-3.0.x installs
+MY_PV="`echo ${PV/_pre} | cut -d. -f1,2`"
+GCC_SUFFIX="-${MY_PV}"
+# Dont install in /usr/include/g++-v3/, as it will nuke gcc-3.0.x installs
STDCXX_INCDIR="${LOC}/include/g++-v${MY_PV/\./}"
-PATCHES="${WORKDIR}/patches"
-SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/${P}/${P}.tar.bz2"
+
+# Snapshot support ...
+#SNAPSHOT="2002-08-12"
+SNAPSHOT=""
+if [ -z "${SNAPSHOT}" ]
+then
+ S="${WORKDIR}/${P}"
+ SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/${P}/${P}.tar.bz2"
+else
+ S="${WORKDIR}/gcc-${SNAPSHOT//-}"
+ SRC_URI="ftp://ftp.mirror.ac.uk/sites/sources.redhat.com/pub/gcc/snapshots/${SNAPSHOT}/gcc-${SNAPSHOT//-}.tar.bz2"
+fi
+
DESCRIPTION="Modern GCC C/C++ compiler"
HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
@@ -37,9 +44,10 @@ RDEPEND="virtual/glibc
>=sys-apps/texinfo-4.2-r4
!build? ( >=sys-libs/ncurses-5.2-r2 )"
+
build_multiple() {
- #try to make sure that we should build multiple
- #versions of gcc (dual install of gcc2 and gcc3)
+ # Try to make sure that we should build multiple
+ # versions of gcc (dual install of gcc2 and gcc3)
profile="`readlink /etc/make.profile`"
# [ "`gcc -dumpversion | cut -d. -f1,2`" != "`echo ${PV} | cut -d. -f1,2`" ]
#
@@ -57,11 +65,16 @@ build_multiple() {
fi
}
-# used to patch Makefiles to install into the build dir
+# Used to patch Makefiles to install into the build dir
FAKE_ROOT=""
src_unpack() {
- unpack ${A}
+ if [ -z "${SNAPSHOT}" ]
+ then
+ unpack ${P}.tar.bz2
+ else
+ unpack gcc-${SNAPSHOT//-}.tar.bz2
+ fi
cd ${S}
# Fixup libtool to correctly generate .la files with portage
@@ -78,7 +91,7 @@ src_unpack() {
# http://archive.linuxfromscratch.org/mail-archives/lfs-dev/2002/08/0410.html
# http://gcc.gnu.org/ml/gcc/2002-08/msg00731.html
#
- #cd ${S}; patch -p0 < ${FILESDIR}/gcc-3-deopt.patch || die
+ cd ${S}; patch -p0 < ${FILESDIR}/gcc-3-deopt.patch || die
# Currently if any path is changed via the configure script, it breaks
# installing into ${D}. We should not patch it in src_install() with
@@ -121,23 +134,22 @@ src_compile() {
gcc_lang="${gcc_lang},java"
fi
- #only build with a program suffix if it is not our
- #default compiler. Also check $GCCBUILD until we got
- #compilers sorted out.
+ # Only build with a program suffix if it is not our
+ # default compiler. Also check $GCCBUILD until we got
+ # compilers sorted out.
#
- #NOTE: for software to detirmine gcc version, it will be easier
- # if we have gcc, gcc-3.0 and gcc-3.1, and NOT gcc-3.0.4.
+ # NOTE: for software to detirmine gcc version, it will be easier
+ # if we have gcc, gcc-3.0 and gcc-3.1, and NOT gcc-3.0.4.
if build_multiple
then
myconf="${myconf} --program-suffix=${GCC_SUFFIX}"
fi
- # gcc does not like optimization
+ # In general gcc does not like optimization
+ export CFLAGS="${CFLAGS//-O?}"
+ export CXXFLAGS="${CXXFLAGS//-O?}"
- export CFLAGS="${CFLAGS/-O?/}"
- export CXXFLAGS="${CXXFLAGS/-O?/}"
-
- #build in a separate build tree
+ # Build in a separate build tree
mkdir -p ${WORKDIR}/build
cd ${WORKDIR}/build
@@ -166,17 +178,20 @@ src_compile() {
if [ -z "`use static`" ]
then
- #fix for our libtool-portage.patch
+ # Fix for our libtool-portage.patch
S="${WORKDIR}/build" \
emake bootstrap-lean || die
else
S="${WORKDIR}/build" \
emake LDFLAGS=-static bootstrap || die
fi
+
+ # Fixes the manpage for the "-maccumulate-outgoing-args bug"
+ cd ${S}; patch -p0 < ${FILESDIR}/gcc-3-deopt-doc.patch || die
}
src_install() {
- #make install from the build directory
+ # Do the 'make install' from the build directory
cd ${WORKDIR}/build
S="${WORKDIR}/build" \
make prefix=${D}${LOC} \
@@ -192,8 +207,8 @@ src_install() {
[ -e ${D}${LOC}/bin/gcc${GCC_SUFFIX} ] || die "gcc not found in ${D}"
- FULLPATH=${LOC}/lib/gcc-lib/${CHOST}/${PV}
- FULLPATH_D=${D}${LOC}/lib/gcc-lib/${CHOST}/${PV}
+ FULLPATH=${LOC}/lib/gcc-lib/${CHOST}/${PV/_pre}
+ FULLPATH_D=${D}${LOC}/lib/gcc-lib/${CHOST}/${PV/_pre}
cd ${FULLPATH_D}
dodir /lib
dodir /etc/env.d
@@ -218,13 +233,13 @@ src_install() {
dosed -e "s:%{L\*} %(link_libgcc):%{L\*} -L/lib %(link_libgcc):" \
${FULLPATH}/specs
- #make sure we dont have stuff lying around that
- #can nuke multiple versions of gcc
+ # Make sure we dont have stuff lying around that
+ # can nuke multiple versions of gcc
if [ -z "`use build`" ]
then
cd ${FULLPATH_D}
- #Tell libtool files where real libraries are
+ # Tell libtool files where real libraries are
for LA in ${D}${LOC}/lib/*.la ${FULLPATH_D}/../*.la
do
if [ -f ${LA} ]
@@ -235,13 +250,13 @@ src_install() {
fi
done
- #move all the libraries to version specific libdir.
+ # Move all the libraries to version specific libdir.
for x in ${D}${LOC}/lib/*.{so,a}* ${FULLPATH_D}/../*.{so,a}*
do
[ -f ${x} ] && mv -f ${x} ${FULLPATH_D}
done
- #move Java headers to compiler-specific dir
+ # Move Java headers to compiler-specific dir
for x in ${D}${LOC}/include/gc*.h ${D}${LOC}/include/j*.h
do
[ -f ${x} ] && mv -f ${x} ${FULLPATH_D}/include/
@@ -256,29 +271,29 @@ src_install() {
fi
done
- #move libgcj.spec to compiler-specific directories
+ # Move libgcj.spec to compiler-specific directories
[ -f ${D}${LOC}/lib/libgcj.spec ] && \
mv -f ${D}${LOC}/lib/libgcj.spec ${FULLPATH_D}/libgcj.spec
- #rename jar because it could clash with Kaffe's jar if this gcc is
- #primary compiler (aka don't have the -<version> extension)
+ # Rename jar because it could clash with Kaffe's jar if this gcc is
+ # primary compiler (aka don't have the -<version> extension)
cd ${D}${LOC}/bin
[ -f jar${GCC_SUFFIX} ] && mv -f jar${GCC_SUFFIX} gcj-jar${GCC_SUFFIX}
- #move <cxxabi.h> to compiler-specific directories
+ # Move <cxxabi.h> to compiler-specific directories
[ -f ${D}${STDCXX_INCDIR}/cxxabi.h ] && \
mv -f ${D}${STDCXX_INCDIR}/cxxabi.h ${FULLPATH_D}/include/
if build_multiple
then
- #now fix the manpages
+ # Now fix the manpages
cd ${D}${LOC}/share/man/man1
mv cpp.1 cpp${GCC_SUFFIX}.1
mv gcov.1 gcov${GCC_SUFFIX}.1
fi
fi
- #this one comes with binutils
+ # This one comes with binutils
if [ -f ${D}${LOC}/lib/libiberty.a ]
then
rm -f ${D}${LOC}/lib/libiberty.a
@@ -289,7 +304,9 @@ src_install() {
then
cd ${S}
docinto /
- dodoc COPYING COPYING.LIB ChangeLog LAST_UPDATED README MAINTAINERS
+ dodoc COPYING COPYING.LIB ChangeLog FAQ GNATS MAINTAINERS README
+ docinto html
+ dohtml *.html
cd ${S}/boehm-gc
docinto boehm-gc
dodoc ChangeLog doc/{README*,barrett_diagram}
@@ -297,12 +314,10 @@ src_install() {
dohtml doc/*.html
cd ${S}/gcc
docinto gcc
- dodoc ChangeLog* COPYING* FSFChangeLog* LANGUAGES NEWS ONEWS \
- README* SERVICE
+ dodoc ChangeLog* FSFChangeLog* LANGUAGES NEWS ONEWS README* SERVICE
cd ${S}/libf2c
docinto libf2c
- dodoc ChangeLog README TODO changes.netlib disclaimer.netlib \
- permission.netlib readme.netlib
+ dodoc ChangeLog README TODO *.netlib
cd ${S}/libffi
docinto libffi
dodoc ChangeLog* LICENSE README
@@ -315,6 +330,10 @@ src_install() {
cd ${S}/libstdc++-v3
docinto libstdc++-v3
dodoc ChangeLog* README
+ docinto libstdc++-v3/html
+ dohtml -r -a css,diff,html,txt,xml docs/html/*
+ cp -f docs/html/17_intro/[A-Z]* \
+ ${D}/usr/share/doc/${PF}/${DOCDESTTREE}/17_intro/
if [ -n "`use java`" ]
then