summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-16 23:51:35 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-16 23:51:35 +0000
commitc4a8e14ccf68f323f64bbf86e9ec653a8aee9954 (patch)
treeea157eac17a32cfddd4248a6b228b95e9f3fb5c9 /sys-devel
parent#include <wait.h> -> #include <sys/wait.h> #79911 (diff)
downloadhistorical-c4a8e14ccf68f323f64bbf86e9ec653a8aee9954.tar.gz
historical-c4a8e14ccf68f323f64bbf86e9ec653a8aee9954.tar.bz2
historical-c4a8e14ccf68f323f64bbf86e9ec653a8aee9954.zip
dont kill /lib/cpp if host is solaris #79964
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-config/Manifest6
-rwxr-xr-xsys-devel/gcc-config/files/gcc-config-1.3.104
-rwxr-xr-xsys-devel/gcc-config/files/gcc-config-1.3.84
-rwxr-xr-xsys-devel/gcc-config/files/gcc-config-1.4.04
4 files changed, 9 insertions, 9 deletions
diff --git a/sys-devel/gcc-config/Manifest b/sys-devel/gcc-config/Manifest
index 0f7d65762a1d..57c6803f2110 100644
--- a/sys-devel/gcc-config/Manifest
+++ b/sys-devel/gcc-config/Manifest
@@ -3,11 +3,11 @@ MD5 012868b502a874cc4f1abfa862bafb8a gcc-config-1.3.8-r4.ebuild 1429
MD5 856d159682acb2dca11e43b8bbe42b70 gcc-config-1.4.0.ebuild 1896
MD5 567094e03359ffc1c95af7356395228d metadata.xml 162
MD5 59fe9b0a4eab7247d332cf0ca73874c4 gcc-config-1.3.10-r1.ebuild 1451
-MD5 2282844b53e06c3ba29d751295544ee2 files/gcc-config-1.3.8 12438
+MD5 cc883aedd8c77676f4fef7de5a5222cf files/gcc-config-1.3.8 12472
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-gcc-config-1.3.8-r4 0
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-gcc-config-1.4.0 0
-MD5 1d04aa04d8a01f6b4da55113f7bbcdf0 files/gcc-config-1.4.0 14500
-MD5 9b36140ce8c4b259c8e479fae7ff5dfa files/gcc-config-1.3.10 13173
+MD5 f95eabcf62085954d3a11976cf5be18f files/gcc-config-1.4.0 14534
+MD5 96ab413be3d6ab70720bc52c76130b6b files/gcc-config-1.3.10 13207
MD5 3b96d761f411a1befda4f334da8fea03 files/wrapper-1.4.6.c 10526
MD5 e3203a5aa6df669ffa479aeeb7605029 files/wrapper-1.4.5.c 10671
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-gcc-config-1.3.10-r1 0
diff --git a/sys-devel/gcc-config/files/gcc-config-1.3.10 b/sys-devel/gcc-config/files/gcc-config-1.3.10
index a2e74f9493c0..f851e6563f32 100755
--- a/sys-devel/gcc-config/files/gcc-config-1.3.10
+++ b/sys-devel/gcc-config/files/gcc-config-1.3.10
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.10,v 1.4 2005/03/16 23:32:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.10,v 1.5 2005/03/16 23:51:35 vapier Exp $
trap ":" INT QUIT TSTP
@@ -220,7 +220,7 @@ switch_profile() {
fi
done
# Only install cpp if switching to a native one
- if ! is_cross_compiler ; then
+ if ! is_cross_compiler && [[ ${CTARGET} != *-solaris* ]] ; then
${RM} -f "${ROOT}/lib/cpp"
${CP} -f "${ROOT}/usr/lib/misc/gcc-config" "${ROOT}/lib/cpp"
fi
diff --git a/sys-devel/gcc-config/files/gcc-config-1.3.8 b/sys-devel/gcc-config/files/gcc-config-1.3.8
index 71575f75b489..37f2a278fad7 100755
--- a/sys-devel/gcc-config/files/gcc-config-1.3.8
+++ b/sys-devel/gcc-config/files/gcc-config-1.3.8
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.8,v 1.7 2005/03/16 23:32:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.8,v 1.8 2005/03/16 23:51:35 vapier Exp $
trap ":" INT QUIT TSTP
@@ -221,7 +221,7 @@ switch_profile() {
fi
done
# Only install cpp if switching to a native one
- if ! is_cross_compiler ; then
+ if ! is_cross_compiler && [[ ${CTARGET} != *-solaris* ]] ; then
${RM} -f "${ROOT}/lib/cpp"
${CP} -f "${ROOT}/usr/lib/gcc-config/wrapper" "${ROOT}/lib/cpp"
fi
diff --git a/sys-devel/gcc-config/files/gcc-config-1.4.0 b/sys-devel/gcc-config/files/gcc-config-1.4.0
index f19fffc54256..3a3ac55e9ced 100755
--- a/sys-devel/gcc-config/files/gcc-config-1.4.0
+++ b/sys-devel/gcc-config/files/gcc-config-1.4.0
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.4.0,v 1.6 2005/03/16 23:32:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.4.0,v 1.7 2005/03/16 23:51:35 vapier Exp $
trap ":" INT QUIT TSTP
@@ -272,7 +272,7 @@ switch_profile() {
done
# Only install cpp if switching to a native one
- if ! is_cross_compiler ; then
+ if ! is_cross_compiler && [[ ${CTARGET} != *-solaris* ]] ; then
${RM} -f "${ROOT}/lib/cpp"
${CP} -f "${WRAPPER}" "${ROOT}/lib/cpp"
fi