summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-08-22 21:00:58 +0000
committerTim Harder <radhermit@gentoo.org>2014-08-22 21:00:58 +0000
commit017bb7c48ebf9ff7b9288fe86d75bf69c793650b (patch)
tree7480889f5bd8ebe6fc3c71241c4c763f395a59b9 /sys-fs/s3ql/s3ql-2.6.ebuild
parentVersion bump. (diff)
downloadhistorical-017bb7c48ebf9ff7b9288fe86d75bf69c793650b.tar.gz
historical-017bb7c48ebf9ff7b9288fe86d75bf69c793650b.tar.bz2
historical-017bb7c48ebf9ff7b9288fe86d75bf69c793650b.zip
Remove old.
Package-Manager: portage-2.2.12/cvs/Linux x86_64 Manifest-Sign-Key: 0x4F064CA3
Diffstat (limited to 'sys-fs/s3ql/s3ql-2.6.ebuild')
-rw-r--r--sys-fs/s3ql/s3ql-2.6.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/sys-fs/s3ql/s3ql-2.6.ebuild b/sys-fs/s3ql/s3ql-2.6.ebuild
deleted file mode 100644
index 942a32b29caf..000000000000
--- a/sys-fs/s3ql/s3ql-2.6.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/s3ql/s3ql-2.6.ebuild,v 1.1 2013/12/05 08:01:19 radhermit Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python3_3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A full-featured file system for online data storage"
-HOMEPAGE="http://code.google.com/p/s3ql/"
-SRC_URI="http://s3ql.googlecode.com/files/${P}.0.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="contrib doc test"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/apsw-3.7.0[${PYTHON_USEDEP}]
- >=dev-python/llfuse-0.39[${PYTHON_USEDEP}]
- dev-python/pycrypto[${PYTHON_USEDEP}]
- sys-fs/fuse"
-DEPEND="${RDEPEND}
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- net-misc/rsync[xattr]
- )"
-
-python_test() {
- if [[ ${EUID} -ne 0 ]] ; then
- ewarn "Skipping tests: root privileges are required so userpriv must be disabled"
- else
- addwrite /dev/fuse
- esetup.py test
- fi
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use contrib ; then
- exeinto /usr/share/doc/${PF}/contrib
- docompress -x /usr/share/doc/${PF}/contrib
- doexe contrib/*.{py,sh}
- doman contrib/*.1
- fi
-
- if use doc ; then
- dodoc doc/manual.pdf
- dohtml -r doc/html/*
- fi
-}