summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2009-05-12 17:46:47 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2009-05-12 17:46:47 +0000
commit0fd7483b0ee9c80f453d34a6c98e081101afcb3c (patch)
tree7d4d5e0b63852db860e7facf95a9c96ece526da8 /sys-fs/udev/udev-124-r2.ebuild
parentVersion bump, #269567 (diff)
downloadhistorical-0fd7483b0ee9c80f453d34a6c98e081101afcb3c.tar.gz
historical-0fd7483b0ee9c80f453d34a6c98e081101afcb3c.tar.bz2
historical-0fd7483b0ee9c80f453d34a6c98e081101afcb3c.zip
Fix config file renaming if user had changes. Bug #269392.
Package-Manager: portage-2.1.6.13/cvs/Linux i686
Diffstat (limited to 'sys-fs/udev/udev-124-r2.ebuild')
-rw-r--r--sys-fs/udev/udev-124-r2.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/sys-fs/udev/udev-124-r2.ebuild b/sys-fs/udev/udev-124-r2.ebuild
index 5aaf21c19c09..bd61485ea4a6 100644
--- a/sys-fs/udev/udev-124-r2.ebuild
+++ b/sys-fs/udev/udev-124-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-124-r2.ebuild,v 1.8 2009/05/06 23:52:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-124-r2.ebuild,v 1.9 2009/05/12 17:46:47 zzam Exp $
inherit eutils flag-o-matic multilib toolchain-funcs versionator
@@ -223,6 +223,15 @@ src_install() {
}
pkg_preinst() {
+ local f dir=${ROOT}/etc/modprobe.d/
+ for f in pnp-aliases blacklist; do
+ if [[ -f $dir/$f && ! -f $dir/$f.conf ]]
+ then
+ elog "Moving $dir/$f to $f.conf"
+ mv -f "$dir/$f" "$dir/$f.conf"
+ fi
+ done
+
if [[ -d ${ROOT}/lib/udev-state ]]
then
mv -f "${ROOT}"/lib/udev-state/* "${D}"/lib/udev/state/