summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-09-20 07:14:35 +0000
committerMike Frysinger <vapier@gentoo.org>2007-09-20 07:14:35 +0000
commit79160a537ea669ff59629b47322bf20d90f6f10e (patch)
tree0c5feb5ae86d2ac6b05fa5005dc05aa59a0e1246 /sys-fs/xfsprogs/xfsprogs-2.9.4.ebuild
parentVersion bump #192647 and unset PLATFORM #184564. (diff)
downloadhistorical-79160a537ea669ff59629b47322bf20d90f6f10e.tar.gz
historical-79160a537ea669ff59629b47322bf20d90f6f10e.tar.bz2
historical-79160a537ea669ff59629b47322bf20d90f6f10e.zip
Version bump #192647 by Arfrever Frehtes Taifersar Arahesis.
Package-Manager: portage-2.1.3.9
Diffstat (limited to 'sys-fs/xfsprogs/xfsprogs-2.9.4.ebuild')
-rw-r--r--sys-fs/xfsprogs/xfsprogs-2.9.4.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sys-fs/xfsprogs/xfsprogs-2.9.4.ebuild b/sys-fs/xfsprogs/xfsprogs-2.9.4.ebuild
new file mode 100644
index 000000000000..f57b060dc455
--- /dev/null
+++ b/sys-fs/xfsprogs/xfsprogs-2.9.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/xfsprogs-2.9.4.ebuild,v 1.1 2007/09/20 07:13:50 vapier Exp $
+
+inherit eutils toolchain-funcs autotools
+
+MY_P="${PN}_${PV}-1"
+DESCRIPTION="xfs filesystem utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs/"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="sys-fs/e2fsprogs"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.8.18-symlinks.patch #166729
+ epatch "${FILESDIR}"/${PN}-2.8.21-kern-types.patch #131483
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ include/builddefs.in \
+ || die "sed include/builddefs.in failed"
+ # We'll handle /lib versus /usr/lib install
+ sed -i -e '/INSTALL.* -S .*LIBNAME/d' \
+ include/buildmacros || die "sed symlinks"
+ eautoconf
+}
+
+src_compile() {
+ export DEBUG=-DNDEBUG
+ export OPTIMIZER=${CFLAGS}
+ unset PLATFORM # if set in user env, this breaks configure
+ econf \
+ --bindir=/usr/bin \
+ --sbindir=/sbin \
+ --libexecdir=/usr/$(get_libdir) \
+ $(use_enable nls gettext) \
+ || die "config failed"
+ emake || die
+}
+
+src_install() {
+ emake DIST_ROOT="${D}" install install-dev || die "make install failed"
+
+ # shared in /lib, static in /usr/lib, ldscript fun too
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/lib*.so* "${D}"/$(get_libdir)/
+ dosym libhandle.so.1 /$(get_libdir)/libhandle.so
+ gen_usr_ldscript libhandle.so
+
+ prepalldocs
+}