summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorBenjamin Smee <strerror@gentoo.org>2005-11-25 23:56:37 +0000
committerBenjamin Smee <strerror@gentoo.org>2005-11-25 23:56:37 +0000
commit4fe6abeadba2e2df1e7e4ccf50b049fc74bb1739 (patch)
tree8c0b75c0f7463500d38f811360ec54072d466128 /sys-fs
parentstable on ppc64 (diff)
downloadhistorical-4fe6abeadba2e2df1e7e4ccf50b049fc74bb1739.tar.gz
historical-4fe6abeadba2e2df1e7e4ccf50b049fc74bb1739.tar.bz2
historical-4fe6abeadba2e2df1e7e4ccf50b049fc74bb1739.zip
removed 1.0 ebuild
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cryptsetup-luks/Manifest1
-rw-r--r--sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.ebuild74
2 files changed, 0 insertions, 75 deletions
diff --git a/sys-fs/cryptsetup-luks/Manifest b/sys-fs/cryptsetup-luks/Manifest
index d60a2e1c247a..34ad9c773d63 100644
--- a/sys-fs/cryptsetup-luks/Manifest
+++ b/sys-fs/cryptsetup-luks/Manifest
@@ -2,7 +2,6 @@ MD5 e61211b214547ee5d6078460df84463a cryptsetup-luks-1.0.1.ebuild 2151
MD5 80fefee20968a47c4c7a68c11e5e6690 cryptsetup-luks-1.0.1-r1.ebuild 1927
MD5 66c1f7dfa9c09e11c9e248dd7ec07a5e cryptsetup-luks-1.0-r1.ebuild 2126
MD5 6e3e82be44b3332d6cda7a23c9b210e9 ChangeLog 2017
-MD5 3caa86ef66126cc858551801beb4b6d0 cryptsetup-luks-1.0.ebuild 2004
MD5 6c788beeca78bd11e5cd6e759e52fadc metadata.xml 228
MD5 c653a0b4ace27569ccc659b7cb43b4a9 files/dm-crypt-start.sh 4306
MD5 6d86b15e07cd0cdf96d8a363b1d778cd files/cryptfs.confd 1548
diff --git a/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.ebuild b/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.ebuild
deleted file mode 100644
index 3677bcb82867..000000000000
--- a/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.ebuild,v 1.3 2005/06/03 04:51:18 mr_bones_ Exp $
-
-inherit linux-info eutils multilib flag-o-matic
-
-DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
-HOMEPAGE="http://clemens.endorphin.org/LUKS/"
-SRC_URI="http://luks.endorphin.org/source/${PN}-${PV}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-
-DEPEND=">=sys-fs/device-mapper-1.00.07-r1
- >=dev-libs/libgcrypt-1.1.42
- >=dev-libs/libgpg-error-1.0-r1
- !sys-fs/cryptsetup"
-
-IUSE="static"
-
-dm-crypt_check() {
- ebegin "Checking for dm-crypt support"
- linux_chkconfig_present DM_CRYPT
- eend $?
-
- if [[ $? -ne 0 ]] ; then
- ewarn "cryptsetup requires dm-crypt support!"
- ewarn "Please enable dm-crypt support in your kernel config, found at:"
- ewarn "(for 2.6 kernels)"
- ewarn
- ewarn " Device Drivers"
- ewarn " Multi-Device Support"
- ewarn " Device mapper support"
- ewarn " [*] Crypt Target Support"
- ewarn
- ewarn "and recompile your kernel if you want this package to work with this kernel"
- epause 5
- fi
-}
-
-pkg_setup() {
- linux-info_pkg_setup
- dm-crypt_check;
-}
-
-src_compile() {
- cd ${S}
-
- if use static ; then
- append-ldflags -static
- econf --sbindir=/bin --enable-static --disable-nls || die
- else
- ewarn "If you need cryptsetup for an initrd or initramfs then you"
- ewarn "should emerge cryptsetup-luks with USE="static""
- epause 5
- econf --sbindir=/bin --disable-static --disable-nls || die
-
- sed -i \
- -e "s|-lgcrypt|/usr/$(get_libdir)/libgcrypt.a|" \
- -e "s|-lgpg-error|/usr/$(get_libdir)/libgpg-error.a|" \
- Makefile src/Makefile
- sed -i -e "s|-lpopt|/usr/$(get_libdir)/libpopt.a|" src/Makefile
- fi
-
- emake || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "install failed"
- insinto /lib/rcscripts/addons
- newconfd ${FILESDIR}/cryptfs.confd cryptfs
- doins "${FILESDIR}"/dm-crypt-{start,stop}.sh
-}