summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2003-03-30 18:29:41 +0000
committerChristian Birchinger <joker@gentoo.org>2003-03-30 18:29:41 +0000
commit26ce66dcb520c5908db1360bdb5333ec3ebd5bb2 (patch)
treecb1996cfb123a95bce4b10a3d47b7b560ad9a49a /sys-kernel/sparc-sources
parentut livecd tweaks (diff)
downloadhistorical-26ce66dcb520c5908db1360bdb5333ec3ebd5bb2.tar.gz
historical-26ce66dcb520c5908db1360bdb5333ec3ebd5bb2.tar.bz2
historical-26ce66dcb520c5908db1360bdb5333ec3ebd5bb2.zip
sparc-sources-2.4.20-r7 and digest added
Diffstat (limited to 'sys-kernel/sparc-sources')
-rw-r--r--sys-kernel/sparc-sources/ChangeLog10
-rw-r--r--sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.20-r72
-rw-r--r--sys-kernel/sparc-sources/sparc-sources-2.4.20-r7.ebuild63
3 files changed, 74 insertions, 1 deletions
diff --git a/sys-kernel/sparc-sources/ChangeLog b/sys-kernel/sparc-sources/ChangeLog
index 19c14cb697da..224819ddc1b1 100644
--- a/sys-kernel/sparc-sources/ChangeLog
+++ b/sys-kernel/sparc-sources/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-kernel/sparc-sources
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.19 2003/03/25 15:16:27 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.20 2003/03/30 18:29:41 joker Exp $
+
+*sparc-sources-2.4.20-r7 (30 Mar 2003)
+
+ 30 Mar 2003; Christian Birchinger <joker@gentoo.org>
+ sparc-sources-2.4.20-r7.ebuild files/digest-sparc-sources-2.4.20-r7 :
+ New Grsecurity 1.9.9e version included which has sparc64 fixes and
+ the ptrace security fix included. The standalone ptrace patch has
+ been removed.
*sparc-sources-2.4.20-r6 (19 Mar 2003)
diff --git a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.20-r7 b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.20-r7
new file mode 100644
index 000000000000..32fc90793270
--- /dev/null
+++ b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.20-r7
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 977c4aeba34dd04f9073142ef99ce89f patches-2.4.20-r7-sparc.tar.bz2 136356
diff --git a/sys-kernel/sparc-sources/sparc-sources-2.4.20-r7.ebuild b/sys-kernel/sparc-sources/sparc-sources-2.4.20-r7.ebuild
new file mode 100644
index 000000000000..4583c79ec363
--- /dev/null
+++ b/sys-kernel/sparc-sources/sparc-sources-2.4.20-r7.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/sparc-sources-2.4.20-r7.ebuild,v 1.1 2003/03/30 18:29:41 joker Exp $
+
+IUSE="build"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the
+# same.
+KV=${PV}
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+# This kernel also has support for the local USE flag acpi4linux which
+# activates the latest code from acpi.sourceforge.net instead of the
+# very out of date vanilla version
+
+ETYPE="sources"
+
+inherit kernel || die
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/sparc-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/patches-${PVR}-sparc.tar.bz2"
+KEYWORDS="~x86 -ppc ~sparc"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ kernel_src_unpack
+
+ # Patch the HME driver only on Ultra1 machines.
+ [ -n "${U1_HME_FIX}" ] && epatch ${FILESDIR}/U1-hme-lockup.patch
+}
+
+pkg_postinst() {
+ kernel_pkg_postinst
+
+ # Display SUN Ultra 1 HME warning if it can be detected or if the machinetype is unknown.
+ if [ ! -r "/proc/openprom/name" -o "`cat /proc/openprom/name 2>/dev/null`" = "'SUNW,Ultra-1'" ]; then
+ einfo
+ einfo "For users with an Enterprise model Ultra 1 using the HME network interface,"
+ einfo "please emerge the kernel using the following command:"
+ einfo
+ einfo "U1_HME_FIX=y emerge sparc-sources"
+ einfo
+ fi
+}