summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-10-29 04:53:35 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-10-29 04:53:35 +0000
commit36faab4904a06f673890be4c47f663e1a5efec2f (patch)
treedcc12089cc80862526fd391016b0999b185abe3c /sys-kernel
parentinitial (diff)
downloadhistorical-36faab4904a06f673890be4c47f663e1a5efec2f.tar.gz
historical-36faab4904a06f673890be4c47f663e1a5efec2f.tar.bz2
historical-36faab4904a06f673890be4c47f663e1a5efec2f.zip
add a few fixes
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/mjc-sources/files/digest-mjc-sources-2.4.20_pre10-r22
-rw-r--r--sys-kernel/mjc-sources/files/linux-2.4.20-pre10-mjc2-gentoo.diff22
-rw-r--r--sys-kernel/mjc-sources/mjc-sources-2.4.20_pre10-r2.ebuild9
3 files changed, 29 insertions, 4 deletions
diff --git a/sys-kernel/mjc-sources/files/digest-mjc-sources-2.4.20_pre10-r2 b/sys-kernel/mjc-sources/files/digest-mjc-sources-2.4.20_pre10-r2
index 1fcd773cd0ca..8659464a9dcf 100644
--- a/sys-kernel/mjc-sources/files/digest-mjc-sources-2.4.20_pre10-r2
+++ b/sys-kernel/mjc-sources/files/digest-mjc-sources-2.4.20_pre10-r2
@@ -1,2 +1,2 @@
MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
-MD5 b5879724ceb12493fffa8c2cd01158fb patches-2.4.20-pre10-mjc2.tar.gz 7887064
+MD5 3f710f8ffad3e8931bd1254fb9fae4b5 patches-2.4.20-pre10-mjc2.tar.bz2 6305791
diff --git a/sys-kernel/mjc-sources/files/linux-2.4.20-pre10-mjc2-gentoo.diff b/sys-kernel/mjc-sources/files/linux-2.4.20-pre10-mjc2-gentoo.diff
new file mode 100644
index 000000000000..105bd75f3dd8
--- /dev/null
+++ b/sys-kernel/mjc-sources/files/linux-2.4.20-pre10-mjc2-gentoo.diff
@@ -0,0 +1,22 @@
+--- linux/kernel/context.c 2002-10-28 21:14:53.000000000 -0600
++++ linux/kernel/context.c.new 2002-10-28 21:34:31.000000000 -0600
+@@ -16,7 +16,7 @@
+ #include <linux/module.h>
+ #include <linux/kernel.h>
+ #include <linux/sched.h>
+-#include <linux/sched_runqueue.h>
++/* #include <linux/sched_runqueue.h> */
+ #include <linux/init.h>
+ #include <linux/unistd.h>
+ #include <linux/signal.h>
+--- linux/include/linux/sched.h 2002-10-28 21:29:32.000000000 -0600
++++ linux/include/linux/sched.h.new 2002-10-28 21:59:50.000000000 -0600
+@@ -464,7 +464,7 @@
+ #define PF_MEMDIE 0x00001000 /* Killed for out-of-memory */
+ #define PF_FREE_PAGES 0x00002000 /* per process page freeing */
+ #define PF_NOIO 0x00004000 /* avoid generating further I/O */
+-
++#define PF_FSTRANS 0x00080000 /* inside a filesystem transaction */
+ #define PF_USEDFPU 0x00100000 /* task used FPU this quantum (SMP) */
+
+ /*
diff --git a/sys-kernel/mjc-sources/mjc-sources-2.4.20_pre10-r2.ebuild b/sys-kernel/mjc-sources/mjc-sources-2.4.20_pre10-r2.ebuild
index 0fc48f32d063..88d5793e6e7c 100644
--- a/sys-kernel/mjc-sources/mjc-sources-2.4.20_pre10-r2.ebuild
+++ b/sys-kernel/mjc-sources/mjc-sources-2.4.20_pre10-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mjc-sources/mjc-sources-2.4.20_pre10-r2.ebuild,v 1.1 2002/10/29 03:17:27 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mjc-sources/mjc-sources-2.4.20_pre10-r2.ebuild,v 1.2 2002/10/29 04:53:35 lostlogic Exp $
IUSE="build"
@@ -16,7 +16,7 @@ EXTRAVERSION=-pre10-mjc2
S=${WORKDIR}/linux-${KV}
DESCRIPTION="Full sources for MJC's Gentoo Linux kernel"
SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
- http://www.kernel.org/pub/linux/kernel/people/mjc/patches-${KV}.tar.gz"
+ http://www.kernel.org/pub/linux/kernel/people/mjc/patches-${KV}.tar.bz2"
KEYWORDS="x86 -ppc -sparc -sparc64"
src_unpack() {
@@ -24,9 +24,12 @@ src_unpack() {
unpack linux-${OKV}.tar.bz2
mv linux-${OKV} linux-${KV} || die
- unpack patches-${KV}.tar.gz
+ unpack patches-${KV}.tar.bz2
cd ${KV}
kernel_src_unpack
+ cd ${WORKDIR}/linux-${KV}
+ patch -p1 < ${FILESDIR}/linux-${KV}-gentoo.diff || die "Quickfixes failed"
+
}