summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2003-08-15 02:43:59 +0000
committerJoshua Kinard <kumba@gentoo.org>2003-08-15 02:43:59 +0000
commit7048722f679f7d29698ff81dd80989e446fe2206 (patch)
treec1ab74b2b29a777a119e5a2c8310efad686e618f /sys-kernel
parentInitial ebuild of linux-2.4.22-rc2 for MIPS systems. (diff)
downloadhistorical-7048722f679f7d29698ff81dd80989e446fe2206.tar.gz
historical-7048722f679f7d29698ff81dd80989e446fe2206.tar.bz2
historical-7048722f679f7d29698ff81dd80989e446fe2206.zip
Initial ebuild of linux-2.4.22-rc2 for MIPS systems.
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/mips-prepatch-sources/Manifest4
-rw-r--r--sys-kernel/mips-prepatch-sources/files/digest-mips-prepatch-sources-2.4.22_rc2-r13
-rw-r--r--sys-kernel/mips-prepatch-sources/files/mips-gcc-makefile-fix-20030813.patch28
-rw-r--r--sys-kernel/mips-prepatch-sources/mips-prepatch-sources-2.4.22_rc2-r1.ebuild53
4 files changed, 86 insertions, 2 deletions
diff --git a/sys-kernel/mips-prepatch-sources/Manifest b/sys-kernel/mips-prepatch-sources/Manifest
index 4c37a2b967d3..24fd893d5c30 100644
--- a/sys-kernel/mips-prepatch-sources/Manifest
+++ b/sys-kernel/mips-prepatch-sources/Manifest
@@ -1,4 +1,4 @@
-MD5 e8584eb21b05465ee87f9b7df1fc1842 mips-prepatch-sources-2.4.22_rc2-r1.ebuild 1570
-MD5 e41daf56daf57ff2881f4d5b3008ae99 ChangeLog 627
+MD5 652107e1001a957e981d9fabb3d7173d mips-prepatch-sources-2.4.22_rc2-r1.ebuild 1707
+MD5 7f8a6e3f98fb6300bfe3c70a318ed43b ChangeLog 731
MD5 b73a606d05e184a8af27c8f9b7a9c9ca files/mips-gcc-makefile-fix-20030813.patch 906
MD5 7383fb7245357cea3b46d07e372fc89a files/digest-mips-prepatch-sources-2.4.22_rc2-r1 215
diff --git a/sys-kernel/mips-prepatch-sources/files/digest-mips-prepatch-sources-2.4.22_rc2-r1 b/sys-kernel/mips-prepatch-sources/files/digest-mips-prepatch-sources-2.4.22_rc2-r1
new file mode 100644
index 000000000000..487b02e8ca79
--- /dev/null
+++ b/sys-kernel/mips-prepatch-sources/files/digest-mips-prepatch-sources-2.4.22_rc2-r1
@@ -0,0 +1,3 @@
+MD5 f51e12efa18bb828cf57d9d4a81b2fb1 linux-2.4.21.tar.bz2 28533733
+MD5 141f00e759d6aa30cc0b2a25f1f0d60e patch-2.4.22-rc2.bz2 4290549
+MD5 ea8b93ffb1a629d55982b7768edad78d mipscvs-2.4.22-rc2-20030813.diff.bz2 1023647
diff --git a/sys-kernel/mips-prepatch-sources/files/mips-gcc-makefile-fix-20030813.patch b/sys-kernel/mips-prepatch-sources/files/mips-gcc-makefile-fix-20030813.patch
new file mode 100644
index 000000000000..587b18073870
--- /dev/null
+++ b/sys-kernel/mips-prepatch-sources/files/mips-gcc-makefile-fix-20030813.patch
@@ -0,0 +1,28 @@
+--- arch/mips/Makefile.orig 2003-08-13 20:45:28.000000000 -0400
++++ arch/mips/Makefile 2003-08-13 20:46:30.000000000 -0400
+@@ -72,7 +72,7 @@ ifdef CONFIG_CPU_VR41XX
+ GCCFLAGS += -mcpu=r4600 -mips2 -Wa,--trap
+ endif
+ ifdef CONFIG_CPU_R4X00
+-GCCFLAGS += -mcpu=r4600 -mips2 -Wa,--trap
++GCCFLAGS += -mips3 -Wa,--trap
+ endif
+ ifdef CONFIG_CPU_TX49XX
+ GCCFLAGS += -mcpu=r4600 -mips2 -Wa,--trap
+@@ -84,14 +84,14 @@ ifdef CONFIG_CPU_MIPS64
+ GCCFLAGS += -mcpu=r4600 -mips2 -Wa,--trap
+ endif
+ ifdef CONFIG_CPU_R5000
+-GCCFLAGS += -mcpu=r5000 -mips2 -Wa,--trap
++GCCFLAGS += -mips4 -Wa,--trap
+ endif
+ ifdef CONFIG_CPU_R5432
+ GCCFLAGS += -mcpu=r5000 -mips2 -Wa,--trap
+ endif
+ ifdef CONFIG_CPU_NEVADA
+ # Cannot use -mmad with currently recommended tools
+-GCCFLAGS += -mcpu=r5000 -mips2 -Wa,--trap
++GCCFLAGS += -mips4 -Wa,--trap
+ endif
+ ifdef CONFIG_CPU_RM7000
+ GCCFLAGS += $(call check_gcc, -march=rm7000, -mcpu=r5000) \
diff --git a/sys-kernel/mips-prepatch-sources/mips-prepatch-sources-2.4.22_rc2-r1.ebuild b/sys-kernel/mips-prepatch-sources/mips-prepatch-sources-2.4.22_rc2-r1.ebuild
new file mode 100644
index 000000000000..9b8151ab9231
--- /dev/null
+++ b/sys-kernel/mips-prepatch-sources/mips-prepatch-sources-2.4.22_rc2-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-prepatch-sources/mips-prepatch-sources-2.4.22_rc2-r1.ebuild,v 1.1 2003/08/15 02:43:52 kumba Exp $
+
+
+# Eclass Stuff
+ETYPE="sources"
+inherit kernel
+
+# Version Data
+OKV=${PV/_/-}
+CVSDATE=20030813
+EXTRAVERSION=-$(echo ${OKV} | cut -d- -f2)-mipscvs-${CVSDATE}
+STABLEVERSION=2.4.21
+
+# Miscellaneous
+S=${WORKDIR}/linux-${OKV}
+PROVIDE="virtual/linux-sources"
+
+
+# INCLUDED:
+# 1) linux stable sources from kernel.org
+# 2) patch to latest linux prepatch sources
+# 3) linux-mips.org CVS snapshot diff from 13 Aug 2003
+# 4) patch to fix arch/mips/Makefile to pass appropriate CFLAGS
+
+DESCRIPTION="Linux-Mips CVS pre-patch sources for MIPS-based machines"
+SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${STABLEVERSION}.tar.bz2
+ mirror://kernel/linux/kernel/v2.4/testing/patch-${OKV}.bz2
+ mirror://gentoo/mipscvs-${OKV}-${CVSDATE}.diff.bz2"
+HOMEPAGE="http://www.kernel.org http://www.linux-mips.org/"
+KEYWORDS="-* ~mips"
+SLOT="${OKV}"
+
+src_unpack() {
+ unpack ${A}
+ mv ${WORKDIR}/linux-${STABLEVERSION} ${S}
+ cd ${S}
+
+ # Update the vanilla sources with prepatch diff
+ einfo ">>> Patching linux-${STABLEVERSION} to linux-${OKV} ..."
+ cat ${WORKDIR}/patch-${OKV} | patch -p1
+
+ # Update the vanilla prepatch sources with linux-mips CVS changes
+ einfo ">>> Patching linux-${OKV} to linux-${OKV}${EXTRAVERSION} ..."
+ cat ${WORKDIR}/mipscvs-${OKV}-${CVSDATE}.diff | patch -p1
+
+ # Patch arch/mips/Makefile for gcc
+ einfo ">>> Patching arch/mips/Makefile ..."
+ cat ${FILESDIR}/mips-gcc-makefile-fix-${CVSDATE}.patch | patch -p0
+
+ kernel_universal_unpack
+}