summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-11 03:30:49 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-11 03:30:49 +0000
commita9819f9a7bad7d28b92d8938f7c2a2887a4e4a05 (patch)
tree4c365f90f17ba8f16e9a0d132a34b38e00712d20 /sys-libs/com_err
parentClean up cross-compile support. (diff)
downloadhistorical-a9819f9a7bad7d28b92d8938f7c2a2887a4e4a05.tar.gz
historical-a9819f9a7bad7d28b92d8938f7c2a2887a4e4a05.tar.bz2
historical-a9819f9a7bad7d28b92d8938f7c2a2887a4e4a05.zip
Clean up cross-compile support.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'sys-libs/com_err')
-rw-r--r--sys-libs/com_err/files/com_err-1.37-makefile.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/sys-libs/com_err/files/com_err-1.37-makefile.patch b/sys-libs/com_err/files/com_err-1.37-makefile.patch
index 57dcee4a20b2..b60ea5a37677 100644
--- a/sys-libs/com_err/files/com_err-1.37-makefile.patch
+++ b/sys-libs/com_err/files/com_err-1.37-makefile.patch
@@ -34,3 +34,14 @@ Don't use target LDFLAGS/CFLAGS when compiling native apps.
gen-tarball: $(srcdir)/gen-tarball.in $(top_builddir)/config.status
@echo " CONFIG.STATUS $@"
+--- lib/Makefile.elf-lib
++++ lib/Makefile.elf-lib
+@@ -26,7 +26,7 @@
+
+ $(ELF_LIB): $(OBJS)
+ @echo " GEN_ELF_SOLIB $(ELF_LIB)"
+- @(cd elfshared; $(CC) --shared -o $(ELF_LIB) \
++ @(cd elfshared; $(CC) --shared -o $(ELF_LIB) $(LDFLAGS) \
+ -Wl,-soname,$(ELF_SONAME) $(OBJS) $(ELF_OTHER_LIBS))
+ @$(MV) elfshared/$(ELF_LIB) .
+ @$(RM) -f ../$(ELF_LIB) ../$(ELF_IMAGE).so ../$(ELF_SONAME)