summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-07-28 23:37:13 +0000
committerMike Frysinger <vapier@gentoo.org>2004-07-28 23:37:13 +0000
commit9fda57165347c6adac01bad3e7120680059544be (patch)
tree650fb79f1cf34b61e306e24c414a5294b6a01883 /sys-libs/readline/readline-4.3-r3.ebuild
parentversion bump (bug #58480) - comments from Gard Spreemann (diff)
downloadhistorical-9fda57165347c6adac01bad3e7120680059544be.tar.gz
historical-9fda57165347c6adac01bad3e7120680059544be.tar.bz2
historical-9fda57165347c6adac01bad3e7120680059544be.zip
punt old versions
Diffstat (limited to 'sys-libs/readline/readline-4.3-r3.ebuild')
-rw-r--r--sys-libs/readline/readline-4.3-r3.ebuild76
1 files changed, 0 insertions, 76 deletions
diff --git a/sys-libs/readline/readline-4.3-r3.ebuild b/sys-libs/readline/readline-4.3-r3.ebuild
deleted file mode 100644
index 38aadd4a29ac..000000000000
--- a/sys-libs/readline/readline-4.3-r3.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.3-r3.ebuild,v 1.11 2004/06/24 23:09:19 agriffis Exp $
-
-inherit eutils
-
-# Official patches
-PLEVEL="x001 x002"
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Another cute console display library"
-SRC_URI="ftp://ftp.gnu.org/gnu/readline/${P}.tar.gz
- ftp://gatekeeper.dec.com/pub/GNU/readline/${P}.tar.gz
- ${PLEVEL//x/ftp://ftp.gnu.org/gnu/${PN}/${PN}-${PV}-patches/${PN}${PV/\.}-}"
-HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha mips"
-
-# We must be sertain that we have a bash that is linked
-# to its internal readline, else we may get problems.
-DEPEND=">=app-shells/bash-2.05b-r2
- >=sys-libs/ncurses-5.2-r2"
-
-src_unpack() {
-
- unpack ${P}.tar.gz
-
- cd ${S}
- for x in ${PLEVEL//x}
- do
- patch -p0 < ${DISTDIR}/${PN}${PV/\.}-${x} || die
- done
-
-}
-
-src_compile() {
-
- econf --with-curses || die
-
- emake || die
- cd shlib
- emake || die
-}
-
-
-src_install() {
-
- make prefix=${D}/usr mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info install || die
- cd ${S}/shlib
- make prefix=${D}/usr mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info install || die
-
- cd ${S}
-
- dodir /lib
- mv ${D}/usr/lib/*.so* ${D}/lib
- # bug #4411
- gen_usr_ldscript libreadline.so
- gen_usr_ldscript libhistory.so
- # end bug #4411
- dosym libhistory.so.${PV/a/} /lib/libhistory.so
- dosym libreadline.so.${PV/a/} /lib/libreadline.so
- # Needed because make install uses ${D} for the link
- dosym libhistory.so.${PV/a/} /lib/libhistory.so.4
- dosym libreadline.so.${PV/a/} /lib/libreadline.so.4
- chmod 755 ${D}/lib/*.${PV/a/}
-
- dodoc CHANGELOG CHANGES COPYING MANIFEST README USAGE
- docinto ps
- dodoc doc/*.ps
- dohtml -r doc
-}
-