summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-07-28 06:11:47 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-07-28 06:11:47 +0000
commit6d08f3cd748dcf67fe2465757992e026d852fd81 (patch)
tree69856341cd76824342f9ab433eb25936b5209a67 /sys-libs
parentAdded ppc to KEYWORDS. Seemant: the compressed folder patch author is Roland ... (diff)
downloadhistorical-6d08f3cd748dcf67fe2465757992e026d852fd81.tar.gz
historical-6d08f3cd748dcf67fe2465757992e026d852fd81.tar.bz2
historical-6d08f3cd748dcf67fe2465757992e026d852fd81.zip
gcc-3.2 fixes; cleanup
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/ChangeLog10
-rw-r--r--sys-libs/db/db-3.2.9-r1.ebuild97
-rw-r--r--sys-libs/db/files/digest-db-3.2.9-r11
3 files changed, 106 insertions, 2 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index 8aef936082cb..aa62d83f3e06 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,10 +1,16 @@
# ChangeLog for sys-libs/db
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.7 2002/07/25 01:52:51 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.8 2002/07/28 06:11:47 azarah Exp $
+
+db-3.2.9-r1 (28 Jul 2002)
+
+ 28 Jul 2002; Martin Schlemmer <azarah@gentoo.org> :
+ Update to get it working with gcc-3.2 (remove config.guess), as well
+ as cleanups.
db-3.2.9 (25 Jul 2002)
25 Jul 2002; Spider <spider@gentoo.org> :
- add a fix to remove -fno-exceptions in CXXFLAGS as it doesnt build then
+ Add a fix to remove -fno-exceptions in CXXFLAGS as it doesnt build then
*db-4.0.14 (changelog entries missing/omitted?) - Gerk
diff --git a/sys-libs/db/db-3.2.9-r1.ebuild b/sys-libs/db/db-3.2.9-r1.ebuild
new file mode 100644
index 000000000000..69c53bcbbaba
--- /dev/null
+++ b/sys-libs/db/db-3.2.9-r1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r1.ebuild,v 1.1 2002/07/28 06:11:47 azarah Exp $
+
+S=${WORKDIR}/${P}/build_unix
+DESCRIPTION="Berkeley DB for transaction support in MySQL"
+SRC_URI="http://www.sleepycat.com/update/${PV}/${P}.tar.gz"
+HOMEPAGE="http://www.sleepycat.com/"
+
+SLOT="3"
+LICENSE="DB"
+KEYWORDS="x86 ppc"
+
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND}
+ =sys-libs/db-1.85-r1
+ sys-devel/libtool
+ sys-devel/m4"
+# We need m4 to else build fails without config.guess
+
+# this doesnt build without exceptions
+export CXXFLAGS="${CXXFLAGS/-fno-exceptions/-fexceptions}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${WORKDIR}/${P}
+ patch -p0 < ${FILESDIR}/patch.3.2.9.1 || die
+ patch -p0 < ${FILESDIR}/patch.3.2.9.2 || die
+
+ # fix invalid .la files
+ cd ${WORKDIR}/${P}/dist
+ rm -f ltversion.sh
+ cp ${ROOT}/usr/share/libtool/ltmain.sh . || \
+ die "Could not update ltmain.sh"
+ # remove config.guess else we have problems with gcc-3.2
+ rm -f config.guess
+}
+
+src_compile() {
+ ../dist/configure --host=${CHOST} \
+ --build=${CHOST} \
+ --enable-compat185 \
+ --enable-dump185 \
+ --prefix=/usr \
+ --enable-shared \
+ --enable-static \
+ --enable-cxx || die
+
+ #--enable-rpc does not work
+ echo
+ # Parallel make does not work
+ einfo "Building static libs..."
+ make libdb=libdb-3.2.a libdb-3.2.a || die
+ make libcxx=libdb_cxx-3.2.a libdb_cxx-3.2.a || die
+ echo
+ einfo "Building db_dump185..."
+ /bin/sh ./libtool --mode=compile cc -c ${CFLAGS} -D_GNU_SOURCE \
+ -I/usr/include/db1 -I../dist/../include -D_REENTRANT \
+ ../dist/../db_dump185/db_dump185.c || die
+ gcc -s -static -o db_dump185 db_dump185.lo -L/usr/lib -ldb1 || die
+ echo
+ einfo "Building everything else..."
+ make libdb=libdb-3.2.a libcxx=libdb_cxx-3.2.a || die
+}
+
+src_install () {
+ make libdb=libdb-3.2.a \
+ libcxx=libcxx_3.2.a \
+ prefix=${D}/usr \
+ install || die
+
+ dolib.a libdb-3.2.a libdb_cxx-3.2.a
+
+ dodir usr/include/db3
+ cd ${D}/usr/include
+ mv *.h db3
+ ln db3/db.h db.h
+
+ cd ${D}/usr/lib
+ ln -s libdb-3.2.so libdb.so.3
+
+ #for some reason, db.so's are *not* readable by group or others, resulting in no one
+ #but root being able to use them!!! This fixes it -- DR 15 Jun 2001
+ cd ${D}/usr/lib
+ chmod go+rx *.so
+ #.la's aren't go readable either
+ chmod go+r *.la
+
+ cd ${S}/..
+ dodoc README LICENSE
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/docs/* ${D}/usr/share/doc/${PF}/html
+ rm -rf ${D}/usr/docs
+}
+
diff --git a/sys-libs/db/files/digest-db-3.2.9-r1 b/sys-libs/db/files/digest-db-3.2.9-r1
new file mode 100644
index 000000000000..cc0f167ea09b
--- /dev/null
+++ b/sys-libs/db/files/digest-db-3.2.9-r1
@@ -0,0 +1 @@
+MD5 4df5c7051b11411e0a970f6c91613942 db-3.2.9.tar.gz 2085238