summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-03-27 12:05:38 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-03-27 12:05:38 +0000
commitadc8e624585f4a0ae7c461fce23e50a0db3ec928 (patch)
tree81324b5a17a71d1da64a283592f4afaf5ab0ee2a /sys-libs
parenttypo fix (diff)
downloadhistorical-adc8e624585f4a0ae7c461fce23e50a0db3ec928.tar.gz
historical-adc8e624585f4a0ae7c461fce23e50a0db3ec928.tar.bz2
historical-adc8e624585f4a0ae7c461fce23e50a0db3ec928.zip
create /dev device
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libraw1394/ChangeLog6
-rw-r--r--sys-libs/libraw1394/libraw1394-0.9.0.ebuild21
2 files changed, 16 insertions, 11 deletions
diff --git a/sys-libs/libraw1394/ChangeLog b/sys-libs/libraw1394/ChangeLog
index 453dbac93a0f..58d33fa322b7 100644
--- a/sys-libs/libraw1394/ChangeLog
+++ b/sys-libs/libraw1394/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sys-libs/libraw1394
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libraw1394/ChangeLog,v 1.4 2003/03/27 12:05:38 seemant Exp $
-*libavc1394-0.3.1 (12 Jul 2002)
+*libraw1394-0.9.0 (12 Jul 2002)
+
+ 27 Mar 2003; Seemant Kulleen <seemant@gentoo.org> libraw1394-0.9.0.ebuild:
+ create device. Closes bug #18287 by Frantz Dhin <tragedy_rm@hotmail.com>
20 Jul 2002; Mark Guertin <gerk@gentoo.org> libraw1394-0.9.0.ebuild :
Added ppc keyword
diff --git a/sys-libs/libraw1394/libraw1394-0.9.0.ebuild b/sys-libs/libraw1394/libraw1394-0.9.0.ebuild
index 219789e54e68..15c9bc382426 100644
--- a/sys-libs/libraw1394/libraw1394-0.9.0.ebuild
+++ b/sys-libs/libraw1394/libraw1394-0.9.0.ebuild
@@ -2,24 +2,25 @@
# Distributed under the terms of the GNU General Public License v2
# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.8 2002/05/30 01:54:49 sandymac Exp
+S=${WORKDIR}/${P}
DESCRIPTION="libraw1394 provides direct access to the IEEE 1394 bus through the Linux 1394 subsystem's raw1394 user space interface."
HOMEPAGE="http://sourceforge.net/projects/libraw1394/"
-LICENSE="LGPL-2.1 | GPL-2"
-SRC_URI="http://telia.dl.sourceforge.net/sourceforge/libraw1394/${PN}_${PV}.tar.gz"
-S=${WORKDIR}/${P}
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.tar.gz"
-DEPEND=""
SLOT="0"
+LICENSE="LGPL-2.1 | GPL-2"
KEYWORDS="x86 ppc"
+DEPEND="virtual/glibc"
+
src_compile() {
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
-
+ econf || die
emake || die
+
+ if [ ! -f /dev/raw1394 ]
+ then
+ emake dev
+ fi
}
src_install () {