summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-12-27 19:08:55 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-12-27 19:08:55 +0000
commit20f76e0b13dbcfda0511078e09438187f8b7c6cd (patch)
tree9805afff6d3e3285503fe7846e50050bfeffd15b /sys-power/iasl
parentFixing bugs 116832 115771 114635, updating grsec, removing selinux/pax networ... (diff)
downloadhistorical-20f76e0b13dbcfda0511078e09438187f8b7c6cd.tar.gz
historical-20f76e0b13dbcfda0511078e09438187f8b7c6cd.tar.bz2
historical-20f76e0b13dbcfda0511078e09438187f8b7c6cd.zip
Bug #116780, version bump. Also authored a patch to allow everything to build properly so that we have all utilities, need to send upstream.
Package-Manager: portage-2.1_pre2
Diffstat (limited to 'sys-power/iasl')
-rw-r--r--sys-power/iasl/ChangeLog9
-rw-r--r--sys-power/iasl/Manifest5
-rw-r--r--sys-power/iasl/files/acpica-unix-20051216-buildfixup.patch195
-rw-r--r--sys-power/iasl/files/digest-iasl-200512161
-rw-r--r--sys-power/iasl/iasl-20051216.ebuild36
5 files changed, 244 insertions, 2 deletions
diff --git a/sys-power/iasl/ChangeLog b/sys-power/iasl/ChangeLog
index 6507f74012fb..68bdf3f92597 100644
--- a/sys-power/iasl/ChangeLog
+++ b/sys-power/iasl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-power/iasl
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/ChangeLog,v 1.5 2005/11/24 15:49:01 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/ChangeLog,v 1.6 2005/12/27 19:08:55 robbat2 Exp $
+
+*iasl-20051216 (27 Dec 2005)
+
+ 27 Dec 2005; Robin H. Johnson <robbat2@gentoo.org>
+ +files/acpica-unix-20051216-buildfixup.patch, +iasl-20051216.ebuild:
+ Bug #116780, version bump. Also authored a patch to allow everything to
+ build properly so that we have all utilities, need to send upstream.
24 Nov 2005; Jory A. Pratt <anarchy@gentoo.org> iasl-20050513.ebuild:
added to ~amd64
diff --git a/sys-power/iasl/Manifest b/sys-power/iasl/Manifest
index 462e0c5343fd..44ac8af96623 100644
--- a/sys-power/iasl/Manifest
+++ b/sys-power/iasl/Manifest
@@ -1,6 +1,9 @@
-MD5 eae4dc7feffdea9e0638e5ece2b668ff ChangeLog 794
+MD5 060be6deaf270b1ba5dd82088d41d898 ChangeLog 1094
+MD5 56a331d92e6f09c331eb8a7ddd2f603a files/acpica-unix-20051216-buildfixup.patch 6542
MD5 ada16f2385fb76e4e3ed7c37844211b3 files/digest-iasl-20050309 72
MD5 dd925783a88732c34474964006307d32 files/digest-iasl-20050513 72
+MD5 8c9da9f366d0d2e4c6aeee492b735660 files/digest-iasl-20051216 72
MD5 e6d1bf87bf02c26164239f9e31cb41ad iasl-20050309.ebuild 700
MD5 ffd86cd542fe8e32753b4ad3c879259c iasl-20050513.ebuild 736
+MD5 f71d0860e670723f7e964fd98b79e35f iasl-20051216.ebuild 922
MD5 21cd68602737d7c996bceabf6e62c468 metadata.xml 223
diff --git a/sys-power/iasl/files/acpica-unix-20051216-buildfixup.patch b/sys-power/iasl/files/acpica-unix-20051216-buildfixup.patch
new file mode 100644
index 000000000000..27056b355689
--- /dev/null
+++ b/sys-power/iasl/files/acpica-unix-20051216-buildfixup.patch
@@ -0,0 +1,195 @@
+Patches by Robin H. Johnson <robbat2@gentoo.org> - 2005/12/27
+
+Previously using GCC you had to do make clean between making each of the
+seperate utilities. This was due to the fact that depending on what compiler
+defines were passed, the output was different.
+The following patch makes the output files reflect which utility they are
+compiled for, so they don't conflict, and no make clean is needed.
+
+This patch also adds a top level Makefile to allow quick building of the entire
+package.
+
+Also fixes parallel build issues in compiler/ and two compile issues with
+acpibin.
+diff -Naur acpica-unix-20051216/Makefile acpica-unix-20051216.new/Makefile
+--- acpica-unix-20051216/Makefile 1969-12-31 16:00:00.000000000 -0800
++++ acpica-unix-20051216.new/Makefile 2005-12-27 10:15:13.000000000 -0800
+@@ -0,0 +1,29 @@
++PROGS= compiler/iasl tools/acpiexec/acpiexec tools/acpibin/acpibin tools/acpisrc/acpisrc
++ifndef CFLAGS
++CFLAGS= -O2
++endif
++
++all: $(PROGS)
++
++iasl: compiler
++acpiexec: tools/acpiexec
++acpibin: tools/acpibin
++acpisrc: tools/acpisrc
++
++SUBDIRS = $(dir $(PROGS))
++.PHONY: $(SUBDIRS) all
++
++compiler: compiler/iasl
++tools/acpiexec: tools/acpiexec/acpiexec
++tools/acpibin: tools/acpibin/acpibin
++tools/acpisrc: tools/acpisrc/acpisrc
++
++
++$(PROGS):
++ CFLAGS="$(CFLAGS)" $(MAKE) -C $(dir $(@))
++
++clean: clean-subdirs
++clean-subdirs:
++ for dir in $(SUBDIRS); do \
++ $(MAKE) -C $$dir clean; \
++ done
+diff -Naur acpica-unix-20051216/compiler/Makefile acpica-unix-20051216.new/compiler/Makefile
+--- acpica-unix-20051216/compiler/Makefile 2005-12-16 14:11:58.000000000 -0800
++++ acpica-unix-20051216.new/compiler/Makefile 2005-12-27 10:07:34.000000000 -0800
+@@ -81,7 +81,7 @@
+ ../osunixxf.c
+
+ NOMAN= YES
+-CFLAGS+= -Wall -O2 -Wstrict-prototypes -D_LINUX -DACPI_ASL_COMPILER -I../include
++CFLAGS+= -Wall -Wstrict-prototypes -D_LINUX -DACPI_ASL_COMPILER -I../include
+
+ #YACC= yacc
+ YACC= bison
+@@ -95,14 +95,22 @@
+ #CFLAGS+= -D_USE_BERKELEY_YACC
+ #.endif
+
+-aslmain : $(patsubst %.c,%.o, $(SRCS))
+- $(CC) $(LDFLAGS) $(patsubst %.c,%.o, $(SRCS)) \
++%.iasl.o: %.c
++ $(COMPILE.c) $(OUTPUT_OPTION) $<
++
++OBJS= $(patsubst %.c,%.iasl.o, $(SRCS))
++
++aslmain : $(OBJS)
++ $(CC) $(LDFLAGS) $(OBJS) \
+ $(LOADLIBES) $(LDLIBS) -o iasl
+
+ CLEANFILES= y.output y.tab.c y.tab.h aslcompiler.y.h \
+ aslcompilerparse.c aslcompilerlex.c iasl
+
+-aslcompilerparse.c: aslcompiler.y
++# force the YACC work to be done before any sources
++# as they all depend on it.
++$(SRCS): aslcompiler.y.h
++aslcompiler.y.h: aslcompiler.y
+ ${YACC} ${YFLAGS} aslcompiler.y
+ cp y.tab.c aslcompilerparse.c
+ cp y.tab.h aslcompiler.y.h
+@@ -111,5 +119,5 @@
+ ${LEX} ${LFLAGS} -PAslCompiler -oaslcompilerlex.c aslcompiler.l
+
+ clean :
+- rm -f $(CLEANFILES) $(patsubst %.c,%.o, $(SRCS))
++ rm -f $(CLEANFILES) $(OBJS)
+
+diff -Naur acpica-unix-20051216/tools/acpibin/Makefile acpica-unix-20051216.new/tools/acpibin/Makefile
+--- acpica-unix-20051216/tools/acpibin/Makefile 2005-12-16 14:12:10.000000000 -0800
++++ acpica-unix-20051216.new/tools/acpibin/Makefile 2005-12-27 09:43:28.000000000 -0800
+@@ -12,14 +12,18 @@
+ ../../osunixxf.c \
+ ../../common/getopt.c
+
+-CFLAGS+= -Wall -O2 -D_LINUX -DACPI_APPLICATION -Wstrict-prototypes -I../../include
++CFLAGS+= -Wall -D_LINUX -DACPI_APPLICATION -Wstrict-prototypes -I../../include
+
++%.acpibinsrc.o: %.c
++ $(COMPILE.c) $(OUTPUT_OPTION) $<
+
+-acpibin : $(patsubst %.c,%.o, $(SRCS))
+- $(CC) $(LDFLAGS) $(patsubst %.c,%.o, $(SRCS)) -o $(PROG)
++OBJS= $(patsubst %.c,%.acpibinsrc.o, $(SRCS))
++
++acpibin : $(OBJS)
++ $(CC) $(LDFLAGS) $(OBJS) -o $(PROG)
+
+ CLEANFILES= $(PROG)
+
+ clean :
+- rm -f $(CLEANFILES) $(patsubst %.c,%.o, $(SRCS))
++ rm -f $(CLEANFILES) $(OBJS)
+
+diff -Naur acpica-unix-20051216/tools/acpibin/abcompare.c acpica-unix-20051216.new/tools/acpibin/abcompare.c
+--- acpica-unix-20051216/tools/acpibin/abcompare.c 2005-12-16 14:12:10.000000000 -0800
++++ acpica-unix-20051216.new/tools/acpibin/abcompare.c 2005-12-26 23:44:16.000000000 -0800
+@@ -116,6 +116,7 @@
+ *****************************************************************************/
+
+ #include "acpibin.h"
++#define O_BINARY 0
+ #include <stdlib.h>
+
+
+diff -Naur acpica-unix-20051216/tools/acpibin/acpibin.h acpica-unix-20051216.new/tools/acpibin/acpibin.h
+--- acpica-unix-20051216/tools/acpibin/acpibin.h 2005-12-16 14:12:10.000000000 -0800
++++ acpica-unix-20051216.new/tools/acpibin/acpibin.h 2005-12-26 23:44:02.000000000 -0800
+@@ -120,9 +120,9 @@
+ #include <sys/stat.h>
+ #include <sys/types.h>
+ #include <fcntl.h>
+-#include <io.h>
++#include <sys/io.h>
+ #include <ctype.h>
+-#include <direct.h>
++//#include <direct.h>
+ #include <errno.h>
+
+ #include "acpi.h"
+diff -Naur acpica-unix-20051216/tools/acpiexec/Makefile acpica-unix-20051216.new/tools/acpiexec/Makefile
+--- acpica-unix-20051216/tools/acpiexec/Makefile 2005-12-16 14:12:10.000000000 -0800
++++ acpica-unix-20051216.new/tools/acpiexec/Makefile 2005-12-27 09:41:46.000000000 -0800
+@@ -130,14 +130,18 @@
+ ../../osunixxf.c
+
+
+-CFLAGS+= -Wall -g -D_LINUX -DNDEBUG -D_CONSOLE -DACPI_EXEC_APP -D_MULTI_THREADED -Wstrict-prototypes -I../../include
++CFLAGS+= -Wall -D_LINUX -DNDEBUG -D_CONSOLE -DACPI_EXEC_APP -D_MULTI_THREADED -Wstrict-prototypes -I../../include
+
++%.acpiexec.o: %.c
++ $(COMPILE.c) $(OUTPUT_OPTION) $<
+
+-acpiexec : $(patsubst %.c,%.o, $(SRCS))
+- $(CC) $(LDFLAGS) $(patsubst %.c,%.o, $(SRCS)) -o $(PROG)
++OBJS = $(patsubst %.c,%.acpiexec.o, $(SRCS))
++
++acpiexec : $(OBJS)
++ $(CC) $(LDFLAGS) $(OBJS) -o $(PROG)
+
+ CLEANFILES= $(PROG)
+
+ clean :
+- rm -f $(CLEANFILES) $(patsubst %.c,%.o, $(SRCS))
++ rm -f $(CLEANFILES) $(OBJS)
+
+diff -Naur acpica-unix-20051216/tools/acpisrc/Makefile acpica-unix-20051216.new/tools/acpisrc/Makefile
+--- acpica-unix-20051216/tools/acpisrc/Makefile 2005-12-16 14:12:11.000000000 -0800
++++ acpica-unix-20051216.new/tools/acpisrc/Makefile 2005-12-27 09:43:21.000000000 -0800
+@@ -4,14 +4,18 @@
+ SRCS= ascase.c asconvrt.c asfile.c asmain.c asremove.c asutils.c osunixdir.c \
+ ../../common/getopt.c
+
+-CFLAGS+= -Wall -O2 -D_LINUX -DACPI_APPLICATION -Wstrict-prototypes -I../../include
++CFLAGS+= -Wall -D_LINUX -DACPI_APPLICATION -Wstrict-prototypes -I../../include
+
++%.acpibinsrc.o: %.c
++ $(COMPILE.c) $(OUTPUT_OPTION) $<
+
+-aslmain : $(patsubst %.c,%.o, $(SRCS))
+- $(CC) $(LDFLAGS) $(patsubst %.c,%.o, $(SRCS)) -o $(PROG)
++OBJS= $(patsubst %.c,%.acpibinsrc.o, $(SRCS))
++
++aslmain : $(OBJS)
++ $(CC) $(LDFLAGS) $(OBJS) -o $(PROG)
+
+ CLEANFILES= $(PROG)
+
+ clean :
+- rm -f $(CLEANFILES) $(patsubst %.c,%.o, $(SRCS))
++ rm -f $(CLEANFILES) $(OBJS)
+
diff --git a/sys-power/iasl/files/digest-iasl-20051216 b/sys-power/iasl/files/digest-iasl-20051216
new file mode 100644
index 000000000000..85d4ec27978e
--- /dev/null
+++ b/sys-power/iasl/files/digest-iasl-20051216
@@ -0,0 +1 @@
+MD5 eee5c3e4e2660b7ddf0102a0d224cb54 acpica-unix-20051216.tar.gz 818242
diff --git a/sys-power/iasl/iasl-20051216.ebuild b/sys-power/iasl/iasl-20051216.ebuild
new file mode 100644
index 000000000000..fabcbf941350
--- /dev/null
+++ b/sys-power/iasl/iasl-20051216.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20051216.ebuild,v 1.1 2005/12/27 19:08:55 robbat2 Exp $
+
+inherit toolchain-funcs eutils
+
+MY_PN=acpica-unix
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Intel ACPI Source Language (ASL) compiler"
+HOMEPAGE="http://www.intel.com/technology/iapc/acpi/"
+SRC_URI="http://www.intel.com/technology/iapc/acpi/downloads/${MY_P}.tar.gz"
+
+LICENSE="iASL"
+SLOT="0"
+KEYWORDS="~ppc ~x86 ~amd64"
+
+IUSE=""
+DEPEND="sys-devel/bison
+ sys-devel/flex"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${MY_PN}-20051216-buildfixup.patch
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ dobin compiler/iasl tools/acpibin/acpibin tools/acpiexec/acpiexec tools/acpisrc/acpisrc
+ dodoc README changes.txt
+}