summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-05-03 19:37:43 +0000
committerJustin Lecher <jlec@gentoo.org>2013-05-03 19:37:43 +0000
commit67f0db3e7b10997816bfa307fc8bbb126f8a2c87 (patch)
treeeb4785742255935b0036cdad9276d6b5143bf256 /sys-process/htop/files
parentNeeds to block the old versions of app-misc/pip before that tool was moved to... (diff)
downloadhistorical-67f0db3e7b10997816bfa307fc8bbb126f8a2c87.tar.gz
historical-67f0db3e7b10997816bfa307fc8bbb126f8a2c87.tar.bz2
historical-67f0db3e7b10997816bfa307fc8bbb126f8a2c87.zip
sys-process/htop: Add compatibility patch for ncurses[tinfo]
Package-Manager: portage-2.2.0_alpha173/cvs/Linux x86_64 Manifest-Sign-Key: 0x8009D6F070EB7916
Diffstat (limited to 'sys-process/htop/files')
-rw-r--r--sys-process/htop/files/htop-1.0.2-tinfo.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-process/htop/files/htop-1.0.2-tinfo.patch b/sys-process/htop/files/htop-1.0.2-tinfo.patch
new file mode 100644
index 000000000000..e7fb43d25a9e
--- /dev/null
+++ b/sys-process/htop/files/htop-1.0.2-tinfo.patch
@@ -0,0 +1,50 @@
+ Makefile.am | 2 ++
+ configure.ac | 20 ++++++++++++--------
+ 2 files changed, 14 insertions(+), 8 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 05a72e7..7908937 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -36,6 +36,8 @@ SUFFIXES = .h
+ BUILT_SOURCES = $(myhtopheaders)
+ htop_SOURCES = $(myhtopheaders) $(myhtopsources) config.h
+
++htop_LDADD = $(NCURSES_LIBS)
++
+ profile:
+ $(MAKE) all CFLAGS="" AM_CPPFLAGS="-pg -O2"
+
+diff --git a/configure.ac b/configure.ac
+index ff6901b..6226d90 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -89,16 +89,20 @@ fi
+
+ AC_ARG_ENABLE(unicode, [AC_HELP_STRING([--enable-unicode], [enable Unicode support])], ,enable_unicode="yes")
+ if test "x$enable_unicode" = xyes; then
+- AC_CHECK_LIB([ncursesw], [refresh], [], [
+- missing_libraries="$missing_libraries libncursesw"
+- AC_MSG_ERROR([You may want to use --disable-unicode or install libncursesw.])
++ PKG_CHECK_MODULES([NCURSES], [ncursesw],[
++ AC_CHECK_LIB([ncursesw], [refresh], [], [
++ missing_libraries="$missing_libraries libncursesw"
++ AC_MSG_ERROR([You may want to use --disable-unicode or install libncursesw.])
++ ])
++ AC_CHECK_HEADERS([ncursesw/curses.h],[:],
++ [AC_CHECK_HEADERS([ncurses/ncurses.h],[:],
++ [AC_CHECK_HEADERS([ncurses.h],[:],[missing_headers="$missing_headers $ac_header"])])])
+ ])
+- AC_CHECK_HEADERS([ncursesw/curses.h],[:],
+- [AC_CHECK_HEADERS([ncurses/ncurses.h],[:],
+- [AC_CHECK_HEADERS([ncurses.h],[:],[missing_headers="$missing_headers $ac_header"])])])
+ else
+- AC_CHECK_LIB([ncurses], [refresh], [], [missing_libraries="$missing_libraries libncurses"])
+- AC_CHECK_HEADERS([curses.h],[:],[missing_headers="$missing_headers $ac_header"])
++ PKG_CHECK_MODULES([NCURSES], [ncurses],[
++ AC_CHECK_LIB([ncurses], [refresh], [], [missing_libraries="$missing_libraries libncurses"])
++ AC_CHECK_HEADERS([curses.h],[:],[missing_headers="$missing_headers $ac_header"])
++ ])
+ fi
+
+ if test ! -z "$missing_libraries"; then