summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-03-23 09:53:46 +0000
committerIan Delaney <idella4@gentoo.org>2015-03-23 09:53:46 +0000
commit6f0ee2801d3c95a783a69024b070e0c41a604eee (patch)
tree5483753630b7937c7a3b27178d43538238457b7e /virtual
parentvirtual package for dealing with cffi builtin in pypy, ebuild made by NP-Hard... (diff)
downloadhistorical-6f0ee2801d3c95a783a69024b070e0c41a604eee.tar.gz
historical-6f0ee2801d3c95a783a69024b070e0c41a604eee.tar.bz2
historical-6f0ee2801d3c95a783a69024b070e0c41a604eee.zip
virtual package for dealing with cffi builtin in pypy, ebuild made by NP-Hardass and checked by myself and jlec
Package-Manager: portage-2.2.18/cvs/Linux x86_64 Manifest-Sign-Key: 0xB8072B0D
Diffstat (limited to 'virtual')
-rw-r--r--virtual/python-cffi/Manifest13
-rw-r--r--virtual/python-cffi/metadata.xml5
-rw-r--r--virtual/python-cffi/python-cffi-0.ebuild23
3 files changed, 40 insertions, 1 deletions
diff --git a/virtual/python-cffi/Manifest b/virtual/python-cffi/Manifest
index 997b4a0fdcd9..f5134f69e494 100644
--- a/virtual/python-cffi/Manifest
+++ b/virtual/python-cffi/Manifest
@@ -1,2 +1,13 @@
-EBUILD python-cffi-0.ebuild 425 SHA256 409c983e0a991afeb215b4f2040875dd32a0c85ba0302902eb542b26ae0b4b99 SHA512 a7dfe6dea724f3372873b08fc4aabe85e46cfa02fed1e9a6c16091e3a345ee59ae587bfad7538b836f2c129e5928e28018a064f67b3b953b7c2fa8381cf9a99c WHIRLPOOL 5f81e3a71da33ca4db05bd0d5b94ae094b58010732709293f6f91cbb0673006710f7ef0491d8379def8e8fd49d897caf436e38b8446a7df753d70a9ef6b374e1
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+EBUILD python-cffi-0.ebuild 528 SHA256 4c950531e836681516c21d3188f35aa6076526d59d6b1424d884cfebd3ceefe5 SHA512 b6b911b052446dbbbfc9963445d4edb2699b4b1c4d9971355bc7a82531c391e97ecc5a11925fbca9c0515c7031531256004d0f7b26071292c72f86d7a07a8d02 WHIRLPOOL ca2303629afe0a3523ebd38d1365943efa74c40abf360dee2293d2413b231f07824f9afdbdee74eb4a9bc95018ebae235ef0dcc34a6d7aff9f66f228e6135a84
+MISC ChangeLog 447 SHA256 43f27d60b7da247edb66adc02d93e347fce20e24c373f2e416660ebfa226ee47 SHA512 1cad8884a42d2b1503a80e401ecb647c76e5264947c63d0723b83a0beedca57f89467a80494f7ebaee9d8f29cabe38c81e0b3fa4aa91287c1c04d7566dcce890 WHIRLPOOL b28b701412f927ecb891482864eeb5fb1e1340eb81c98215aa53b16ef8ffa0d9811197ee5c68fa46a26c69ad714deaaa18b0cb9301fd1bf2d480147ab6df9ad1
MISC metadata.xml 160 SHA256 6cd954a9de2307c57d32b25fa3599dee2908a4ddc6a98594f593d53577307a3a SHA512 7c02a1de1ddcb6b7c6378cceff0458da3a15d5381417f7cdf01874e7c372664b8899863f41b3a2fd8d6ad67ceb732dac6da0cc17575bf8e3e6d89480417c6628 WHIRLPOOL ed2795e4466eda8c804d5067c87386e269a59fe959393057ca5ddc36851e00f5210c4da1adf4bbdfdbb7d1d3d5c60aced25727ca12fdc8305d9e263a3aca9b13
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iEYEAREIAAYFAlUP4p8ACgkQso7CE7gHKw1WOgCfY0aPKvcs5HFiR5y9CfTvZkE1
+ubQAnjhQAQSPlqBRYoHwQOrj0WYUkCfh
+=5jeK
+-----END PGP SIGNATURE-----
diff --git a/virtual/python-cffi/metadata.xml b/virtual/python-cffi/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/virtual/python-cffi/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/virtual/python-cffi/python-cffi-0.ebuild b/virtual/python-cffi/python-cffi-0.ebuild
new file mode 100644
index 000000000000..e6ad6a0f5681
--- /dev/null
+++ b/virtual/python-cffi/python-cffi-0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/python-cffi/python-cffi-0.ebuild,v 1.1 2015/03/23 09:53:15 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit python-r1
+
+DESCRIPTION="EDIT ME"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/cffi[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep 'virtual/pypy' pypy)"