summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2005-02-24 14:15:49 +0000
committerRoy Marples <uberlord@gentoo.org>2005-02-24 14:15:49 +0000
commit32e7c0ea35af9c62fbbc3673d97ef65e33842d71 (patch)
tree54c8402cd0fbcfe862511a6e60268b1cff69f348 /www-apps/websvn
parentinitial release, bug 74986. (diff)
downloadhistorical-32e7c0ea35af9c62fbbc3673d97ef65e33842d71.tar.gz
historical-32e7c0ea35af9c62fbbc3673d97ef65e33842d71.tar.bz2
historical-32e7c0ea35af9c62fbbc3673d97ef65e33842d71.zip
Initial import.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'www-apps/websvn')
-rw-r--r--www-apps/websvn/ChangeLog8
-rw-r--r--www-apps/websvn/Manifest4
-rw-r--r--www-apps/websvn/files/digest-websvn-1.611
-rw-r--r--www-apps/websvn/metadata.xml9
-rw-r--r--www-apps/websvn/websvn-1.61.ebuild55
5 files changed, 77 insertions, 0 deletions
diff --git a/www-apps/websvn/ChangeLog b/www-apps/websvn/ChangeLog
new file mode 100644
index 000000000000..31e5b6d71a7d
--- /dev/null
+++ b/www-apps/websvn/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for www-apps/websvn
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/websvn/ChangeLog,v 1.1 2005/02/24 14:15:49 uberlord Exp $
+
+*webapps/websvn-1.61 (24 Feb 2005)
+
+ 24 Feb 2005; Roy Marples <uberlord@gentoo.org> +websvn-1.61.ebuild:
+ Initial import.
diff --git a/www-apps/websvn/Manifest b/www-apps/websvn/Manifest
new file mode 100644
index 000000000000..1e13cbb3e2a5
--- /dev/null
+++ b/www-apps/websvn/Manifest
@@ -0,0 +1,4 @@
+MD5 6cdf2e3c224f3f9d79baefe34452cc96 websvn-1.61.ebuild 1308
+MD5 b6e79669f4bc75f09075fae8e34186d0 ChangeLog 329
+MD5 7999d6b6542ca3e8b7f9fb693fbbd016 metadata.xml 323
+MD5 6b1f00eaf678b8581924b0611c017839 files/digest-websvn-1.61 61
diff --git a/www-apps/websvn/files/digest-websvn-1.61 b/www-apps/websvn/files/digest-websvn-1.61
new file mode 100644
index 000000000000..9a1a0b280f50
--- /dev/null
+++ b/www-apps/websvn/files/digest-websvn-1.61
@@ -0,0 +1 @@
+MD5 9f81a3793d08bde2e425d2c98f923875 WebSVN_161.tar.gz 89305
diff --git a/www-apps/websvn/metadata.xml b/www-apps/websvn/metadata.xml
new file mode 100644
index 000000000000..e371223cbc24
--- /dev/null
+++ b/www-apps/websvn/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>uberlord@gentoo.org</email>
+ <name>Roy Marples</name>
+ </maintainer>
+ <longdescription>Web based Subversion repository browser written in PHP</longdescription>
+</pkgmetadata>
diff --git a/www-apps/websvn/websvn-1.61.ebuild b/www-apps/websvn/websvn-1.61.ebuild
new file mode 100644
index 000000000000..2b031a654eb7
--- /dev/null
+++ b/www-apps/websvn/websvn-1.61.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/websvn/websvn-1.61.ebuild,v 1.1 2005/02/24 14:15:49 uberlord Exp $
+
+inherit eutils webapp
+
+MY_PV=161
+DESCRIPTION="Web-based browsing tool for Subversion (SVN) repositories in PHP"
+HOMEPAGE="http://websvn.tirgris.org/"
+SRC_URI="http://websvn.tigris.org/files/documents/1380/14334/WebSVN_${MY_PV}.tar.gz"
+LICENSE="GPL-2"
+IUSE="enscript"
+KEYWORDS="~x86"
+
+RDEPEND=">=dev-php/mod_php-4.1.0
+ sys-apps/sed
+ enscript? ( >=app-text/enscript-1.6.0 )"
+DEPEND="sys-apps/findutils"
+
+S=${WORKDIR}/WebSVN
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ mv ${S}/include/distconfig.inc ${S}/include/config.inc
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local doc docs="changes.txt install.txt templates.txt"
+
+ dodoc ${docs}
+ for doc in ${docs}; do
+ rm -f ${doc}
+ done
+
+ # Remove .cvs* files and CVS directories
+ find -name .cvs\* -or \( -type d -name CVS -prune \) | xargs rm -rf
+
+ insinto ${MY_HTDOCSDIR}
+ doins -r *
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.inc
+
+ # This is the multiview config file
+ webapp_configfile ${MY_HTDOCSDIR}/wsvn.php
+
+ # The cache directory needs to be writeable
+ webapp_serverowned ${MY_HTDOCSDIR}/cache
+
+ webapp_src_install
+}